Kann ein Makro auch Inhalte eines Bereiches nach dem zählen löschen wenn das Ergebnis "falsch" ist?

Hallo liebe Excel Experten,

Ich möchte in Sachen Excel gern ein mal wieder eine Abkürzung durch ein Makro nehmen. Ich bin jedoch mit dieser Materie nicht vertraut!

Ich habe in einer Tabelle 10 Spalten und 1000 Zeilen ! in diesem Bereich stehen Werte, Werte die zuvor eine Formel war und ich dann kopiert und in Werte einfügen umgewandelt habe! Ich möchte nun die Duplikate in dieser Tabelle entfernen, aber !!!!!!

Es soll der Inhalt der ganzen Zeile gelöscht werden und nicht jedes einzelne Duplikat!

Manuell bearbeite ich das Ganze so: =ZÄHLENWENN($A$1:$J1;A2)

befindet sich ein Wert aus Zeile 2 in Zeile 1 dann lösche ich den Inhalt in Zeile 2 , dann berechne ich neu !

befindet sich kein Wert in Zeile 1 dann berechne ich Zeile 3 , =ZÄHLENWENN($A$1:$J2;A3)

also mit jeder Zeile nach unten erweitert sich oben der Zählenwenn Bereich um eine Zeile nach unten

WARUM nach jedem löschen neu berechnen? Ganz wichtig !!!!!

befindet sich beispielsweise in Zeile 200 ein Wert der sich in Zeile 100 befindet könnte ich Zeile 200 löschen, aber nun befindet sich ein Wert in Zeile 100 der sich in Zeile $A$1:$J99 befindet dann lösche ich Zeile 100 ja zuerst und durch die Neuberechnung befindet sich nun kein Duplikat mehr in Zeile 200! deshalb kann ich auch nicht alles auf einmal berechnen, sondern Zeile für Zeile,

vielleicht kann mir ja in diesem fall helfen , vielen Dank im voraus!

Excel, makro, VBA, Formeln Excel
Excel Wiederholungen zählen. Welche Suchkriterien?

Hallo ihr Lieben, bitte um Hilfe. Habe bereits intensiv danach gegoogelt und habe jetzt einen Knoten im Hirn.

Die Situation ist folgende: ich überprüfe Datensätze auf Fehler und trage hierfür diese händisch ein (richtige und fehlerhafte). (Bitte fragt nicht wie und warum. Es geht dabei eher darum Excel zu lernen.) Die fehlerhaften Datensätze werden dann überarbeitet und als neue Zeile weiter unten nochmal eingetragen. Hierfür wollte ich mitzählen lassen, welche Datensätze wie oft wiederholt werden mussten, bis sie richtig sind. In einer weiteren Spalte lasse ich bereits automatisch das aktuelle Datum (Kontrolldatum) einfügen. Mein weiterer Versuch ist eine zählenwenn-Funktion mit dynamischem Ende (index(anzahl2)) als Bezugsbereich. Ich weiß aber nicht wie die Suchkriterien aussehen sollen.

Des Weiteren würde mir die  zählenwenn-funktion die älteren Einträge überschreiben. Die hätte ich aber gern beibehalten.

Also es sollte so aussehen:

fehlerhafter Datensatz abc - Kontrolldatum (autom) - Wiederholung 0
fehlerhafter Datensatz abc - Kontrolldatum (autom) - Wiederholung 1
jetzt richtiger Datensatz abc - Kontrolldatum (autom) - Wiederholung 2

Zwischen den fehlerhaften Datensätzen sind dann noch einige richtige eingetragen.

Meine Formel =ZÄHLENWENN($B$3:INDEX($B:$B;ANZAHL2($B:$B));"="&$B4)
hilft mir da nur nicht.

Die Wiederholungen werden dann mit jedem weiteren Eintrag automatisch angepasst, wegen dem dynamischen Ende. Das passt aber so.

Könnte mir da jemand helfen, ohne dass ich VPA benützen muss?

Vielen Dank

Grizzly1703

Computer, Excel

Meistgelesene Fragen zum Thema Excel