Wie bekomme ich eine leere Zelle statt einem #NV?

5 Antworten

Schreibe mal die konkrete Formel hin, dann kann man Fehler auch konkret überprüfen, ansonsten sieht sie soweit richtig aus.

Man kann es auch einfacher mit

=WENNFEHLER(Sverweisformel;"")

bilden. Neuere Excelversionen (ab 2013) untersützen auch WENNNV, was nur bei dieser Fehlerart greift.

ISTNV geht, ist aber umständlich. Die von dir angegebene Syntax ist korrekt. Du musst dich mit irgendeinem Semikolon oder einer Klammer vertan haben.

Einfacher, aber leider universell einsetzbar ist die Funktion WENNFEHLER:

=WENNFEHLER(SVERWEIS(...);"")

Hallo,

Dir fehlt der Eintrag im Suchkriterium.

Angenommen Formel in E2 wäre: =SVERWEIS(D2;B2:C5;2)

Würde als Beispiel bedeuten (Suchkriterium ist D2; Matrix B2:C5, ist die Datenbank; Spaltenindex 2, ist die Ausgabe aus Spalte C), dass wenn Du in D2 keinen Eintrag für Deine Abfrage hast der Fehler #NV erscheint.

Mit folgender Formel lässt sich die Fehlermeldung eleminieren.

=WENN(D2="";"";SVERWEIS(D2;B2:C5;2))

Oder Du verwendest die bereits angebotenen Lösungen.

Gruß Tron

Was möchtest Du wissen?