Excel VBA, Sowie Sverweis abfrage wie mach ich das?

 Public Function Startmakro() As String


   Call Makro1       Startmakro = "Gestartet."

      End Function Sub Anzeige()

 MsgBox "Makro wurde gestartet"

   End Sub

Sub Makro1()

Dim i As Integer Dim rngFoundCell As Range Dim rngBereich As Range

For i = 0 To 100 '100 anpassen
  Set rngBereich = Sheets("Oktober").Range(Cells(i * 7 + 5, 4), Cells(i * 7 + 11, 4))
  Debug.Print rngBereich.Address
   Set rngFoundCell = rngBereich.Find(What:="test")
   If Not rngFoundCell Is Nothing Then
    rngBereich.Select
    With Selection
     .HorizontalAlignment = xlCenter
     .VerticalAlignment = xlCenter
     .WrapText = False
     .Orientation = 0
     .AddIndent = False
     .IndentLevel = 0
     .ShrinkToFit = False
     .ReadingOrder = xlContext
     .MergeCells = True
    End With
   End If
Next i
End Sub

Folgendes würde ich gern ändern, ich würde gerne mehrere Suchkriterien haben nicht nur für test sondern für test1, test2, test3 usw...

Desweiteren würde ich gerne mit einem Sverweis eine Tabelle abfragen wo Feiertage eingetragen sind und sobald dort ein Datum übereinstimmt würde ich gerne wollen das er bestimmte Zellen formatiert und denn Text dort einträgt, dh. Zelle A Datums werte, Zelle B leere Zellen die wenn Feiertage drauffallen dort eingetragen werden sollen sollte aber kein Feiertag sein soll diese leer bleiben das man dort eintragungen vornehmen kann.

Wie mach ich das am besten?

Danke für jede Hilfe

Computer, Excel, programmieren, VBA, schwer, Sverweis, wenn-Funktion
2 Antworten
Excel-Vergleich: 2x2 Spalten miteinander vergleichen und den Inhalt einer fünften Spalte ausgeben?

Hallo zusammen,

Ich möchte die Routen-ID (A) und die dazugehörige Sender Location (B) aus Reiter 1 mit der Routen-ID (C) und der Sender Location (D) aus Reiter 2 vergleichen. Bei Übereinstimmung möchte ich die dazugehörige Distance in km aus (E) in einer Spalte (F) ausgeben.

Excel Reiter 1: Daten

  Routen-ID (A)             Sender Location (B)

1 DE24DE40                 Remscheid

2 DE25DE40                  Alsdorf

3 …

 Excel Reiter 2: Routen-Distanz

  Routen-ID (C)               Sender Location (D)                   Distance in km (E)

1 DE24DE40                   Remscheid                                               32,2

2 DE25DE40                    Alsdorf                                                     85,4

3 …

Bei einem Vergleich ohne die Sender Location zu berücksichtigen habe ich es folgendermaßen gelöst:

=WENN(ISTNV(VERGLEICH(A1;'Routen-Distanz'!C:C;));"";INDEX('Routen-Distanz'!E:E;VERGLEICH(Daten!A1;'Routen-Distanz'!C:C;)))

Die Sender Location ist notwendig, da eine bestimmte Routen-ID mehrere Sender Location haben kann und somit andere Distanzen zu berücksichtigen sind. Zur eindeutigen Zuordnung muss daher ein weiteres Merkmal, in dem Fall die Routen-ID hinzugezogen werden.

 (F)

=?

Ich freue mich über eure Antworten.

VG

Computer, Excel, Vergleich, excel-formel, Excel Funktion, Sverweis, Spalten vergleichen, Excel SVerweis
3 Antworten
Excel Programmieren Index und Vergleichsfunktion?

Hallo zusammen,

folgende Situation: Ich habe 2 Tabellen. In einer sind in einer Spalte Namen und in der anderen Fähigkeiten aufgelistet. In der anderen Tabelle sind in der ersten Spalte die Namen aufgelistet und in den anderen Spalten die Fähigkeiten. Nun will ich einen Code schreiben, welche aus der ersten Tabelle die Fähigkeiten liest und in der zweiten Tabelle in der entsprechenden Zeile und Spalte ein "x" macht, sodass man am Schluss sieht, welche Person welche Fähigkeiten hat.

Mein Problem: in der ersten Tabelle stehen einige Namen mehrfach mit unterschiedlichen Fähigkeiten. Ich habe eine Formel aus Wenn, Index und Vergleich geschrieben, welche die Werte auslesen soll. Jedoch stoppt diese logischerweise beim ersten Treffer und vernachlässigt somit einige Fähigkeiten von Personen.

Ich brauche also einen Vergleichs-Formel, welche nicht nach dem ersten Treffer stoppt, sondern weiter sucht. Oder einen Befehl, welche die Formel weiter suchen lässt.

Da ich die Formel nicht da habe kann ich sie auch nicht posten. Diese Tabellen sind nur Beispiele. In echt schaut das Problem so ähnlich aus, da ich das Problem aber in der Arbeit habe, kann ich hier keine Tabellen von dort posten.

Die Formel arbeite im moment folgendermaßen: Sie vergleicht den Namen aus Tabelle 2 mit den Namen aus Tabelle 1 und schaut dann welche Fähigkeit die Person hat. Wenn die Fähigkeit der Person mit der Fähigkeit in der Spalte in Tabelle 2 übereinstimmt macht sie ein "x".

Vielen Dank für Eure Hilfe im Voraus!

Grüße

Fighter 25253

Excel, Vergleich, programmieren, Formel, Index, Sverweis
2 Antworten
Excel soll Automatisch Text ausfüllen wenn eine Zahl angegeben wird?

Hallo

Ich bekomme eine Liste mit Zahlen und muss diese dann in Excel eintragen, bzw. Raussuchen welches Wort zu welcher Zahl passt und dann das noch eingeben. Excel soll dann anhand der von mir angegeben Zahl in einerm anderen einen Passenden Text hinsetzten. Wenn aber nichts da steht soll da nicht WERT oder NAME oder so stehen sondern es soll leer bleiben.

Beispiel Ich bekomme die Liste Name | Datum | Objekt

Das Objekt ist nur eine Zahl

Hans | 1.6.16 | 5

Excel soll mir dann neben der Zahl das Objekt in Worte fassen

Hans | 1.6.16 | 5 | Garten

Wenn dann aber bei der Objekt Zahl noch kein Wert drin steht soll da auch nichts stehen. Auch kein Fehler.

Zudem möchte ich die Formel eingeben können und einmal nach unten ziehen und nicht jedesmal alles eingeben müssen.

Ich habe alle Werte in der Selben Arbeitsmappe in Tabelle 2 eingegeben. In Tabelle 1 Arbeite ich.

Tabelle 2 sieht in etwa so aus

1 | Wohnung 2 | Haus 3 | Platz 4 | Abstellraum 5 | Garten

Habe dann versucht das ganze mit sverweis zu lösen.

=SVERWEIS(B1;Tabelle2!A1:B16;2)

Sprich Wenn in B1 eine Zahl steht; Aus Tabelle 2 A1-B16; in der zweiten spalte dann soll er das Wort dahinter nehmen.

Klappt soweit ziemlich gut, nur Probelem sind trotzdem da.

  1. Wenn noch Kein Wert (Zahl) in Tabelle 1 steht dann steht da #NV Wie bekomme ich das Weg?

  2. Ich kann die Formel nicht runter ziehen sonst werden alle Werte geändert

=SVERWEIS(B1;Tabelle2!A1:B16;2) =SVERWEIS(B2;Tabelle2!A2:B16;3) =SVERWEIS(B3;Tabelle2!A3:B16;4)

jedoch sollte es beim runterziehen der Formel so aussehen:

=SVERWEIS(B1;Tabelle2!A1:B16;2) =SVERWEIS(B2;Tabelle2!A1:B16;2) =SVERWEIS(B3;Tabelle2!A1:B16;2)

Weil die Matrix (A1:B16) bleibt ja die selbe.

Bin dankbar über jeden Rat. Es muss nicht mit sverweis gelöst sein. Jedoch suchen und ersetzen ist auch keine Option, da es zum einen mehr aufwand ist und zum anderen benötige ich ja die Zahl und das dazugehörige Wort.. Geht aber auch nicht immer.

Danke euch Gruss Grischabock

Excel, Zahlen, ersetzen, automatisch, Formel, Wort, Sverweis, wenn, Durch
2 Antworten
Excel SUMMEWENNS nach Inhalt einer Zelle suchen lassen?

Guten Tag,

ich versuche momentan verzeweifelt folgendes mit Excel:

Es gibt eine Übersichtsdatei in der unter Anderem Angaben zu Projektnummer+Bezeichnung, Namen und Stunden gibt.

Projektnummer - Name - Stunden

Nun habe ich einem anderen Tabellenblatt eine Auswertungsübersicht geschaffen, in der jetzt folgendes ausgewertet werden soll:

In der Zelle E3 trage ich die Projektnummer ein (z. B. 4-15-160), nun will ich mit der SUMMEWENNS Funktion in der vorgenannten Tabelle auf Blatt 1 eine Suche auslösen, die mir die Stunden angibt, wenn die Projektnummer aus E4 und der Name, den ich auch in der Auswertung angebe. Dies klappt soweit auch. Jedoch habe ich das Problem, dass die Projektnummer die ich in der Auswertung eingebe, jediglich die Nummer ist. In der Tabelle auf Blatt 1 steht hier auch noch eine Bezeichnung bei, also z. B. [4-15-160] Test, ABCDE.

Nun soll die SUMMEWENNS also schauen, ob die Projektnummer in der Projektbezeichnung enthalten ist und mir anhand dessen die Auswertung geben, sodass ich nicht die genaue Projektbezeichnung eingeben muss.

Es müsste also geschaut werden, ob z. B. "4-15-160" in der Matrix enthalten ist.

Folgend die derzeitige Funktion. (SHEET ist das erste Blatt; Spalte D der Name, Spalte I die Projektnummer+Bezeichnung und Spalte V die Stunden)

=SUMMEWENNS(Sheet!$V$8:$V$999;Sheet!$I$8:$I$999;INDEX(Sheet!I8:I999;VERGLEICH(E3;Sheet!I8:I999;0);Sheet!I8:I9999);Sheet!$D$8:$D$999;B9)

Ich danke Euch vielmals im Voraus!!!

Excel, Sverweis
2 Antworten
wie kann ich mit SVERWEIS ungeordnete werte zuweisen?

es geht um das zuordnen von Bildernamen zu Sitzplatznummern, die sich unterscheiden (wobei die Sitzplatzbezeichnung gleich ist)

Ich habe 2 Tabellen in einem Dokument in OpenOffice Calc

Spalten in Tabelle 1:

  • A Sitzplatznummer (irrelevant)
  • B Sektion Sitzplatz (z.B. "PM_C")
  • C Beschreibung Sektion (irrelevant)
  • D Reihe (z.B. "4")
  • E Sitzplatz (z.B. "34")
  • F Bildname (z.B. "img_0004.jpg" - ein Bildname gilt für mehrere Sitzplätze, kommt also in mehreren Zeilen vor)
  • G Sitzplatzname, zusammengeschustert aus B, D und E (z.B. "PM_C+4+34")
  • H genauso wie F

da in Tabelle 2 die Sitzplatznummern für die gleichen Plätze anders sind (also auch in anderen Zeilen stehen) möchte ich es über die zusammengeschusterte Spalte G aus Tabelle 1 abgleichen. Diesen Plätzen sollen also die Bildnamen aus Spalte H (bzw. F) zugewiesen werden.

relevante Spalten aus Tabelle 2:

  • F (noch leer) - hier soll der Bildname zugeordnet werden
  • G zusammengeschusterter Name (z.B. "PM_C+4+34")

die zusammengeschusterten Namen sind eineindeutig

ich habe es über den SVERWEIS Befehl versucht, jedoch kommen immer wieder Fehler (ab dem ersten anders sortierten Platz wird unbegreiflich Bild 0001 genommen, wenige Zeilen später wird wieder korrekt zugeordnet).

meine Eingabe für Tabelle 2, Spalte F: "=SVERWEIS(G1; Tabelle1.$G$1:$H$2200; 2; 1)" nach unten in der Spalte vervollständigt

da ich sonst nie mit calc oder Excel arbeite, hab ich keinen Plan, wo hier der Fehler liegt. Auch verstehe ich die letzten beiden Eingaben von SVERWEIS nicht so richtig.

Bin für jede brauchbare Hilfe dankbar

Office, Excel, OpenOffice, Calc, Sverweis
2 Antworten
Wieso erkennt Excel meine Formel nicht?

Ich habe folgende Formel eingegeben:

=WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 Januar.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ");WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 Februar.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 März.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 April.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 Mai.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 Juni.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 Juli.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 August.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 September.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 Oktober.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 November.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 Dezember.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ");" "))))))))))))))))))))))

und bekomme die Fehlermeldung, die mich fragt, ob ich überhaupt eine Formel eingeben will.

Any suggestions?

Excel, Sverweis
2 Antworten

Meistgelesene Fragen zum Thema Sverweis

Excel soll mir mehrere Ergebnisse zu einen Suchkriterium ausgeben?

3 Antworten

Excelformel SVerweis kann ich nicht runterziehen, warum?

3 Antworten

Zwei Tabellen abgleichen? SVerweis?

3 Antworten

Excel Zählen wenn Wert übereinstimmt

2 Antworten

Wie kann man zwei Excel Tabellen vergleichen und die Abweichung ausgeben?

1 Antwort

s-verweis formel funktioniert erst nach doppelklick?

5 Antworten

Excel: Mit SVerweis nicht nur die Werte, sondern auch die Hintergrundfarben auslesen?

2 Antworten

sverweis - tabellenübergreifend

3 Antworten

Excel: ein Bereich als Suchkriterium (SVERWEIS)

5 Antworten

Sverweis - Neue und gute Antworten