EXCEL Funktionien funktionieren nicht wie gewünscht?

3 Antworten

Welche Formatierung haben denn deine Postleitzahlen? Standard?

Ansonsten kannst du ganz schnell ein Apostroph mit dem Verketten-Befehl vor die Postleitzahl stellen und die Werte(!) in eine neue Spalte kopieren.

Vielen Dank für die Antwort. Könntest du mir eventuell ein Beispiel für diese Funktion geben? Ich habe die noch nie verwendet. :/

1

Bei mir geht es genau so:

=SVERWEIS(B5;PLZ!$A$1:$B$59215;2)

Ich schätze, du hast deine Eingabezelle (B5) nicht als Zahl formatiert. Excel sucht in der Liste wohl nach einem Text.

Ich würde Postleitzahlen als Text abspeichern, da mit ihnen nicht gerechnet wird.

Vielen Dank für deine Antwort. Ich habe nun die Zellen formatiert, aber dennoch erfolglos... sobald ich ein Apostroph davor setze funktioniert es..

1
@Suboptimierer

@Suboptimierer ja alle von 01067 Dresden bis 99998 Weinbergen

1

zudem ist Excel etwas anstrengend wenn Zahlenfolgen mit führenden Nullen beginnen.
Zwar lässt sich das über die Formatierung lösen, sowas verschwindet beim Kopieren usw aber gern mal.
Bei Text ist es eineindeutig.

3

Da fehlt der vierte Parameter:

=SVERWEIS(B5;PLZ!$A$1:$B$59215;2;0)

Sonst wird bei nicht-finden etwas falsches angezeigt.

4
@Oubyi, UserMod Light

@Oubyi hat leider dennoch nicht funktioniert.. alle Formatierungen verändert und haste nicht gesehen... immer nur mit dem Apostroph am Anfang funktioniert es..

0

Ich denke mal, die Postleitzahlen in Deiner Liste sind als Text formatiert, was so auch richtig ist und sein muss.
Du musst daher B5 auch als Text formatieren (das Apostroph tut das händisch), dann sollte es klappen.

Woher ich das weiß:Beruf – IT-Administrator (i.R.)

Leider funktioniert das nicht.. habe jetzt alle Zeilen als Text formatiert aber dennoch macht er das nicht. Kann es an einer ältere Tabellen Version liegen?

1
@Ruyukolo

Nein.
Wenn Dir sonst nicht geholfen werden kann, lade mal Beispieltabellen hoch oder zeige zumindest Screenshots.
Wie lautet denn Deine Formel ganau?

0
@Ruyukolo

Da hatte ich jetzt aber auch zu kämpfen.

Mache mal Folgendes:

Lösche Test!A5:A7 (also die Suchfelder)

Markiere die komplette Spalte A im Blatt PLZ.

Neben der aktiven Zelle siehst Du ein Quadrat, das auf der Spitze steht und in dem ein Ausrufezeichen ist. Klick da drauf.

Klick in dem Kontextmenü auf "Fehler ignorieren".

Wenn Du jetzt in die Suchfelder, also in Text!A5:A7 (bleiben als Text formatiert) etwas eingibst, sollte es klappen. Oder?

Frage mich aber bitte nicht warum. Ich habe da auch nur rumprobiert. Das ist auf jeden Fall eine "Macke" von Excel.

1
@Oubyi, UserMod Light

Ouh vielen Dank! - Ich wusste doch das es nicht an mir lag! :P Ich danke vielmals das du dir die Mühe gemacht hast.

1

Was möchtest Du wissen?