SVERWEIS oder WENN-Funktion?

... komplette Frage anzeigen

1 Antwort

Falls Du bei der Wenn-Formel bleiben will, dann fang mit der größten Zahl an, dass spart einiges an Logik ein, weil die zu erst gefundene gültige Bedingungen genommen wird. Du musst nicht mit < als x und > als y arbeiten.

=WENN(A2>15000;A2*0,06;WENN(A2>12000;A2*0,05;WENN(A2>10000;A2*0,05;WENN(A2<5000;A2*0))))

Der Betrag steht im Beispiel in A2 - ich habe nicht alle Varianten abgebildet, daher gibt es noch Lücken.

Alternativ und vermutlich einfacher per VERWEIS (der löst gefühlt ein Drittel der auf GF gestellten Probleme mit Excel)

=A2*VERWEIS(A2;{1;5000;6000;7500;9000;10000;12000;15000};{0;0,02;0,03;0,04;0,045;0,05;0,055;0,06})

Hier aber wieder unbedingt aufsteigend die Beträge und zusätzlich noch die Untergrenze für die es nichts gibt. Ich hab hier 1 eingesetzt.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Jackie251
12.12.2015, 10:40

gut gemacht Ninombre

0

Was möchtest Du wissen?