Excel Feiertage SVerweis?

3 Antworten

Das erscheint mir zwar eine eher fragwürdige vorgehendweise, weil man eine komplette Spalte dafür opfert, anzuzeigen ob es sich um einen Feiertag handel...

aber funktionieren wird es, das Problem das du dir jedoch eingebaut hat, ist das der in Spalte 1 deiner Feiertagsübersicht der Name des Feiertags steht - Sverweis sucht in der 1. Spalte jedoch den Suchwert.
Du kannst nun entweder deiner Spaltenanordnung ändern oder mit Index arbeiten:

=WENNNV(INDEX(FTAGE!$A$3:$A$16;VERGLEICH(A5;FTAGE!$B$3:$B$16;0););"")

DH!, da bist du mir zuvorgekommen, aber genauso!

Nur: seit wann gibts WennNV(...;...) ? ich muss da in xl2010 noch mit Wennfehler(...;...) arbeiten!

2
@Iamiam

@Burak
Der SVERWEIS funktioniert hier deswegen nicht, weil er den Suchwert (in diesem Fall das Datum) immer nur in der linken Spalte eines Bereichs sucht. In deiner FTAGE-Tabelle steht das Datum rechts von der Bezeichnung. U.a. deswegen hat Jackie es mit INDEX(VERGLEICH) gelöst. Diese Kombination kann den SVERWEIS vollständig ersetzen und ist flexibler.

PS. Sehe gerade, das hat Jackie auch schon erklärt.

@Iamiam
Irgendwie kommen bei jeder Version ein paar neue - mehr oder weniger sinnvolle - Funktionen dazu. Langsam verliert man den Überblick, was in welcher Version vorhanden ist.

1

@Jackie

Ich habe mir extra diese Spalte mehr angelegt, um da den Namen des Feiertags anzeigen zu lassen (Oder gibt es da etwas unkomplizierteres?). Zudem werden die Feiertage durch eine bedingte Formatierung farbig hervorgehoben.

Vielen Dank, endlich funktioniert es! War echt am verzweifeln. Naja, bevor ich jetzt die Spaltenanordnung ändere, mache ich es mit INDEX, wie du es beschrieben hast. Sollte ja keine Nachteile mit dieser Formel geben oder?

@Lamiam & @DeeDee

Danke auch euch beiden!

0

Ich habe jetzt erst gesehen, dass die Frage aus dem dynamischen Kalender hier quasi noch weitergeht. Du musst nicht unbedingt eine eigene Spalte für die Anzeige der Feiertage nehmen. Mein Kommentar bezog sich darauf, dass es nicht in dem normalerweise freien Feld stehen sollte, in das sonstige Inhalte eingetragen wird.

Du könntest die Feiertage bspw. bei Wochentag anzeigen lassen. Formel von britzcontrol mit index oder nach Umsortieren der Feiertage (also erst Datum, dann den Namen des Feiertags) mit sverweis:

=TEXT(A5;"TTT")&" "&WENNFEHLER(SVERWEIS(A5;G:H;2;FALSCH);"")
Das liefert bei normalen Tagen einfach weiterhin Mo, Di, Mi etc. und wenn über den sverweis oder index was gefunden wird, zusätzlich den Namen des Feiertags.

Die sverweis Formel musst Du entsprechend ersetzen, die passt nur für mein Beispiel

Danke dir. Werde ich morgen gleich mal testen. =)

0

Jackies Lösung funzt bei mir (XL2007) nicht, aber ...

=WENNFEHLER(INDEX(FTAGE!$A$3:$A$14;VERGLEICH(A5;FTAGE!$B$3:$B$14;0));"")

Mach was draus.

Gruß aus Berlin

KalenderFTag - (Excel, Sverweis)

Danke Britzcontrol.

Bei mir funktioniert es, so wie du beschrieben hast. Aber auch Jackies Lösung funktioniert bei mir. (XL2013)

0

Was möchtest Du wissen?