Switch bekommt über DHCP keine IP Adresse zugewiesen?

6 Antworten

Nun, der Netgear JGS524Ev2 ist ein sog. Managed-Switch, welcher auch eine Weboberfläche hat und somit auch eine IP im Netzwerk erhalten kann/soll.

Sofern der Switch sich keine automatische IP vom DHCP holt ist er etwa nicht so eingestellt, dass er das tut, oder der DHCP-Server auf dem Router ist nicht aktiviert. Natürlich kannst du dem Switch auch einfach eine statische IP verpassen, was ich bei derartigen Komponenten immer tun würde. Diese muss dann aber außerhalb des DHCP-Bereiches sein, aber noch innerhalb des IP-Bereiches deines Netzwerkes. So verwenden die meisten Router immer eine 24er-Netzmaske und einen IP-Bereich 192.168.X.0, wobei das X dabei eine Zahl ist, welche je nach Routerhersteller und Modell variieren kann. So ist es bei AVMs FRITZ!Boxen z.B. immer die 178, also 192.168.178.0/24. Eine FRITZ!Box vergibt zum Beispiel die Adressen 192.168.178.20 - 192.168.178.200 via DHCP, weswegen du dem Switch einfach eine IP von 192.168.178.2 - 20 oder von 201 - 254 vergeben kannst.

Also, das Problem ist, wenn ich ihm eine IP zuweise über das Netzwerk, steht trotzdem in der Netzwerk Oberfläche drinnen das er Offline und nicht connected ist!            
          
Meine Einstellungen im Router sehen so aus:
Router IP: 192.168.0.1        
Subbetzmask: 255.255.255.0

DHCP:
IP Start: 192.168.0.100
IP Ende: 192.168.0.254
lease Time: 3600
Domänenname:            
            
Außerdem ist RoutedwithNat
        
        
Dem Switch ist die IP: 192.168.0.2 zugewiesen!

Somit sollte alles richtig sein!

0
@Hairgott

Netzwerkeinstellungen sollten soweit passen. 

Ist vielleicht der Switchport auf dem der Uplink zum Router steckt deaktiviert? 

Vielleicht aus Versehen ein Crossover Kabel benutzt?

Kannst du den Switch so konfigurieren dass er vom DHCP Server eine Adresse bekommt? Falls das geht solltest du ja dann in der Router Übersicht die DHCP Geräte sehen....

0
@blackfades2grey

Nein. ist kein Crossover-kabel. Ist eins für Switch geeignetes 0.25  meter kabel. Also kanns an der Länge auch nicht liegen!

Ja, kann ich machen. Aber dann bekommt er keine IP bzw. empfängt keine vom Router. Da steht dann immer bei IP: 0.0.0.0

Und bei der Routerübersicht steht auch kein Switch.

0

Für alle die das gleiche Problem haben:

Der Switch will einfach nicht.
habe es die Jahre immer wieder probiert.

in anderen Netzen geht er ohne Probleme. Bei mir und 2 Freunden gehts dann aber nicht.
Könnt an den Routern liegen (waren von Liwest zur Verfügung gestellt)

ein Anderer Switch hat das Problem gelöst.

Bevor wir uns hier an die Problemlösung (bzw. zuerst an die Suche der Ursache) machen, eine einfache Frage:

Wozu brauchst du am Switch eine IP-Adresse?

Für das Switchen brauchst du die nämlich nicht. Der Funktioniert wunderbar und du wirst alle Zugänge zu Internet und anderen Geräten in deinem Netzwerk erhalten, wo wie du das wünschst! Du kannst also getrost darauf verzichten, dem Switch eine IP-Adresse zu geben :-))

Hmm, okay. Dann ist mein Problem das der Switch falsche oder gar keine IP adressen verteilt...

0
@Hairgott

Der Switch verteilt doch keine Adressen! Oder hast du ihn als DHCP-Server konfiguriert? Das darf dann natürlich gar nicht sein, denn in einem Subnetz darf es immer nur einen einzigen DHCP-Server geben und das ist richtigerweise dein Internet-Router.

1
@suessf

Warte, sorry hab mich falsch ausgedrückt. Ist nicht als Server konfiguriert.

Also. Wenn ich mein PC an den switch hänge, steht unter Netzwerkeigenschaften am PC immer Kein Internet und nicht identifiziertes Netzwerk. 

Die Ip ist dann eine 169.254.xxx.xxx Ip obwohl meine DHCP zuweisung eigentlich nur 192.168.x.xxx zuweisen sollte. 

wenn ich mit den Befehlen ipconfig /release und /renew eine neue IP über den DHCP server holen will, steht da immer das das nicht funktioniert hat! Und hab dann gar keine IP mehr. 

0
@Hairgott

Eine IP-Adresse von 169.254.x.y heisst schlicht und einfach, dass dein Computer keinen DHCP-Server finden konnte. Wir haben wohl irgendwo ein Problem mit der Verbindung. Schauen wir uns das also mal der Reihe nach an:

Wie ist dein Switch an den Router angehängt? Leuchten die zugehörigen Led-Lämpchen am Switch und am Router?

Kann es sein, dass du irgendwo ein defektes Kabel hast -> einfach mal tauschen (kannst dir sicher eines mal von einem Kollegen oder Nachbar ausleihen, bevor du dir gleich ein Neues kaufst.

1

was hält dich davon ab, das Handbuch oder die Installationsanleitung zu nutzen ?

http://downloadcenter.netgear.com/de/product/JGS524Ev2#searchResults

für spezielle Probleme kann man dann gerne gemeinsam eine Lösung suchen.....

aber Standard-Sachen wie z.B: "...configure a switch that is not connected to a network...." solltest schon selbst hinbekommen ;)

das ist ja gleich am Anfang des Handbuchs beschrieben ..... Static-P am Rechner und die "Service"-IP des Switch aufrufen.......

0

Also, es ist so. Das Handbuch hab ich schon 3,5 Millionen mal durchgelesen und es klappt nicht!        
          
Also den Switch zu Konfigurieren ohne ein Netzwerk zu nutzen hab ich gemacht, wenn man ihn dann aber aber ans Netzwerk anschließt steht da immer Kein Internet!                
Mit Netzwerk habe ich ihn auch schon konfiguriert. Nur da ist das Problem das er wie schon erwähn nicht im Netzwerk gefunden wird...    
        

0
@Hairgott

könntest du das vielleicht so beschreiben, das man auch versteht was du gemacht hast ? ;)

"es klappt nicht" usw. helfen nicht dein Problem zu erkennen, nur du sitzt vor deinen Geräten, also beschreibe es so, das man es auch versteht wenn man nicht davorsitzt ;)

nach deiner "wirren" Beschreibung entnehme ich nur, das du etwas falsch konfiguriert hast....... also zurück auf Werkseinstellungen und neu einrichten

dir ist aber schon bewußt bzw. hast du das sicher auch schon gelesen (nach 3,5 Mio mal), das sich der Switch automatisch verbindet, wenn im Netz ein DHCP-Server läuft ;)

1
@netzy

Jap is mir alles klar. ALso mein Computer empfängt wenn er am Switch hängt keine IP adresse die gültig ist. 

Der switch verbindet sich aber nicht automatisch mit dem DHCP server. Er macht  es nicht und gibt sich selbst dann die IP 192.168.0.239. Wenn man dann auf dem Switch auf DHCP geht und es aktiviert, wird dem Switch keine IP zugewiesen.

0

Ein Switch braucht keine IP-Adresse. Ein normaler Switch weiß nichtmal, was eine IP-Adresse ist.

Ist ein Managable Switch. Der weiß was das ist.

0

Was möchtest Du wissen?