Wie kann ich Zellen mit bestimmten Inhalten von Excel addieren lassen?

 - (Computer, Informatik, Excel)

8 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Formel in E3: {=SUMME(WENN(ISTFEHLER(FINDEN(D3;B3:B8));0;LINKS(B3:B8;FINDEN(" ";B3:B8))*1))}

Formel in E4: {=SUMME(WENN(ISTFEHLER(FINDEN(D4;B3:B8));0;LINKS(B3:B8;FINDEN(" ";B3:B8))*1))}

Achtung Arrayformeln: Die geschweiften Klammern nicht mit eingeben sondern durch Abschließen der Formel Strg+Shift+Enter erzeugen.

 - (Computer, Informatik, Excel)

PS: Alternativ kannst du auch die Zellen D3 und D4 weglassen und direkt schreiben:

{=SUMME(WENN(ISTFEHLER(FINDEN("Cola";B3:B8));0;LINKS(B3:B8;FINDEN(" ";B3:B8))*1))&" Cola"}

bzw.

{=SUMME(WENN(ISTFEHLER(FINDEN("Bier";B3:B8));0;LINKS(B3:B8;FINDEN(" ";B3:B8))*1)) & " Bier"}

1
@augsburgchris

Ich bleibe gleich beim ersten Vorschlag, der ist am komfortabelsten.

0

Top! das richtet sich nach dem ERSTEN Leerzeichen und müsste auch 12 Cola light oder 2 Kröver Nacktarsch Jahrgang 1995 akzeptieren

0

Die Ziffern müssen in eine eigene Spalte geschrieben werden. Dann geht das einfach.

Sagen wir mal, du hast die Zahlen in der A-Spalte von A1 bis A13 und möchtest die Summe in B1 verankern. Dann schreibst du in B1: =SUMME(A1:A13) und schon hast du dort die Summe aller Zahlen von A1 bis A13.

Kannst in der B-Spalte auch die Getränkenamen reinschreiben und die Summe dann in C1 (oder sonst in eine Spalte) summierne lassen - die Formel bleibt die Gleiche.

ja, ich weiss, aber das darf ich nicht.

0
@eddiepoole

Was darfst du nicht? Die Zahlen und die Wörter in verschiedene Spalten eintragen? Musst du aber, sonst geht es nicht.

0
@SarahSchweiz

da kann ich mich leider keinen millimeter bewegen. ich muss eine andere lösung finden. vllt gibt es ja eine funktion. zählenwenn führt nicht zum ziel, weil dann für jede zelle 1 addiert wird ungeachtet der zahlenwerte. aber bestimmt gibt es noch was anderes.

0
@eddiepoole

Dann wirst du das ohne Excel tun müssen. Dort geht das nicht. Wieso solltest du dich dabei keinen Milimeter bewegen dürfen?

PS: Nein, es geht NICHT anders in Excel.

1
@SarahSchweiz

aus übersichtlichkeitsgründen kann ich das unter keinen umständen tun. das hier ist ja nur ein stark vereinfachtes beispiel - in wirklichkeit habe ich eine mehrdimensionale matrix und darf keine weiteren spalten einfügen.

0
@eddiepoole

Wenn du die Spalte einfügst, dann wirst du den Unterschied noch nicht mal merken. Das ist eine rein optische Verschiebung und alle Parameter, welche du bereits in Formeln angelegt hast, passen sich automatisch an. Die Tabelle wird ja nicht breiter dadurch, die entsprechenden Zeilen sind dann ja auch dünner.

Aber wie du meinst... Ich arbeite viel mit Excel, auch mit mehrdimensoinalen Dateien. Sagen kann ich dir nur, dass du dann mit Excel nicht weiterkommen wirst.

0
@eddiepoole

...was absolut unwichtig ist! Die Anzahl der Spalten ist völlig irrelevant, solange sie auf das von dir angepasste Blattformat passen.

Egal... wenn du da zu wenig Flexibilität hast (unsinnigerweise), dann musst du dir eine Alternative suchen. Mit Excel wirst du hier nicht weiterkommen.

1
@eddiepoole

Oh je, wieso das denn nicht? Das hebelt die eigentliche funktion von einer tabellenkalkulation völlig aus

0
@eddiepoole

In einer Matrix gilt die Grundregel... eine Zelle gleich eine Information. Die Anzahl ist eine Information, die Getränkesorte ist eine Information.

Ergo gilt bei deinem Aufbau, dass er nicht den Grundsätzen einer ordentlichen Tabelle entspricht. Das kann man machen, dann muss man aber auch damit leben, dass eventuelle Auswertungen um einiges komplizierter sind.

What so ever - Du hast eine Lösung - aber für die Zukunft sollte das beim Aufbau der Tabelle berücksichtigt werden.

1
@Funfroc

Es gibt keine Regel auf dieser Welt mit einem unendlichen Geltungsbereich. Was du sagst, ist sinnvoll und nötig, wenn maschinelle Auswertungen drüber laufen sollen. Für meinen Anwendungsfall gilt das nicht.

0
@Funfroc

als Leitlinie ist das schon richtig, aber wenn die Katze mal auf dem Baum ist, muss man sich eben was einfallen lassen!

0

Was möchtest Du wissen?