Excel - nächst höheren Wert aus einer Tabelle finden?

Meine Referenztabelle - (Computer, Technik, Microsoft) .. - (Computer, Technik, Microsoft)

7 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Fährt die S-Bahn alle 5 Minuten? Um die Formel kurz zu halten kannst du tricksen.

Leg dir im Namensmanager eine Formel für die aktuelle Uhrzeit an. JETZT() enthält auch das Datum, welches wir nicht gebrauchen können.

Name: Uhrzeit

=ZEITWERT(TEXT(JETZT();"hh:mm:ss"))

Da VERWEIS die nächstfrühere Uhrzeit liefert, musst du auf die aktuelle Uhrzeit noch den Zeitabstand addieren, der zwischen zwei Zügen liegt.

=VERWEIS(Uhrzeit+ZEIT(0;5;0);A1:A32)
56

Alternative:

Wenn du den Namen "Uhrzeit" wie oben beschrieben angelegt hast, kannst du das Minimum mit MIN finden.

=MIN(WENN(A1:A32>Uhrzeit;A1:A32))

Diese Formel musst du mit Strg + Shift + Enter abschließen.

2
6

Vielen Dank für die schnelle Antwort! Allerdings fährt die Bahn nicht alle 5 Minuten, sondern über den Tag verteilt entweder alle 5, 10 oder 20 Minuten, je nach Uhrzeit.

Ich möchte mir meinen eigenen Excel-Fahrplan erstellen, als Projekt, daher sind nachher auch unregelmäßig fahrende Züge betroffen.

Geht die Funktion dann trotzdem? Oder hast du eine Alternative?

0

Ich bin jetzt gerade nicht ganz fit darin, wie man das in Excel genau codiert, aber meine Idee zum Verfahren:

Suche aus allen Zahlen diejenigen heraus, die größer als "jetzt" sind, und ermittle aus denen das Minimum.

also irgendwie so was wie:

= Minimum ( Wenn (Wert aus Spalte Abfahrt > jetzt; Wert aus Spalte Abfahrt > jetzt))
"")""

In der Spalte A stehen die Abfahrtszeiten. Daneben gibst du folgende Formel ein:

=WENN(MIN(WENN(A1:A45>ZEITWERT(TEXT(JETZT();"hh:mm:ss"));A1:A45))>0;KKLEINSTE(A1:A45;1);"")

Diese Formel ziehst bis zum Ende. Dann werden alle Abfahrtszeiten ab der momentanen Uhrzeit angezeigt. Damit kannst du selber entscheiden, welche S-Bahn du nehmen möchtest. 

Abfahrtszeiten - (Computer, Technik, Microsoft)
22

perfekt,
wenn man jetzt noch das Ende der Datenreihe absolut setzt (A1:$A$45), würde mir das noch besser gefallen.

Gruß aus Berlin

0
45
@Britzcontrol

Was meinst du "Das Ende setzen" 

Kann es sein, dass du nie zwischen 20 und 6 Uhr niemals mit der S-Bahn fährst?

0

Excel Tabelle mit Hilfe von Wenn Funktion etc. erstellen?

Hallo habe von meinem Chef eine Aufgabe bekommen, bin neu im Unternehmen und er lässt mich schon ziemlich vieles schon alleine machn , wo ich keine Hilfe kriege.

ich muss mit hilfe von einer Preisliste 3 Lieferanten/Speditionen vergleichen für den Preis pro Palette, da sich die 3 unterscheiden, denn manche geben die Preise in 700 kg manche jedoch in 400 kg, und sie gliedern die Transportbereiche in versch. Zonen ein. Ich bräuchte Vorschläge wie das zum lösen ist, da er momentan im Stress ist und nicht helfen kann, sagte er nur ich solle recherchieren ^^.

Bitte um Hilfe :)

...zur Frage

Wie kann ich auf Excel nach dem Filtern die Nummerierung der Zeilen Fortsetzen so das Sie fortlaufend ist und nicht einen Sprung macht?

Wie kann ich auf Excel nach dem Filtern die Nummerierung der Zeilen Fortsetzen so das Sie fortlaufend ist und nicht einen Sprung macht? Also wie auf dem Bild nicht auf 97 gesprungen wird sondern mit 7 fortgesetzt wird?

...zur Frage

Excel 2010 SVerweis - Bestellliste?

Hallo zusammen,

Folgendes Szenario:

Ich habe eine Bestellliste.

Eingabe ist eine Bestellnummer hinter der ein spezifischer Preis hinterlegt ist.

Zum Beispiel: 1=2€, 3=4€, 5=6€. Jetzt möchte ich in einer Spalte diese Bestellnummern eingeben und automatisch den zugehörigen Betrag in einer anderen Spalte ausgegeben haben.

Ich habe 2 Tabellen-blätter:

Tabellenblatt1 hat einen Wert in C1 der auf Tabellenblatt2 verweist.

Tabellenblatt2 hat in Spalte A die Bestellnummer und in Spalte B der Preis.

=WENN(ISTFEHLER(SVERWEIS(Bestellung!C2;Speisekarte!A:B;"2"));"";SVERWEIS(Bestellung!C2;Speisekarte!A:B;"2"))

Diese Formel sollte mir egtl. die Werte passend ausgeben, aber das klappt nur teilweise, da Excel hingeht und anstelle der Bestellnummer "A9" zum Beispiel die "A2" nimmt. Oder die Bestellnummer "C9" wird zur Bestellnummer "Text"

Kann mir hier einer weiterhelfen?

...zur Frage

Excel-Differenz in 2 Zellen?

Hallo, ich möchte in meiner Excel-Tabelle eine Formel einfügen, wo es mir aus einer Zahl in Zelle A1 eine Zahl aus der Zelle A2 abzieht. Soweit ich weis ist das ja ein Zirkelbezug, oder?

Es funktioniert nicht, weil ich in die Zelle A1 ja keinen Wert mehr, den es mir abziehen soll hineinschreiben kann.

Hat jemand einen Lösungsvorschlag? Im besten Fall sollte die zahl in Zelle A2 danach auch noch verschwinden.

...zur Frage

excel Schraffur

hi, ich erstelle hier grad eine Excel Tabelle und müsste eine Schraffur einfügen, weiß aber nicht wie das geht, bzw. kann in excel diesen button nicht finden! Danke für eure Hilfe!

...zur Frage

Excel (2007): Nach Anführungszeichen in String suchen

Hallo zusammen, ich habe das Problem, dass ich in einem String / in einer Zelle nach einem Anführungszeichen suchen lassen möchte und mit die Position zurückgegeben werden soll.

Normalerweise ist die Vorgehensweise die folgende: Wert in Zelle A1: Peter Funktion in Zelle A2: =FINDEN("T";A1;1) Ergebnis: 3

im konkreten Fall ist komme ich mit der oben beschriebenen Systematik nicht weiter. Wert in Zelle A1: Peter sagt: "Hallo" Funktion in Zelle A2: =FINDEN(""";A1;1) Ergebnis: #WERT!

Dabei sol nach dem Anführungszeichen " gesucht werden . Kann anstelle dessen evtl. auf Umwegen der HTML-Sonderzeichencode oder Ähnliches abgefragt werden?

Vielen Dank für eure Hilfe vorab.

...zur Frage

Was möchtest Du wissen?