Excel: nur addieren wenn zelle nicht leer, wie?

6 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

=WENN(D2="";"";D2*10%&" €")

Aber das € mit in die Formel zu schreiben halte ich für nicht so gut. Warum nicht einfach als Währung formatieren?

Danke fürs

0

Oh je - sorry, aber das ist mit stümperhaft noch geschmeichelt.

  • Wenn Du den Wert von nur einer Zelle übernimmst ist die Summen-Formel Blödsinn.
  • Eine Formatangabe wie das €-Zeichen gehört nicht in eine Formel sondern in die Formatangabe.
  • Ansonsten regelt man das, was Du wünschst über eine "WENN"-Abfrage

Empfehle dringen einen Excel-Grundkurs.

Ich weiß jetzt nicht genau was du vorhast, aber da fehlt das "Mal-Zeichen".

Wenn eine Zelle leer ist, dann hast sie den rechnerischen Wert "Null". In der Addition wird dann einfach diese Null addiert. Die Auswirkung ist dabei:

X + 0 = X

was muss ich hier umschreiben damit es nur die summe ausgibt wenn feld D2 NICHT leer ist ?

0
@TommysWaden

Welche Summe? Die Formel nimmt 10 Prozent der Zahl in Zelle D2 und hängt ein Eurozeichen drann.

Ach...jetzt kapier ichs:

=WENN(D2<>0;SUMME(D2)*10%&"€";"")

0

Was möchtest Du wissen?