Durchschnitt in Excel?

 - (Computer, Schule, Noten)

8 Antworten

Moin,

ich würde es etwas anders aufbauen als Oubry. Es kommt aber auf deine Excel-Version an. Ich habe mal ein bisschen getestet.

Ich würde die Formel:

=WENNFEHLER(MITTELWERTWENN(L8:L10;">0");0)

einsetzen. An allen Stellen. Auch zum ermitteln des Gesamtdurchschnittes.

(Alle Fehler werden in 0 "verwandelt" und alle 0 werden ignoriert. Negative Zensuren möchtest du ja nicht bekommen ;) )

Grüße

Woher ich das weiß:Hobby

Andere Möglichkeit:

=Wennfehler(DeineFormel;"-")

Leer würde ich die Zelle nicht lassen, damit man sieht, dass da eine Formel oder '- drinsteht.

DeineFormel natürlich ohne =, das muss an den Anfang.

=WENN(B1=0;"";(A1/B1))

(A1/B1) durch Deine Formel ersetzen und B1 durch den Divisor-Teil.

Woher ich das weiß:Beruf – IT-Administrator (i.R.)

P.S.: Für Dein Beispiel bei der Antwort von MNW1705:

=WENN(ANZAHL(C3:P3)>0;MITTELWERT(C3:P3);""

Etwas "unsauberer" wäre:

=WENNFEHLER(MITTELWERT(C3:P3);"")

Sollte aber auch problemlos klappen.

1
@Oubyi

Ich habe die erste Formel benutzt. Nun ist das Problem, dass wenn ich bei einem Fach die Note eintrage, dann kommt überall bei dem Durchschnitt die Note des Faches

0

Habe ich gemacht. Jetzt ist es zwar leer beim Durchschnitt aber wenn ich eine Note Einträge dann bleibt es auch leer. Wieso denn?

0
@gutefragenco
aber wenn ich eine Note Einträge dann bleibt es auch leer.

Das kann ich nicht nachvollziehen. Wenn im Berich C3:P3 eine Zahl steht, kann die Formelzelle eigentlich nicht leer bleiben.
Zeige mal einen aussagekräftigen Screenshot.

1

DIV/0 steht für Division durch 0...eins deiner Felder, bei denen du versuchst zu teilen, ist leer -> x/0 ist nicht berechenbar. Probier mal, alle Felder mit 1 aufzufüllen. Dann müsste es klappen.

Meine Formel ist so: =MITTELWERT(C3:P3)

1
@MNW1705

Versteh ich nicht :( also was muss ich jetzt eingeben?

1
@gutefragenco

Na in den Feldern, bei denen du einen Mittelwert haben willst, schreibst du eine Note rein.

1

"Mittelwert" und dann die betreffenden Felder markieren.

Es darf natürlich kein Feld leer sein.

Aber meine Frage ist, ob es eine Formel gibt, auch wenn nichts bei den Noten steht, dass bei dem Durchschnitt auch nichts steht?

1

Doch, bei dem MittelwertBefehl dürfen Felder leer sein! Das ist sogar besser, weil 0,0 den Mittelwert positiv verzerren würde, oder wenn zB die Anzahl der Noten unterschiedlich ist!

2

Was möchtest Du wissen?