Wenn A1=A2="X" Dann "Ja" sonst "nein" Excel Wenn dann formel?

...komplette Frage anzeigen

6 Antworten

Wenn in keiner Zelle X mehrfach stehen kann, ist am einfachsten

=WENN(A1&A2&A3="XXX";"gewonnen";"")

Mit deinem letzten Vorschlag bist du also schon nah dran.

Der normale Weg ohne Tricksen ist:

=WENN(UND(A1="X";A2="X";A3="X");"gewonnen";"")

oder 

=WENN(A1="X";WENN(A2="X";WENN(A3="X";"gewonnen";"");"");"")

_____________

Praktisch würde ich es so machen, dass du einfach unter jeder Spalte und rechts neben jeder Zeile und die Diagonalen überprüfst. =UND(A1="X";A2="X";A3="X") und dann nur noch überprüfst =WENN(UND(<Bereich Zwischenergebnisse>);"gewonnen";"")

Vielen dank. habe ich noch die Möglichkeit mehrer Möglichkeiten zu erstellen in einer Zelle? so was wie:
=WENN(UND(A1="X";A2="X";A3="X")oder(und(A1="X";b2="X";c3="X");"Gewonnen";"")

0
@blir14

Ja geht, wird nur unübersichtlich. Besser du machst pro Tripel eine Abfrage in einer eigenen Zelle.

0
@Suboptimierer

Schon möchte es aber dennoch testen. Wo wie ich es eingegeben habe geht es nicht haben Sie eine Idee?

0
@blir14

Du musst das ODER ganz nach vorne ziehen. Die Schreibweise ist funktional, nicht wie man spricht:

=WENN(ODER(UND(...);UND(...);UND(...);...)

1

habe es:

=WENN(ODER(UND(A1="X";A2="X";A3="X");UND(A1="X";B2="X";C3="X"));"Gewonnen";"")

Danke für die hilfe

1
@blir14

da fehlen natürlich noch 6 Möglichkeiten (B1 senkrecht, C1 senkrecht, A2waagrecht, A3 waagrecht, 2 Diagonalen, aber das Prinzip mit den Und innerhalb der Oder ist genau das Richtige!

0

übersichtlicher als mit einer verschachtelten Wenn-Formel ist eine verkettete, wobei ich hier

anstelle von zB =wenn(und(A1="x";B1="x";C1="x");1;0)

die Logik-Verknüpfung WAHR*WAHR*WAHR

(wird durch math. Operation * zu 1*1*1 (oder FALSCH =>0)) verwende, ist einfach kürzer. Das äussere Wenn braucht es natürlich trotzdem.

=WENN((A1="x")*(B1="x")*(C1="x")+(A2="x")*(B2="x")*(C2="x")+(A3="x")*(B3="x")*(C3="x")+(A1="x")*(A2="x")*(A3="x")+(B1="x")*(B2="x")*(B3="x")+(C1="x")*(C2="x")*(C3="x")+(A1="x")*(B2="x")*(C3="x")+(A3="x")*(2="x")*(C1="x")>0;"☻Gewonnen☺";"☹")

im Prinzip hat dkilli mit UND((A1="x";B1="x";C1="x")+... das Gleiche gemacht, nur vllt etwas xl-näher.

Aber da mehr als drei x auftreten könnten in 2 Gewinnkonstellationen (mind. 5 x), darf die Summe nicht =1 festgelegt werden, sondern muss einfach >0 lauten, das erfüllt hier denselben Zweck.
+ hat Priorität vor > , braucht also keine eigene Klammer.

Das Ganze erscheint Dir im Moment vllt noch etwas undurchsichtig, wirst Du aber später (sofern Du Dich wirklich in xl weiterbilden willst) vllt gut gebrauchen können. (Boule*sche Logikzahlen als Stichwort für zB gugl und/oder Wikipedia)

vor lauter Spiele hab ich Boule geschrieben, der Mann heißt natürlich Boole

hier ein Link (erfordert allerdings eine halbe Stunde Konzentration, ggf in 2 oder mehr Portionen)

Boolesche Algebra (Einführung) | Informatik Lernvideo

https://www.youtube.com/watch?v=pppTemykV5I

1

Da lamiam eine bessere und eine kürze Formel für Tic-Tac-Toe gefunden hat als ich, so muss ich neidvoll zugeben, dass er die Auszeichnung verdient hat, dass seine Antwort als "Hilfreichste Antwort" ausgezeichnet wird! 

Ich hoffe, dass der, die Fragesteller(in) dies zu würdigen weiß. 

Leider ist es immer so, dass Leute die sich sehr viel Mühe geben eine Antwort zu geben am wenigsten belohnt werden.

Die Hoffnung stirbt als letztes. 

1

=WENN(UND(A1="X";A2="X";A3="X");"Gewonnen";"")

Vielen dank. habe ich noch die Möglichkeit mehrer Möglichkeiten zu erstellen in einer Zelle? so was wie:
=WENN(UND(A1="X";A2="X";A3="X")oder(und(A1="X";b2="X";c3="X");"Gewonnen";"")

0
@blir14

Ja. Das "Oder" ist auch eine Funktion, wie das "Und". Also:

=WENN(ODER(
UND(A1="X";A2="X";A3="X");
UND(B1="X";B2="X";B3="X");
UND(C1="X";C2="X";C3="X");
UND(A1="X";B1="X";C1="X");
UND(A2="X";B2="X";C2="X");
UND(A2="X";B2="X";C2="X");
UND(A1="X";B2="X";C3="X");
UND(A3="X";B2="X";C1="X"));"Gewonnen";"")

0
@daCypher

Oder mit "Verloren"-Auswertung:

=WENN(ODER(
UND(A1="X";A2="X";A3="X");
UND(B1="X";B2="X";B3="X");
UND(C1="X";C2="X";C3="X");
UND(A1="X";B1="X";C1="X");
UND(A2="X";B2="X";C2="X");
UND(A3="X";B3="X";C3="X");
UND(A1="X";B2="X";C3="X");
UND(A3="X";B2="X";C1="X"));"Gewonnen";WENN(ODER(
UND(A1="O";A2="O";A3="O");
UND(B1="O";B2="O";B3="O");
UND(C1="O";C2="O";C3="O");
UND(A1="O";B1="O";C1="O");
UND(A2="O";B2="O";C2="O");
UND(A3="O";B3="O";C3="O");
UND(A1="O";B2="O";C3="O");
UND(A3="O";B2="O";C1="O"));"Verloren";""))

(Kann sein, dass irgendwo eine Klammer auf oder zu zu viel oder zu wenig drin ist. Hab die Funktion nicht getestet)

0
@daCypher

=WENN(ODER(UND(A1="X";A2="X";A3="X");UND(A1="X";B2="X";C3="X"));"Gewonnen";"")

habe es for 3 min selber hin bekommen vielen dank für die hilfe 

0

Die Spielregeln von Tic-Tac-Toe (auch 3 gewinnt genanntlauten: Wenn in einer Spalte, Zeile oder diagonal 3 x sind, so hat man gewonnen. 

Das ergibt insgesamt 8 Möglichkeiten zu gewinnen. Die müssen alle ausgewertet werden!

Das geht mit einer verschachtelte Wenn-Formel  nicht, da nur 7 Verschachtelungen zulässt. Außer mit Tricks. 

Daher meine Lösung, die alle Möglichkeiten zu gewinnen berücksichtigt:

=WENN(UND(A1="x";B1="x";C1="x")+UND(A2="x";B2="x";C2="x")+UND(A3="x";B3="x";C3="x")+UND(A1="x";A2="x";A3="x")+UND(B1="x";B2="x";B3="x")+UND(C1="x";C2="x";C3="x")+UND(A1="x";B2="x";C3="x")+UND(A3="x";B2="x";C1="x")=1;"Gewonnen";"")

"Das geht mit einer verschachtelte Wenn-Formel  nicht, da nur 7 Verschachtelungen zulässt"
die Zahl der Klammerebenen ist -ich glaube schon seit der letzten 2003-Version- gewaltig erweitert worden (32 oder mehr?)

1
@Iamiam

ich habs mal mit 14 Klammerebenen in einem einfachen Modell getestet, kein Problem, trotzdem würde das recht unübersichtlich, die addierte Und-Verkettung ist in jedem Fall übersichtlicher!

1

=Wenn(Und(A1=X;A2=X;A3=X);gewonnen;verloren)

Vielen dank. habe ich noch die Möglichkeit mehrer Möglichkeiten zu erstellen in einer Zelle? so was wie:
=WENN(UND(A1="X";A2="X";A3="X")oder(und(A1="X";b2="X";c3="X");"Gewonnen";"")

0

Vielen dank. habe ich noch die Möglichkeit mehrer Möglichkeiten zu erstellen in einer Zelle? so was wie:
=WENN(UND(A1="X";A2="X";A3="X")oder(und(A1="X";b2="X";c3="X");"Gewonnen";"")

Was möchtest Du wissen?