Ich habe einenFehler bei Installation von OpenSSH auf Ubuntu-server?

5 Antworten

Hallo

ich versuche gerade auf meinem Ubuntu server ssh zu installieren

Was ist denn das für ein dummes Server-Betriebssystem bei dem noch kein ssh installiert und aktiviert ist?

Linuxhase

Vielleicht eines in dem der Administrator Administrator ist und eigene Entscheidungen fällt...

0
@hanssorglos

@hanssorglos

Vielleicht eines in dem der Administrator Administrator ist und eigene Entscheidungen fällt...

Das ist doch Bullshit, welchen Sinn macht es denn ein Server-Betriebssystem/eine Server-Distribution zu schaffen die nicht über diese essenziell wichtige Sache verfügt?

Gerade von Canonical ist man (nicht ich)  es doch gewöhnt das man mehr als anderswo bevormundet wird.

Linuxhase

0

Sag mal, was in deiner /etc/apt/sources.list (incl.sources.list.d. natürlich) ist - sofern das apt update, wie dir bereits geschrieben wurde, nichts bringt.

Auf der Server-Variante muss ssh Server bereits installiert sein.

Und der muss dieses Paket finden

https://packages.ubuntu.com/de/openssh-server

Von was für Ubuntu Version reden wir eigentlich?

"apt-get install ssh" heißt das bei Ubuntu dann klappt das auch ;)

der ssh-client ist in ubuntu standard, schon drin.
was er will ist:

sudo apt-get install openssh-server 
0
@pisanius

Das passt schon. Das ist nämlich nicht nur der Client sondern auch der Server (Metapacket)

1

@hackspoiler

"apt-get install ssh" heißt das bei Ubuntu dann klappt das auch ;)

Beim aktuellen Ubuntu bekomme ich das hier angezeigt:

http://sprunge.us/XIgI

Linuxhase

0
@Linuxhase

@Linuxhase

Das hier wird bei mir auf einem Ubuntu 16.04 LTS Server angezeigt.

root@olum:~# aptitude update && aptitude show ssh
Paket: ssh
Zustand: Installiert
Beschreibung: Secure Shell Client und Server (Meta-Paket)
2

Ubuntu: sudo apt-get upgrade , schlägt Fehl?

Ich hab heute einfach mal wieder in der Konsole meine Updates und Upgrades laufen lassen wollen. Nach dem ich "sudo apt-get upgrade" eingegeben hab schlug es fehl und mir ist nicht ganz klar wieso. (Habe Ubuntu 14.04 LTS 3)

Hier mal alles nach der eingabe von "sudo apt-get upgrade":

fabian@fabian-MS-7373:~$ sudo apt-get upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 openjdk-7-jre : Hängt ab von: openjdk-7-jre-headless (= 7u85-2.6.1-5ubuntu0.14.04.1) aber 7u79-2.5.6-0ubuntu1.14.04.1 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.

Und nun wenn ich den empfohlenen befehl "sudo apt-get -f install" mache oder "sudo apt-get -f upgrade" oder "sudo apt-get upgrade -f" kommt das :

fabian@fabian-MS-7373:~$ sudo apt-get upgrade -f
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden aktualisiert (Upgrade):
  openjdk-7-jre-headless
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
2 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 41,4 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 92,2 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] 
(Lese Datenbank ... 323943 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../openjdk-7-jre-headless_7u85-2.6.1-5ubuntu0.14.04.1_i386.deb ...
Entpacken von openjdk-7-jre-headless:i386 (7u85-2.6.1-5ubuntu0.14.04.1) über (7u79-2.5.6-0ubuntu1.14.04.1) ...
dpkg-deb (Unterprozess): Archiv-Element wird dekomprimiert: lzma-Fehler: komprimierte Daten sind beschädigt
dpkg-deb: Fehler: Unterprozess <Dekompression> gab den Fehlerwert 2 zurück
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/openjdk-7-jre-headless_7u85-2.6.1-5ubuntu0.14.04.1_i386.deb (--unpack):
 Extrahierte Daten für »./usr/lib/jvm/java-7-openjdk-i386/jre/lib/i386/client/libjvm.so« können nicht nach »/usr/lib/jvm/java-7-openjdk-i386/jre/lib/i386/client/libjvm.so.dpkg-new« kopiert werden: Unerwartetes Ende der Datei oder des Datenstroms
E: Sub-process /usr/bin/dpkg returned an error code (1)
fabian@fabian-MS-7373:~$ 

Bitte um Hilfe!

...zur Frage

Ubuntu Wine1.5 installieren?!

Hallo ich habe Wine (um win programm auf ubuntu auzuführen) nach der anleitung auf der www.winehq.org instaliert (per terminal):

"Es ist auch möglich, das Hinzufügen des Wine PPA und die Installation wie folgt mit der Kommandozeile durchzuführen. Die Instruktionen sind nützlich für Kubuntu, Xubuntu und andere Ubuntu Derivate. Zuerst öffne ein Terminalfenster (Anwendungen->Zubehör->Terminal).

sudo add-apt-repository ppa:ubuntu-wine/ppa

Aktualisiere dann die APT-Paketinformationen durch Ausführen von 'sudo apt-get update'. Du kannst nun Wine durch Ausführen von 'sudo apt-get install wine1.5' im Terminal installieren."

Jedoch sagt wir das terminal immer einen Fehler am ende

root@ubuntu:~# sudo apt-get install wine1.5 Paketlisten werden gelesen... Fertig Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass Sie eine unmögliche Situation angefordert haben oder, wenn Sie die Unstable-Distribution verwenden, dass einige erforderliche Pakete noch nicht erstellt wurden oder Incoming noch nicht verlassen haben. Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten: <--Fehler wine1.5 : Hängt ab von: wine1.5-i386 (= 1.5.30-0ubuntu3) ist aber nicht installierbar Empfiehlt: gnome-exe-thumbnailer soll aber nicht installiert werden oder kde-runtime soll aber nicht installiert werden Empfiehlt: fonts-droid soll aber nicht installiert werden Empfiehlt: ttf-mscorefonts-installer soll aber nicht installiert werden Empfiehlt: fonts-horai-umefont soll aber nicht installiert werden Empfiehlt: fonts-unfonts-core soll aber nicht installiert werden
Empfiehlt: winbind soll aber nicht installiert werden Empfiehlt: winetricks soll aber nicht installiert werden E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

...zur Frage

Ubuntu Virtualbox lassen sich keine VM's starten?

Hallo, ich habe VirtualBox vorschriftsgemäß wie im Wiki beschrieben installiert und auf dem neusten Stand. Wenn ich VB starte bekomme ich in der shell diese Meldung ausgegeben und ich kann keine virtuellen Maschinen starten:

user@PC:~$ virtualbox WARNING: The character device /dev/vboxdrv does not exist. Please install the virtualbox-dkms package and the appropriate headers, most likely linux-headers-generic.

 You will not be able to start VMs until this problem is fixed.

ABER:

user@PC:~$ sudo apt-get install virtualbox-dkms [sudo] Passwort für user: Paketlisten werden gelesen... Fertig Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig »virtualbox-dkms« ist bereits die neuste Version (5.0.24-dfsg-0ubuntu1.16.04.1). 0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

Wie löse ich das Problem?

...zur Frage

Was möchtest Du wissen?