Excel: Wie verhindere ich die Änderung von Summen beim Benutzen von Filtern?

4 Antworten

Dass sich die Summe nach SORTIEREN ändert wirst Du mit einer Summenformel nicht vermeiden können, da sich ja die Werte in den angesprochenen Zellen ändern.
WIE soll Excel wissen, welch Werte es jetzt summieren soll?
Du kannst aber vielleicht einen Primärschlüssel setzten.
Also z.B. in Spalte A - bevor Du irgend etwas mit den Daten machst - die Zahlen von 1 bis 100 schreiben.
Und dann für die Summe (angenommen die Euros stehen in Spalte H):

=SUMMEWENN(A1:A100;"<=25";H1:H100)

Dann bleibt das auch vom Filter unbeeinflusst.

Hilft Dir das?

Woher ich das weiß:Beruf – IT-Administrator (i.R.)

Hi Oubyi, danke für deine Hilfe. Ich habe vor 5 Minuten unter der Frage einen Beitrag geschrieben mit einem Screenshot und weitere Hinweise zum Fehler gegeben. Vielleicht kannst du dir das nochmal angucken? Das wäre sehr freundlich!

0
@Oubyi, UserMod Light

Ich bin gerade dabei :). Was gebe ich denn ein, wenn die Werte in A Zwischen 121 und 125 liegen? =SUMMEWENN(A125;A129;">=121 UND <=125";J125:J129) ?

0
@topmacuser

Ich konnte die Formel bei 4 der 6 Zellen bereits ausprobieren. Leider besteht das Problem weiterhin. Sobald ich die Summen absteigend sortiere, ändern sich die Ergebnisse.

0
@topmacuser

Trotz der Primätschlüssel?
Das kann ich leider nicht nachvollziehen.

P.S:
Zeige mal die Formeln, hast Du da auch mit:

SUMMEWENN(A125;A129; ....

o.Ä. angefangen?
Das ist schon mal falsch,

SUMMEWENN(A125:A129; ...

muss es heißen.

0
@topmacuser

Am einfachsten vielleicht.

=SUMMEWENN(A1:A1000;"<=125";J1:J1000)-SUMMEWENN(A1:A1000;"<121";J1:J1000)

Es geht aber auch direkter:

=SUMMENPRODUKT((A1:A1000>=121)*((A1:A1000)<=125)*(J1:J1000))

0

@milonguero008

Alle Formeln wurden mit SUMME ohne vorher gesetztem Filter gebildet.

Anbei ein Screenhot. Die Formeln lauten:

  1. (=SUMME(I5:I124)
  2. (=SUMME(I125:I129)
  3. (=SUMME(I130:I193)
  4. keine Formel
  5. (=SUMME(K194:K195)
  6. (=SUMME(I196)
  7. (=SUMME(I197:I412)

Zuerst habe ich die Tabelle erstellt, dann die Summen wie oben dargestellt gebildet. Wenn ich jetzt den im Screenshot dargestellten Filter anwende passiert folgendes:

  1. ausblenden der 0€ Felder = funktioniert
  2. Klicke ich jetzt auf "Nach Größe sortieren (absteigend)" = Summen ändern sich

Der Hinweis an den Formeln lautet:

"Die Formel in dieser Zelle bezieht sich auf einen Bereich, der an weitere Zahlen angrenzt. Die Formel schließt nicht alle angrenzenden Felder ein."

Vielleicht hast du noch einen Tipp für mich. Dank dir auf jeden Fall schon mal!

 - (Computer, Excel, Office)

Bitte die Felder auf Formeln überprüfen. Wenn die Summen VOR Einsatz eines Filters mit dem Summen-Zeichen (Sigma) gebildet wurden, steht dort tatsächlich die Formel SUMME, und die sollte sich durch den Einsatz von Filtern nicht beeindrucken lassen, sondern immer das Gesamtergebnis anzeigen.
Hast Du die Formel NACH aktivieren eines Filters gesetzt, findest Du in den Zellen die Formel TEILERGEBNIS, die sich an die filterbedingte Anzeige hält.
Einfach ausgedrückt -> stelle sicher, dass dort wirklich SUMME steht...

Woher ich das weiß:Studium / Ausbildung – Tätigkeit als IT Trainer
 - (Computer, Excel, Office)

Danke Dir. Ich habe eine Antwort mit Screenshot separat in die Frage geschrieben. Bei der Antworten Funktion ging das leider nicht. Vielleicht kannst du dir das ja einmal anschauen. Danke vorab!

0

F4 drücken an der Stelle der Formel, welche beibehalten werden soll.

Dank dir schonmal. Das hilft leider nur, wenn ich z.B. Zellen mit 0 Euro ausblende. Wenn ich jedoch die Reihenfolge sortiere (von groß nach klein), dann ändern sich die Summen leider trotzdem ...

0

Was möchtest Du wissen?