Excel 2 Spalten vergleichen und fehlende(n) Wert(e) anzeigen lassen

2 Antworten

Schreibe z.B. in C1 diese Formel:
=WENN(ISTNV(VERGLEICH(A1;B:B;0));"Fehlt in B";"")
und kopiere sie runter.
Dann zeigt sie Dir an , welcher Name in B nicht vorkommt.
Habe ich Dich richtig verstanden?

Woher ich das weiß:Beruf – IT-Administrator (i.R.)

Diese antwort ist zwar schon alt, aber ich hab sie mir in den Favoriten gespeichert und brauch sie fast jeden Tag ;) Ein großes DANKE an den Verfasser!

1

Wie kann ich nun statt "Fehlt in B" den entsprechenden fehlenden Namen ausgeben lassen?

Hintergrund: Ich habe, ähnlich wie der ursprünliche Fragensteller, zwei Spalten. In Spalte A befindet sich die Gesamtheit aller Dokumentnummern (knapp 800). In Spalte B alle aufgerufenen Dokumente in Form der Dokumentnummernn (ca. 300). In Spalte C möchte ich nun die Gesamtheit aller nicht aufgerufenen Dokumentnummern ausgeben lassen, da diese Nummern als Ergebnis festgehalten werden sollen.

Vielen Dank für die Hilfe!

0
@Judith1403

Das löst Du am besten mithilfe einer Hilfsspalte.
Schreibe z.B. in Spalte D (oder irgendeine andere Spalte, die Du auch ausblenden kannst) in D1 diese Formel und runterkopieren:

=ZÄHLENWENN($B$1:$B$1000;A1)=0

Jetzt hast Du schon mal die Möglichkeit diese Spalte nach WAHR zu filtern um in Spalte A nur die nicht aufgerufenen Nummern zu sehen.
ODER Du schreibst in C1 und runterkopieren:

{=WENNFEHLER(INDEX($A$1:$A$1000;KKLEINSTE(WENN($D$1:$D$1000=WAHR;ZEILE($D$1:$D$1000));ZEILE(A1)));"")}

**ACHTUNG!**   
Das ist eine Matrixformel.  
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:  
STRG & SHIFT & ENTER (alle drei gleichzeitig).  
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.  

Klappt es?

0

Wie kann ich nun statt "Fehlt in B" den entsprechenden fehlenden Namen ausgeben lassen?

Hintergrund: Ich habe, ähnlich wie der ursprünliche Fragensteller, zwei Spalten. In Spalte A befindet sich die Gesamtheit aller Dokumentnummern (knapp 800). In Spalte B alle aufgerufenen Dokumente in Form der Dokumentnummernn (ca. 300). In Spalte C möchte ich nun die Gesamtheit aller nicht aufgerufenen Dokumentnummern ausgeben lassen, da diese Nummern als Ergebnis festgehalten werden sollen.

Vielen Dank für die Hilfe!

Was möchtest Du wissen?