Mehrere Werte in mehrere Excel-Spalten suchen?

...komplette Frage anzeigen Tabelle - (Excel, Office)

2 Antworten

"Irgendewo" vorkommen bedeutet irgendwo in der Spalte oder Irgendwo in der gesamten Tabelle (außer in der ersten Spalte?)

Mein Ansatz wäre mit ZÄHLENWENN - Ist das Ergebnis > 0 kommt der Wert irgendwo vor. (Ich kanns im Moment leider nicht ausprobieren)

Antwort bewerten Vielen Dank für Deine Bewertung
gfntom 30.08.2016, 12:25

Ja, funktioniert - sowohl wenn du nur in einer Zeile suchst, als auch in mehreren.

=ZÄHLENWENN(A1;B1:P100)

Liefert einen Wert> 0 wenn A1 irgendwo im Berecih B1:P100 vorkommt.

1

{=SUMME(ZÄHLENWENN(B1:Z100;B1:Z100)>1}

Ohne geschweifte Klammern eingeben und mit Strg+ Shift+Enter abschließen.

Ungetestet da gerade kein Excel zur Verfügung.

Antwort bewerten Vielen Dank für Deine Bewertung
augsburgchris 30.08.2016, 12:19

Sorry gerade gesehen:
{=SUMME(ZÄHLENWENN(B1:Z100;A1:A100)>1}

1
Ninombre 30.08.2016, 13:52
@augsburgchris

den Matrixansatz fand ich interessant, zumindest unter Excel 2010 wir aber nur der erste Wert aus A1:A100 gesucht. Würde mit Hilfsspalte funktionieren, aber der Ehrgeiz sollte ja sein, ohne auszukommen..

0
Oubyi 30.08.2016, 13:53
@augsburgchris

Nach meinem Test sind klein Verbesserungen notwendig.
So funktioniert Deine Idee:

{=SUMME(ZÄHLENWENN(B1:Z100;A1:A100))>0}

Die Formel muss natürlich außerhalb der Bereiche stehen.

0
Oubyi 30.08.2016, 13:56
@Ninombre

zumindest unter Excel 2010 wir aber nur der erste Wert aus A1:A100 gesucht

Mit meiner kleinen Korrektur funktioniert das einwandfrei.
Vom Prinzip her eigentlich auch mit Chris` Formel.

0
augsburgchris 30.08.2016, 14:26

Hi Uwe. Ja bei der 1 hatte ich nen Denkfehler. Wollte >= 1 schreiben aber das ist ja auch Quatsch. >0 reicht vollkommen. Mega culpa.

Auch 2010 kann mit der Matrixformel korrekt umgehen wenn man sie mit Strg+Shift+Enter sbschliesst. Sonst wird klar nur der erste Wert gesucht.

1

Was möchtest Du wissen?