Zwei Spalten vergleichen; Wenn groesser bzw. kleiner als...

3 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

=SUMMENPRODUKT((B1:B190>A1:A190)*1)

Klappt es?

P.S.:
In der englischen Version dürfte das:
=SUMPRODUCT((B1:B190>A1:A190)*1)
heißen, wenn ich mich recht erinnere.

P.P.S.:
Angepasst an Deine Bereiche dann, denke ich:
=SUMPRODUCT((AQ3:AQ192>AP3:AP192)*1)

1
@Oubyi

Super, das hat geklappt :) Waere es moeglich dazu noch eine weitere Bedingung einzufuegen. Also alle Daten die groesser als AP sind und dazu noch in H als Wert "1" haben zum Beispiel?

0
@junti

Klar!

=SUMPRODUCT((AQ3:AQ192>AP3:AP192)*(H3:H192=1))

oder, falls Deine 1 wirklich Text ist, und keine Zahl:

=SUMPRODUCT((AQ3:AQ192>AP3:AP192)*(H3:H192="1"))

2

moin, ein drittes feld aufmachen mit folgender formel =wenn(a1>b1;1;"") die formel kannst du dann runter kopieren auf deine 190 zeilen. am ende dann die zählenwenn funktion - ist im statistischen bereich bei mehr funktionen zu finden. dort bekommst du dann ausgegeben wie oft die erste, bzw. 2 reihe größer war. saguma

Du kannst das auch mit einer Matrixfunktion in einer beliebeigen Zelle erreichen:

=summe(wenn(AQ3:AQ192>Ap3:AP192;1;""))

Abschließen mußt du die Funktion mit STRG+SHIFT+Enter, dann werden {gescheifte Klammern} um die Matrix-Funktion gelegt.

Die Funktion Summe zählt die mit der Wenn-Funktion ermittelten "Einsen" in den Matritzen :)

Hoffe, das hilft

Das geht auch über SUMMENPRODUKT und normales ENTER.
Ich versuche "echte" Arrays immer zu vermeiden, weil man schnell einmal in die Zelle reingeklickt hat, und dann mit ENTER wieder raus und die Matrix-Funktion ist weg.
SUMMENPRODUKT ist da oft hilfreich, weil es auch als Matrix funktioniert, aber "normal" eingegeben wird.
Bei Deiner Formel kannst Du Dir das WENN übrigens auch sparen:

{=SUMME((AP3:AP192>AQ3:AQ192)*1)}

1
@Oubyi

Richtig, mit Summenprodukt ist das genau so gut lösbar. Das Wenn würde ich als hilfreiches Instrument dennoch verwenden, da dieser Aufbau bei mehreren abgefragten Parametern durch einfache Verschatelungen dem gleichen Aufbau einfach folgen kann .. und dann sind wir beim Summenprodukt auch an den Grenzen :)

1
@tiger885i

und dann sind wir beim Summenprodukt auch an den Grenzen

Ganz im Gegenteil. DA zeigt Summenprodukt erst seine ganze Stärke.

=SUMMENPRODUKT((B1:B190>A1:A190)*(C1:C190= "x")*(D1:D190>10)*(usw....)).

Und eine WENN-Verschachtelung ist - zumal für "Anfänger" - alles andere als "einfach".

2
@Oubyi

... dafür liebe ich Excel - es gibt halt viele Wege die nach Rom führen

hoffe junti hat es geholfen

3
@Oubyi

Vielen Dank an euch beide! Ich habe mich (der Einfachheit halber) aber fuer die Summenformel entschieden :)

0
@Oubyi

Ausserdem ist SUMMENPRODUKT deutlich übersichtlicher als WENN-Verschachtelungen.

1

Was möchtest Du wissen?