WS2812B LED-Strip flackert am Ende?

 - (Computer, Technik, Technologie)

1 Antwort

  1. hast du n Oszi?
  2. bei mir hilft es manchmal, wenn ich n Kondensator zwischen 0V und ner digitalen Datenleitung einbaue... oder bei analogen Daten n Widerstand in Reihe... da scheinen sich irgendwelche dämlichen Schwingungen zu bilden...

wielang ist eigentlich das Kabel zwischen Strom-Regler und LED? vielleicht stört ja die Induktivität dieses Kabels den Strom-Regler? und deine Hand ändert die Kapazität des Kabels? also durch die Hand wird das L-Glied zum LC-Glied... dann würd es helfen, wenn du n paar µF parallel zu den LEDs anschließt... aber dicht dran an denen...

1
@RIDDICC

Ich kann leider nicht mit Bildern kommentieren. Kabel ist so 30-40cm lang. Ok, dann werde ich das wohl mal versuchen.

1
@RIDDICC

Habe es jetzt mit 100 und 10 µF ausprobiert, doch da bleiben die restlichen LEDs jeweils dauerhaft aus

0
@recoN90

lol... komisch... aber da sind wir wohl auf dem richtigen Weg... und bei 10nF (oder 22nF)? parallel zu den LEDs?

0
@RIDDICC

Hatte nichts anderes da, muss wohl mal zu Conrad oder so...

0
@recoN90

probier doch (bevor du zu Conrad gehst) n Stück Alu-Folie um das Kabel zu wickeln und verbinde die Alu-Folie mit 0V... das bildet vllt deine Hand nach...

0
@RIDDICC

Ok, hatte doch noch was da. Bei 100 nF bleiben die LEDs noch aus, aber bei 10 nF flackern sie wie zuvor. Also schätze ich, dass ich irgendwas dazwischen brauche?

0
@recoN90
  1. neee.... das mit dem Kondensator wär zu doll gepfuscht, glaub ich... ich versteh gar nich, war die ausgehen, wenn da n Kondensator parallel ist... meine Stromquellen finden 's gut, wenn da n fetter Kondensator am Ausgang ist...
  2. kannst du mal n kürzeres Kabel zwischen Stromquelle und LEDs versuchen?
  3. wie war die 0V-Alu-Folie um eines der Kabel?
0
@RIDDICC

Bei einem kürzeren Kabel flackert es wesentlich weniger und bei dem Trick mit der Alu-Folie war auch ein Unterschied bemerkbar

0
@recoN90

komische Stromquelle... da schwingt irgendwas, weil das Kabel sich ne Störung einfängt, würd ich mal vermuten... hast du Koax-Kabel? eins hin und ins zurück... und den Schirm auf 0V ziehen? oder geht das mechanisch nicht? um wieviel Strom geht es?

1
@RIDDICC

habe jetzt provisorisch eine weiter gnd-Leitung verlegt und damit scheine ich es in den griff zu bekommen

1
@recoN90

komisch... aber wenn's geht, dann ist's ja gut... :)

1

Was möchtest Du wissen?