Wie kann ich bei Excel Leerzeilen überspringen und Werte aus einer Tabelle in eine andere Tabelle übertragen?

...komplette Frage anzeigen Beispiel - (Excel, Funktion, Vergleich)

4 Antworten

Teste mal in I2 (und runterkopieren):

{=WENNFEHLER(INDEX($C$1:$C$25;KKLEINSTE(WENN($C$2:$C$25<>"";ZEILE($C$2:$C$25));ZEILE(A1)));"")}

und in J2 (und runterkopieren):

{=WENNFEHLER(INDEX($A$1:$A$25;KKLEINSTE(WENN($C$2:$C$25<>"";ZEILE($C$2:$C$25));ZEILE(A1)));"")}

**ACHTUNG!** Das sind Matrixformeln.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formeln zu einer Matrixformeln

Klappt es?.

Funktioniert perfekt. Vielen Dank dafür!!! Hab nur noch die 25 auf 100 erweitert und die Formel für die anderen Spalten angepasst. Und jetzt macht das Ding genau das was ich wollte.

0
@rh4001

Gern geschehen ☼
Freut mich, dass ich helfen konnte.

0

per Formel ist es kompliziert, wobei ich nicht einmal weiß, ob das in googledocs überhaupt geht, Grundentwurf steht hier beschrieben, müsste man aber noch anpassen, weil Du zusätzlich die Anzahl haben willst:
http://www.at-exceltraining.de/index.php/fragen-a-anworten-zu-excel/49-formeln-und-funktionen/179-sverweis-mit-mehreren-suchergebnissen.html

Ich würde es mit einer Pivottabelle lösen, jeweils eine pro Teilnehmer
Dafür brauchst Du noch eine Überschrift in A1 (Pivot erfordert für jede verwendete Spalte die Überschrift). In Excel würde sie beispielhaft aussehen wie im Bild
Optisch kann / muss man noch etwas feintunen gegenüber den Standardeinstellungen (z.B. macht eine Zeile Gesamtsumme keinen Sinn wenn auch Grammangaben verwendet werden -> Ausblenden unter Pivotoptionen Ergebnissummen). Kann inhaltlich bei googledocs etwas anders aussehen, ich kann es leider nicht direkt ausprobieren.

edit: na prima, beim Ändern kann ich scheinbar kein Bild mehr anfügen. Kommt in einer eigenen Antwort


Ich würde das mit einer wenn-dann-Funktion machen.

Könntest du mir eine Beispielformel geben? Wenn möglich mit Erklärung. Die Wenn-Funktion an sich kenne ich schon.

0
@rh4001

Wenn B2 ungleich 0 (oder meinetwegen auch wenn B2 nicht leer ist), dann I2 gleich C2 UND J2 gleich A2.

Und dann halt fortführen.

0
@ErsterSchnee

Und wenn B2 leer ist? Der Fragesteller will eine lückenlose Auflistung.

0

so noch das Bild zur ersten Antwort

Über den Berichtsfilter lässt man die Gegenstände weg, für die keine Anzahl eingetragen ist. Das sieht man im Screenshot nicht

 - (Excel, Funktion, Vergleich)

Was möchtest Du wissen?