Excel, wenn(enthält;dann;wenn(enthält;dann;sonst))

5 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Gesetzt dem Fall, du prüfst die Zelle A1

= WENN(A1=5;"Taschenschirm";WENN(A1=6;"Stockschirm";""))

evtl musst du die Zahlen noch in Hochkomma setzen, wenn A1 als Text formatiert ist

Habe mich wohl falsch ausgedrückt, es stehen mehrere Zahlen pro Zelle drin, deshalb funktioniert das so nicht

0
@MichaelTraut

Achso, sorry falsch verstanden....

dann so:

=WENN(ISTFEHLER(FINDEN("5";A1));WENN(ISTFEHLER(FINDEN("6";A1));"";"Stockschirm");"Taschenschirm")
1
@ShitzOvran

Danke, so funktioniert, ich hab immer das erste "dann" zu früh benutzt, habe nämlich: =WENN(ISTFEHLER(FINDEN("5";A1));"stockschirm";WENN(ISTFEHLER(FINDEN("6";A1));"taschenschirm";""))

Vielen Dank :)

0
@MichaelTraut

Übersichtlicher wäre:
=Wenn(istfehler(FINDEN("5";A1));"";"Taschenschirm")
&WENN(ISTFEHLER(FINDEN("6";A1));"";"Stockschirm")

&(kann fast beliebig fortgesetzt werden, ist nämlich keine Verschachtelung!)

und (durch die Einbeziehung der Kommata ins Suchargument verbessert -besonders bei den kleinen Zahlen- siehe meine AW):

&WENN(ISTFEHLER(FINDEN(",15,";A1));"";"Regencape")
&WENN(ISTFEHLER(FINDEN(",151,";A1));"";"Hut, Stroh-, mit breiter Krempe")

0

DH!
So wie die Frage gestellt ist, ist das DIE Lösung.
@MichaelTraut: Wenn Dein eigentlicher Aufbau komplizierter ist, dann beschreibe ihn nochmal genau, oder zeige uns hier in einer Antwort einen Screenshot.
Es gibt da noch andere Möglichkeiten z,B. über WAHL.

1

mit finden() oder suchen(): =WENN(FINDEN(",1 ";H31;1);"stock";"-") und das verschachteln oder mit & aneinanderhängen. finden und suchen unterscheiden sich in Bezug aug Groß-und kleinschreibung(=>Hilfe)

Es gibt aber auch etliche Formeln, die Wildcards akzeptieren, zB: =VERGLEICH("*1, *";H31;0) (ich würde Dir unbedingt empfehlen, die Kommata gegen entweder Komma+Leerzeichen oder durch Semicolon, noch besser durch mehrere Trennzeichen zu ersetzen, damit nicht eine Kommazahl oder Zahlenfolge (wie 321,156) als 1 ausgewertet wird Die Ersetzung kann gesammelt erfolgen, Die Zahl (5/4=)1,25 würde von so einem Austausch nicht erfasst. Auch bei SVerweis sind * und ? zulässig.

um 2 von 26 oder 152 zu differenzieren, kannst Du nach "*,2,*" bzw "*,26,*" oder "*,152,* abfragen, wenn Du mehr als Stockschirm, Taschenschirm, Regencape und Hut hast.
Dann musst du Zuordnungstabellen machen, zB in ZTab!A2:B365 (oder weiteren Spalten, zB in A die Leitzahl (hier als Label, in B die Bezeichnung, in weiteren Spalten zB Preis, Hersteller, Lagerort etc. ).
Das geht dann über die Formel
=index(ZTab!B:B;Vergleich("*,152,*";ZTab!$A:$A;0);1)
(ähnlich SVerweis, aber der Spaltenversatz verändert sich beim Kopieren und die Leitspalte muss nicht zwingend links stehen!) Steht "152" in zB B2, dann musst Du das Suchargument stückeln:

=index(ZTab!B:B;Vergleich("*,"&B2&",*";ZTab!$A:$A;0);1)

Um die allererste 1 zu finden, musst du per Formel ein Komma oder ein 0, davorsetzen.
Und, wie ShitzOphran schon schrieb, evtl ein Wenn(istfehler(Vergleich(...));"nicht findbar";
davorsetzen, also

=Wenn(istfehler(Vergleich("*,"&B2&",*"));"nicht findbar";index(ZTab!B:B;Vergleich("*,"&B2&",*";ZTab!$A:$A;0);1))

0
@Iamiam

"Die Zahl (5/4=)1,25 würde von so einem Austausch nicht erfasst" ist ein

Irrtum!

auch bei normalen Kommazahlen wird der Austausch vorgenommen, es entsteht ein Label! Der Austausch ist aber -entgegen dem oben gesagten- nicht nötig, wenn keine Kommazahlen auftreten, nur das Zufügen des Kommas vor dem ganzen Zellinhalt, damit die erste Zahl richtig ausgelesen wird.

Alles andere stimmt

0

Schau Dir mal die Funktion SVerweis an

Geht nicht, hätte mich auch gewundert, bzw. hätte mich geärgert, da ich es sonst immer zu kompliziert gemacht hätte...

0
@MichaelTraut

Bei 2-3 Alternativen ist eine Wenn Formel am einfachsten, aber mehr ist der SVerweis besser. Wenn du es nicht hin bekommst hast, wird sicher etwas an deiner Formel nicht richtig sein. Ich benutze im meinem Arbeitsalltag sehr oft diese Formel für solche Zwecke und kann daher sagen das es genau das ist was du suchst.

0
@FitnessIT

Ich benutze die auch oft, nur das Problem ist das in den Zellen z. B. 1,2,3,4,6 oder 1,2,3,4,6,15,23 drin steht, deshalb ist Sverweis nicht möglich

0
@FGO65

offensichtlich ist das so, gut gesehen!
Kaum einer denkt dran, wie oft kleine Weiterungen zu großen Problemen führen können!. Lösung: ein , als erstes Glied verbindlich einführen, ggf in eine leere Spalte mit dem Formeltyp:
=","&A1
dann die Formelspalte kopieren und als Werte am ursprünglichen Platz überschreiben oder sich auf die Formelspalte beziehen
(mit index/Vergleich geht das im Ggs zum SVerweis!)

0

Ich habe in Excel 2013 2 Spalten die ich vergleiche. Spalte A ist vollständig und Spalte G nicht. Ich möchte nun Fehlende Zahlen in Spalte M ausgeben kein #NV?

...zur Frage

Excel: gesamte Spalte jewals mal 30% nehmen wie geht das?

Also ich hab in der einen spalte B eine reihe von zahlen und in der nächsten spalte sollen jewals die zahlen plus 30% stehen

...zur Frage

Excel 2010: Wenn-Funktion - Prüfung: Wert in Bereich enthalten?

Hallo Excel-Experten,

ich habe folgendes Problem: In Spalte A und B steht jeweils Text. Diese Werte überschneiden sich teilweise. In Spalte C möchte ich jetzt ein "ja" oder "nein" haben um zu wissen, ob der Wert in der anderen Tabelle enthalten ist. Ich habe mir das in etwa so vorgestellt:

=Wenn($A$1:$A$878 enthält B1;"ja";"nein")

Wie kann ich dieses "enthält" ausdrücken? Evtl. mit einer anderen Funktion verschachteln? Wenn ja, welche? Ich steh total auf dem Schlauch... :-(

Danke & Gruß

...zur Frage

Gutes Computerspiel für mich?

Hey,

Ich such zurzeit nach einem Computer spiel dass:

  • Ab 12 oder niedriger ist
  • nicht so schnell Langweilig wird
  • Einen Online Modus enthält
  • (Nicht Unbedingt) Eine Story enthält
  • Action Enthält
  • Strategisch sein kann
...zur Frage

Was bedeutet ,, Enthält bezahlte Promotion ''?

Ich wollte gerade ein Youtube Video schauen, da stand unten links ,, Enthält bezahlte Promotion ''. Was bedeutet das ?

Danke :)

...zur Frage

Excel in einer Spalte Zahlen weiterführen mit mehreren Zahlen?

Hallo. Ich habe eine Excel Tabelle erstellt und muß in einer Spalte folgendes haben: Regal 1, Ebene 1, Fach 1. Wenn ich die Nummerierung fortsetzen möchte kopiere ich mir die runter aber ich möchte das es so kopiert wird: Regal 1, Ebene 1, Fach 2. Das mit dem Fach soll immer bis 3 gehen und danach soll die Ebene auf 2 umspringen und das Fach fängt wieder bei 1 an. Und immer so weiter bis ich am Ende z.b. das sortiert stehen habe Regal 1, Ebene 7, Fach 3. Gibt es so eine Möglichkeit bei Excel oder muss ich alles per Hand schreiben? Wichtig dabei ist noch das es Alles in einer Spalte steht und ich nicht 3 Spalten verwende! Ich hoffe mein Problem ist halbwegs gut erklärt.

...zur Frage

Was möchtest Du wissen?