Üerstunden Berechnen in Excel

2 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Hallo Mueser,

so, nun zum hoffentlich letzten Anlauf: das beigefügte Bild zeigt Dir alles. Wichtig ist, dass alle Zellen in denen Zeiten stehen als h:mm formatiert sind (hoffe dass das in Deutsch dasselbe ist, also Stunde/Minutenformat. Wird automatisch erzeugt wenn Du in eine Zelle z.B. 8:00 eingibst. Dann kannst Du das Format mit dem Formatpinsel übertragen). Sind alle Zellen in diesem Format, kannst Du auch die 8/24 weglassen da Excel automatisch weiss das es in Stunden rechnen soll.

Denk' noch an Spaltenbreite wenn der 'Gartenzaun' auftaucht.

P.S. Wenn Du das Bild nicht aufmachen kannst, Seite nochmal laden, eventuell mehrmals.

Überstunden berechnen - (Excel, Formel, Überstunden)

uuups, vergessen: Ich habe die Zelle C1 'Regelarbeitszeit' genannt (ich nehme gerne Namen statt Zelladressen), Du kannst stattdessen $C$1 schreiben.

0

Hallo CholoAleman,

hat fast alles geklappt. Nur ein Problem:

wenn ich deine Formel nehme: =WENN(F4>8;F4-8;0) zeigt er mir bei den Überstunden immer 0:00 an, obwohl ich ja eigentlich über 8 bin (also müsste er ja z.B. 1:00 anzeigen). Und wenn ich dann einfach das > in ein < ändere, kommt wieder der Gartenzaun...

Wo ist da der Fehler?

Habe die Tabelle so aufgeteilt:

Datum, Tag, Beginn, Ende, Pause, Arbeitszeit, Überstunden

Also: =wenn(Arbeitszeit>8;Arbeitszeit-8;0) dann kommt immer eine 0:00, obwohl ich eigentlich im Überstundenbereich wäre. Wenn ich dann einfach da ">" in ein "<" ändere, kommt wieder Gartenzaun (#####) obwohl da ja eigentlich z.B. 1:00 stehen müsste...

Danke nochmal und sorry, dass ich so schwer von Begriff bin

0
@Mueser

Hat sich erledigt. Wer lesen kann, ist klar im Vorteil :-) Herzlichen Dank! Große Hilfe !!!

LG

0
@Mueser

Hallo Mueser,

freut mich dass es jetzt klappt. Und kein Problem mit etwas langsam, wir haben alle mal angefangen. Wichtig ist, dass jemand mitdenkt, probiert, experimentiert, nicht nur 'hä verstehe ich nicht, nochmal...' sagt. Dann macht auch das Ratgeben Spaß. Und wenn dann die Lösung da ist, und man auch och gesagt bekommt 'Alles klar jetzt', was will man mehr.

Außer dem Sternchen, auch das freut ;-). Mein 10.

0

Hallo,

ausgehend von Distels Vorschlag, musst Du einfache eine weitere Abfrage einfügen, ob es überhaupt schon was zu rechne gibt. Und das "-" würde ich durch 0 ersetzen, also etwa:

=WENN(F4=0;0;WENN(F4<8;F4-8/24;0))

wobei F4=0 eventuell angepasst werden muss, ich weiss nicht was da auftaucht wenn noch keine Daten der realen Arbeitszeit vorliegen. Wenn dort ein 'Gartenzaun' steht, einfach mal die Spalte breiter machen, denn der Gartenzaun steht für 'Kann ich aus Platzgründen nicht anzeigen'. Ich würde sogar in F4 eine Abfrage machen:

=WENN(C4=0;0;C4-8), wobei C4=Reale Arbeitszeit.

Jetzt kannst Du eine Summe bilden über die Spalte G.

Danke sehr.

Deine erste Formel habe ich verwendet, und funktioniert eigentlich auch... nur in manchen Spalten macht er einfach keine Zahlen rein. Sondern die ###. Ich habe einfach die oberster Zeile bis unten durchkopiert. Deshalb verstehe ich jetzt nicht ganz, warum das bei manchen Spalten nicht gerechnet wird...

0

Und deine Idee, was F4 betrifft ist ja auch ganz gut. Aber F4 rechne ich zzt. wie folgt aus: =D4-C4-E4

Wäre gut, wenn man die beiden Formlen verknüpfen könnte...

Danke

0

Was möchtest Du wissen?