PC Bluescreen Crash auf Grund von ntoskrnl.exe?

 - (Computer, PC, Technik)

5 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Meistens ist fehlerhafte Hardware die Ursache dieser Fehlermeldung:

https://docs.microsoft.com/en-us/windows-hardware/drivers/debugger/bug-check-0x50--page-fault-in-nonpaged-area?redirectedfrom=MSDN" rel="noopener noreferrer" target="_blank">Bug Check 0x50: PAGE_FAULT_IN_NONPAGED_AREA (Windows Debuggers)

Möglicherweise hat ein RAM-Riegel den Geist aufgegeben. Es könnte aber auch gerne Mal ein Treiber abgestürzt sein. Um das zu analysieren, wäre es sinnvoll, zuerst einmal die Chipset- und Grafikkartentreiber zu deinstallieren, den Rechner neu zu starten und dann die neuesten Treiber zu installieren.

Falls das nichts bringt, wäre ein mehrstündiger Test mit diesem Programm hier:

http://www.drwindows.de/hardware-too...ndows-pcs.html

Hast du schon mal chkdsk /f /r und sfc /scannow probiert?

Kannst du mal die Minidump Datei senden?

Hast du es schonmal es mit Ubuntu probiert?

 chkdsk /f /r 

was muss ich machen damit ich den aufführen kann ?

Festplatte muss entsperrt sein



0
@GoD4EVER

Du musst CMD als Admin starten, Powershell sollte auch klappen.

1

Hi GoD4EVER,

ich wollte fragen ob Du die Ursache gefunden hast. Ich habe einen recht ähnlichen PC (i9 9900K, MSI GTX 1080 Ti Gaming X, 16 GB Patriot Viper DDR4-3200, MSI MPG Z390 Gaming Edge AC, 1 TB Crucial M500) bei dem ich seit Anfang Februar 2020 mehrere Bluescreens mit Bezug auf die ntoskrnl.exe erlebt habe. Die Bluescreens traten nur auf, wenn der PC (einige Zeit) im Leerlauf lief - kein einziger während der Benutzung.

Nach dem Kauf von Board, RAM, CPU und der Win 10 x64 Neuinstallation im Juli 2019 hatte ich bis Februar 2020 keine Bluescreens. Alle anderen Komponenten sind teilweise seit Jahren ohne Probleme in Gebrauch.

1) Es ist möglich, dass ich zuvor keinen Bluescreen erlebte, weil ich den PC immer nur kurz nach der Arbeit benutzte und dann ausschaltete. Derzeit nutze ich den PC intensiver und beobachte daher die Bluescreens möglicherweise erst jetzt.

2) Erst im Januar stellte ich fest, dass die CPU nicht heruntertaket und unabhängig von der Last konstant bei 4.7 GHz läuft. Dann habe ich mich mit den Stromspareinstellungen von Windows nochmal beschäftigt, sodass die gewünschte dynamische Taktanpassung eintrat. Hier habe ich alle Einstellungen auf maximales Stromsparen eingestellt. Dies könnte das Auftreten der Bluescreens im Leerlauf ab Februar ermöglicht haben.

3) Ich halte Windows, Treiber, Programme immer auf dem aktuellen Stand. Daher ist es auch möglich, dass diese Aktualisierungen Ursache der Bluescreens ist. Das MSI Dragon Center machte mich im letzten halben Jahr glauben, dass ich immer die aktuellsten Treiber installiert hatte. Nach den Bluescreens habe ich auf der MSI-Website noch neuere Treiber gefunden und installiert. Jedoch hatte dies keinen Einfluss auf die Bluescreens.

4) Die CPU habe ich mit Prime95 einen Tag getestet. Den RAM habe ich mit Memtest86 über 2.5 h mit 48 Tests geprüft. Dass ich keine Probleme gefunden habe, deckt sich mit dem fehlerfreien Betrieb bei der Benutzung.

5) "DISM /Online /Cleanup-Image /ScanHealth", "SFC /scannow", "chkdsk C: /f /r" zeigten keine Probleme der Windows-Dateien oder des Dateisystems. Zusätzlich habe ich nach jedem Bluescreen auch nach Malware suchen lassen.

6) Im Gerätemanager habe ich auch unter den versteckten Einträgen nach problematischen Treibern gesucht. Dies und Driverview x64 zeigten keine Auffälligkeiten. Driverview x64 listete nur eine überschaubare Zahl nicht windowseigener Treiber.

a) Nach der Antwort von Kunzinger habe ich die Windows-Energiespareinstellungen zurückgesetzt. Erstaunlicherweise blieb die dynamische Taktung der CPU aktiv. Nichtsdestotrotz kann ich aufgrund der kurzen Zeit seit der Änderung nicht sagen ob die Windows-Energiespareinstellungen Ursache für die Bluescreens waren.

b) Des Weiteren habe ich einen ähnlichen Fall für die Kombination aus CPU, RAM, Board und Bluescreens gefunden: https://answers.microsoft.com/en-us/windows/forum/all/windows-10-bsods/9cd0bf3a-11bc-4ede-be2f-3a8fc76070d6?page=3. Hier half die Anpassung der CPU Load Line Calibration um die Bluescreens zu beheben. Dieser Artikel nutzte die Hinweise aus einem spannenden Beitrag im MSI-Forum (https://forum-en.msi.com/index.php?topic=327051.0) der recht gut zur Problemlage passt.

c) Ein Fall bei dem auch Probleme im Leerlauf auftraten wurde durch das Deaktivieren von EIST und C1E gelöst: https://forums.tomshardware.com/threads/my-pc-keep-freeze-if-left-idle-or-low-usage-like-browsing.3523769/. Der unter b) genannte MSI-Forum-Eintrag deutet auch auf den Einfluss von EIST hin. Gezeigt wird zudem, dass mit einer Zusatzkernspannung (CPU Core Voltage Mode = Adaptive + Offset) EIST keine Bluescreens mehr verursacht. Im Forum wurde spekuliert, dass ein Spannungsreglermodul des Boards nicht optimal arbeiten würde und so die Zusatzspannung das System bei niedrigen Kernspannungen im Leerlauf stabilisiert.

Im Fall dass, ein neuer Bluescreen trotz Zurücksetzen der Windowsenergieeinstellungen (Option a) auftritt, würde ich Option b) und c) testen und wieder berichten. Dass bei Dir das identische Problem bei nahezu gleichen Komponenten auftritt, macht mir Hoffnung die Ursache zu finden. Ich bin gespannt ob Du bereits eine Lösung gefunden hast oder ob Dir meine Antwort etwas weiterhilft.

Woher ich das weiß:eigene Erfahrung

Nein leider noch keine Lösung aber danke für deine Antwort.

bis auf den Beitrag von "framesjames" hört sich sehr interessant an !

Mfg

1

Hallo GoD4EVER,

ich habe erst gestern Abend das Lesen des Beitrags im MSI-Forum abgeschlossen. Die meiste Zeit konnte man nicht auf das Forum zugreifen, sodass ich die vierzig A4-Seiten im Google-Cache gelesen habe. Ich wollte hier nur kurz die Quintessenz aus dem Beitrag (https://forum-en.msi.com/index.php?topic=327051.0;all) dokumentieren:

  • Intel bestätigte, dass ein Problem mit dem MSI MPG Z390 Gaming Edge AC in Kombination mit dem i9 9900K vorliegt: sie konnten das Problem reproduzieren - mit Boards anderer Hersteller jedoch nicht.
  • Am 20. Dezember 2019 händigte MSI dem Ersteller des Threads ein Test-BIOS aus (A72) welches die Probleme weitestgehend behebt. Dieses BIOS steht derzeit leider noch nicht auf der Support-Website für das Board (Stand: 23.02.2020).

Mittlerweile haben sich weitere Leute mit dieser Problematik im Forum gemeldet. Als Optionen stehen zur Verfügung:

1) MSI um das A72-BIOS für das MPG Z390 Gaming Edge AC bitten.

2) Leichte Zusatzspannung bei weiterhin taktabhängiger CPU-Spannung: "CPU Core Voltage Mode" auf "Adaptive + Offset" umstellen und den Offset auf "+ 0.035 V" stellen.

3) Konstante CPU-Spannung unabhängig vom Takt: die "CPU Core Voltage" auf 1.325 V - 1.300 V einstellen.

Der Hintergrund warum das bisherige BIOS von MSI zu den Bluescreens führt hat "falkentyne" (Reply #128) technisch beschrieben.

Woher ich das weiß:Recherche

Vielen Dank !

1

ich bin mir sicher, du hast schon einiges probiert.

Aber spontan würde mir da nur irgendein Energiespartool ausm Bios einfallen, was das verursacht, bzw. ein zu hoher RAM Takt.

mit einem 9900k und Corsair Dominatior will man scheinbar außerordentliche Leistung haben.

Setz mal im Bios alles auf Default zurück und/oder nimm einen viel niedrigeren RAM Takt.

statt 3200 Mhz auf 2600 (2666 Mhz)

BIOS auf Default habe ich letztens auch probiert

2

Das Problem hab ich auch Bluescreen immer im lehrlauf echt komisch.

Hast du schon ne Lösung?

Nein habe nix neues dazu gefunden aber ich lasse jetzt einfach immmer ein kleines Programm offen dann kommt es dazu nichtmehr

1

Ende Februar 2020 veröffentlichte MSI ein neues BIOS A.70 (7B17vA7) für das MPG Z390 Gaming Edge AC, welches aber auf der Website auf Anfang Januar zurückdatiert wurde. Für die meisten Benutzer hat es das Problem mit dem BSOD behoben (siehe: https://forum-en.msi.com/index.php?topic=327051.0;all#lastPost). Zwar schreibt MSI in der Beschreibung der neuen BIOS-Version nichts davon, aber die BSOD-ursächlichen falschen CPU-Spannungen und Lastlinien-Kalibrationen sind nach der BIOS-Aktualisierung verändert. Ich habe nach der Aktualisierung vor zwei Monaten keinen einzigen BSOD mehr erhalten.

1

Was möchtest Du wissen?