Excelfunktion für Materialliste?

...komplette Frage anzeigen Excelliste - (Computer, Excel)

4 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Hallo,


versuche diese Formel in G10 und ziehe sie einfach runter =)

=SVERWEIS($B$9;$A$3:$B$7;2;0)*B10+SVERWEIS($C$9;$A$3:$B$7;2;0)*C10+SVERWEIS($D$9;$A$3:$B$7;2;0)*D10+SVERWEIS($E$9;$A$3:$B$7;2;0)*E10+SVERWEIS($F$9;$A$3:$B$7;2;0)*F10

oder

=SUMMENPRODUKT($B$3:$B$7;MTRANS(B10:F10))

2. ist eine Matrixformel, muss mit STRG+UMSCH+SHIFT abgeschlossen werden!

Grüße,


iMPerFekTioN

bei der geplanten Liste mit 50 Materialien ist die Sverweislösung aber schon recht unperformant

2
@Jackie251

Jap, da hast du natürlich recht,

ich wollte trotzdem einfach eine weitere Lösung zeigen, die auch die Syntax und die Logik etwas erklärt =)

Matrixformeln sind eigentlich in 99% immer komfortabler :p

1

Dir auch danke! So ähnlich hatte ich meine Verweisformel auch zum Schluss auch. Nur irgendwo immer noch einen Denk-Fehler. Ist halt sehr unübersichtlich.

1
@Kaskura

Ja, wie gesagt  :), Matrixformeln sind besser :p

Jackie251 war leider etwas schneller mit der Antwort hat aber exakt die gleiche Formel genutzt :p

0
@Jackie251

Nö, :d

aber der Fairness nach solltest dann du die Hilfreichste Antwort bekommen wenn sie vergeben wird, da du ja die richtige Antwort hattest, was ja hilfreich war und das eben als erste/erster ;)

0

Tut mir leid.... Nicht verdient!

0

das geht so

=SUMMENPRODUKT($B$3:$B$7;MTRANS(B10:F10))

in G10 und dann mit Strg+Shift+Enter die Zelle abschließen

nach unten ausfüllen, fertig

ich lese gerade in den Kommentaren, das du ggf auch Änderungen vornehmen willst, wie wegfall von Materialien.

Dann wäre es wohl sinniger die Materialliste zu trennen und als Datenbank auf ein anderes Tabellenblatt zu legen. In einer Hilfzeile unter der Zeile 9 werden dann die Kosten je Material automatisch aus der Datenbank eingetragen und die Summe der Kosten geht dann durch ein Summenprodukt ohne transponierte Matrix.
Oder, falls es je Produkt nicht viele Materialien gibt es aber viele Materialien sind (oder wenn bestimmte Produkte selbst wieder Materialien anderer Produkte sind) dann würde ich einfach ein paar Spalten für die Materialien lassen (immer abwechseln mit Materialtyp und Anzahl) und in Hilfspalten dann die Materialkosten ermitteln und summieren.

2
@Jackie251

Oder die Materialien auch quer stellen. Würde sowieso besser passen, weil man die Oberste Zeile dann auch fixieren könnte.

2

Top! 

MTrans habe ich gesucht. Ich habe mit SVERWEIS, WVERWEIS und VERWEIS "rumgedoktort".

Ich kann auch Problemlos Produkte und Material zufügen da der Bereich sich mit vergrößert oder verkleinert wenn ich das über Spalte/Zeile hinzufügen oder löschen mache.

Vielen Dank!

2

So wie du das vorhast, wird das nciht wirklich mit Excel klappen. Da wirds wahrscheinlich Access sein müssen.

Oder aber du nimmst es in Kauf, dass die Formeln geändert werden müssen, wenn Materialien hinzukommen. Kurzfristig umgehen kann man das, wenn man bereits jetzt schon mehrere leere Dummy-Materialien anlegt.

Inwieweit das dann sinnvoll ist sei mal dahingestellt.

ich sehe nicht wozu bei der Aufgabe Access erforderlich sein sollte.
Ja Excel ist keine Datenbank. Dennoch ist diese Aufgabe doch nicht deutlich im Excelstandard, da wird noch nix verbogen.

1
@Jackie251

Theoretisch reicht eine Matrix vollauf und ist ja genau für sowas gedacht.

Das Problem ist eben nur, wenn er die Formel nicht ändern will. Spätestens wenn da neue Materialien oder Produkte dazukommen, muss die Matrix erweitert werden. Im gewissen Maße macht das Excel zwar automatisch, kann aber auch mal daneben gehen.

0

Was möchtest Du wissen?