Excel =WENN Uhrzeit zwischen, dann...?

6 Antworten

xl erlaubt seit einiger Zeit die Eingabe im Uhrzeitformat (in Gänsefüßchen*1). Weiß allerdings nicht, was du unter Bewegungszeit verstehst. Wenn das die Kommen-Zeit ist, dann:

=wenn((KommenZelle>"5:00")*(KommenZelle<"13:30"*1);"Frühschicht";"")&Wenn((Kommenzelle>="13:30"*1)*(Kommenzelle<"21:00"*1);"Spätschicht";"")

Das ()*() ist ein funktionales UND, die Zeiten kannst Du selber variieren (hab hier 1h vor Schichtbeginn/-Ende "umgeschaltet")

Da nur eine der beiden Möglichkeiten zutreffen kann, geht ein unverschachteltes aneinanderhängen von zwei unabhängigen WENNs, auch bei Kommen-Zeiten ausserhalb 5:00-21:00 stellt sich die Zelle leer dar (tatsächlich ist natürlich die Formel drin!)

mit dieser Art von Formelanordnung kannst du sie sehr kurz halten und effektiv arbeiten

Du fragst zweimal < 14:30 ab.

Für die Spätschicht musst du beide Vergleichsoperatoren drehen.

Der Übersicht halber würde ich nicht so tief mit WENN schachteln. Du könntest besser UND verwenden, wenn zwei Bedingungen erfüllt sein müssen.
___________________

Generell  würde ich den Vergleichsoperator nicht innerhalb der Formel wechseln und entweder von der spätesten Zeit mit > Abfragen beginnen oder von der frühesten Zeit mit < Abfragen.

Wenn Zeiten hier keine Ausnahme darstellen sollten, kannst du sogar besser den SVERWEIS verwenden.

Tipp: Mach eine Spalte für Frühschicht und eine für Spätschicht und definiere die Formeln zunächst einzeln für beide Schichten. Wenn alles passt, kannst du die Formeln relativ leicht zusammenfassen.

1

=WENN((A1>=ZEIT(6;0;0))*(B1<=ZEIT(14;30;0));"Frühschicht";WENN((A1>=ZEIT(14;30;0))*(B1<=ZEIT(22;0;0));"Spätschicht";"Fehler"))

In A1 steht die Ankunfts- und in B1 die Verlass-Zeit.

Bin mir nicht sicher, wie genau du mit Bewegungszeit hantierst <.<

Hast du nur 1 Zeit pro Mitarbeiter? Wenn ja, wie kommt diese zustande?

Lg Tobi

Was möchtest Du wissen?