Excel: Mit MONAT(Bereich) nur zB den "Januar" zählen bringt falsches Ergebnis bei leeren Zellen?

2 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

=SUMMENPRODUKT(($C3:$C1000<>"")*(MONAT($C3:$C1000)=MONAT(F$3)))

Klappt es?

Woher ich das weiß:Beruf – IT-Administrator (i.R.)

Ja... (ich hab da noch ein Bezug zu einer anderem Blatt, hier aber weggelassen)

2

Anstelle von $C$3:$C$1000<>""
habe ich ISTLEER($C$3:$C$1000) also mit NICHT() damit es korrket multiplizieren kann, zwischenzeitlich gebastelt.

Ist das gleich oder ist meins einfach nur komplizierter?

1
@Hirnlos

Letzteres.
Meins ist die Version für Schreibfaule 😉.
Deins ist die "offizielle" Form.
Sollte keinen Unterschied machen.

3

Danke fürs

0

Vorschlag. Eine Hilfsspalte für den Monat einfügen und mit =Summewenns summieren lassen.

Woher ich das weiß:eigene Erfahrung
 - (Fehler, Excel, Formel)

Ja, Extraspalte will ich lieber nicht, aber danke.

1

Es geht auch ohne Hilfsspalte:

=ZÄHLENWENNS(C:C;">=01.01.2020";C:C;"<=31.01.2020")

Funktioniert so natürlich nur, wenn nur ein Monat gezählt werden soll (und nicht jeder Januar von mehreren Jahren)

Wenn du den Monat in einer Zelle bestimmen willst (F3), nimmst du statt der absoluten Datumsgrenze die DATUM-Funktion

=ZÄHLENWENNS(C:C;">="&DATUM(2020;F3;1);C:C;"<="&DATUM(2020;F3+1;0))

1
@DeeDee07

Gute Idee, danke für deine Ergänzung.

0

Was möchtest Du wissen?