Excel: Letzter Wert der Tabelle addieren - kann mir da einer weiterhelfen?

... komplette Frage anzeigen

4 Antworten

Gehen wir davon aus, dass der zu addierende Betrag in XY1 steht.

In der Spalte (A) mit dem Betrag schreibst du:

A2: =WENN(UND(A3="";XY1>0);<Betrag>+XY1;<Betrag>)

In Worten: Wenn das direkt unten angrenzende Feld leer ist und der zu addirende Betrag größer als 0, dann addiere den Betrag zu dem, der hier sonst stünde, ansonsten schreibe in diese Zelle ganz normal den Betrag, ohne etwas zu addieren.

Wenn du die Beträge als fixe Werte vorliegen hast, kannst du eine Hilfsspalte einfügen mit der o. g. Formel und die Originalwerte später ausblenden.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von nextwifey2k7
26.11.2015, 14:12

Danke für die schnelle Antwort. Leider ist es nicht so einfach, da ich den Betrag bzw. Zeile auf den XY1 hinzuaddiert werden soll nicht kenne. Ich weiß nur die Spalte, die Zeile kann sich je nach Datum variieren. Der letzte Betrag in der Spalte könnte L4 sein, aber auch L90.

1

Da ich nicht weiß wie Deine Formelbezüge gestaltet sind, rate ich dazu, den Restwert (also die 5000) aus dem Rechenbereich herauszuverschieben, zB nach U1 (kannst später ausprobieren, wo überall es keinen Fehler gibt)

Dann gibst Du in T7 die Formel ein:

=wenn(und(E8="";E7>0);T1;0)

hoch- und runterziehen

Der Restwert erscheint nun nur einmal in der letzten gefüllten Zeile und Du kannst Deine Formel in L(7) einfach erweitern um +T(7) (ich bin davon ausgegangen, dass der Restwert nur einmal dazuaddiert werden darf, sonst ergäbe die Frage vermutlich keinen Sinn)

Anstatt E8║E7 kannst Du natürlich auch D8║D7 verwenden, sollte das Datum in die Berechnungen einfließen.

Das sollte es dann auch schon gewesen sein!

Wenn nicht, melde Dich nochmal!
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
26.11.2015, 23:13

Schlamperei! natürlich nicht T1, sondern U1, also

=wenn(und(E8="";E7<>"");U1;0)

das <>"" habe ich nur der Systematik wegen so formuliert, es geht auch >0, da auch Texte >0 sind

0

So, anbei nochmal als Bild die Tabelle. In der Spalte T, ist ein Restbuchwert von 5000. Der muss in L7 hinzuaddiert werden. Und Zwar immer in der letzten Zeile. Es ist nur ein Zufall dass die letzte Zeile L7 ist. Es könnte auch, L12 sein, dann müssen die 5000 in L12 hinzuaddiert werden. Ich hab es leider mit deiner Formel nicht geschafft, und befürchte das wie übereinander reden.

Antwort bewerten Vielen Dank für Deine Bewertung

Nicht besonders elegant, und kann vielleicht auch schiefgehen, aber im Versuch hat's geklappt:

=VERWEIS(9,999999E+307;L:L)

Vorausgesetzt, ich habe dich richtig verstanden, und du suchst den letzten Eintrag in Spalte L.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von nextwifey2k7
26.11.2015, 14:51

leider nicht, ich brauch ja noch den Bezug zu den Restwert von 5000. Die müssen ja in der letzten Zeile hinzuaddiert werden. Danke für deine Antwort

0
Kommentar von nextwifey2k7
26.11.2015, 15:02

Die Formel kann beliebig stehen. Das Ergebnis muss nur in der letzten Zeile im L stehen. In dem Fall 15000 + 5000. Die Formel müsste also automatisch den Restwert in die letzte Zahlung hinzuaddieren.

0

Was möchtest Du wissen?