XAMPP Apache startet nicht bzw. bleibt hängen?

3 Antworten

es sieht für mich so aus, als ob durch vorgehende installationsversuche, die wohl erfolgreich waren, die entsprechenden services (hintergrundprozesse), die wohl auch automatisch beim start von windows gestartet werden, den entsprechenden start der neuinstallierten services behindert: "... dienst mit falschen pfad erkannt"

versuch mal per taskmanager alle verdächtigen services (dienste) - ApacheServer, MySQL, ... zu stoppen und dann per XAMP - tool neu zu starten.



Das Control Panel kann auf die einzelnen Komponenten nicht zugreifen, weil die Pfadangaben nicht stimmen. Was genau nicht stimmt, so auch nicht nachvollziehen kann. XAMPP nochmal deinstallieren und sauber installieren. 


Habe ich jetzt schon 3x, und jedes Mal kommt das gleiche... Ganz normal ohne was zu ändern unter c:/xampp installiert

0

Und lustigerweise sind alle Dateien, die er benennt, vorhanden

0
@Croghs

Welches OS verwendest du? Bin etwas überfragt. Ich selber nutze XAMPP schon länger nicht mehr, daher jetzt nicht alles auf dem Schirm habe. Vielleicht mal Alternativ AMPPS oder WAMP installieren. 

0

Hast du evtl. Skype am laufen?

Ich habe Skype installiert, aber nicht am laufen...

0
@Croghs

Spielt keine Rolle ob Skype am laufen ist oder nicht. Testweise mal einen anderen Port zuweisen. 

0
@medmonk

Ich hab jetzt mal die 79 genommen, geht immer noch nicht

0
@Croghs

Wenn du den Port 79 hast dann sollte der Apache starten und dann musst du auch den localhost mit Port 79 aufrufen! http://localhost:79

Versuche mal den Port 8080

0
@yerooke

Quatsch! In der Adressleiste muss der Port überhaupt nicht aufgerufen werden. Mit localhost landet man direkt im root-Verzeichnis (htdocs). Wie dem auch sei, der Apache läuft nicht. Daher auch kein Zugriff auf dessen Verzeichnisse.  

0
@medmonk

Beschäftige dich mal näher mit Protokollen und Ports. Natürlich musst du explizit den Port angeben wenn dieser geändert wird! Bei Port 80 musst du das nicht tun weil die Webrowser diesen automatisch aufrufen wenn kein Port angegeben wird. Also nicht gleich Quatsch schreiben sondern erkundigen und lernen!

0

Warum funktioniert Xampp nicht mehr?

Hallo, ich hätte da ein Problem, kann auf meine Daten nicht zugreifen. Kenne mich mit Xamp nicht aus, mir wurde es installiert.

MySQl läßt sich nicht starten und folgender Eintrag erscheint in meinem Fenster:

Initialisere Control Panel Windows Version: Windows 7 Professional SP1 64-bit XAMPP Version: 1.8.2 Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ] Dein Benutzerprofil besitzt keine Administratorenrechte! Das reicht aus für die meisten Anwendungsfunktionen, aber wann immer du etwas mit Windows-Diensten tun möchtest, wird eine Sicherheitsabfrage erscheinen oder etwas wird garnicht erst funktionieren! Also denke daran diese Anwendung mit Administratorrechten zu starten! XAMPP Installationsverzeichnis: "g:\box 20 - webserver\xampp-1-8-2\" ACHTUNG: Der XAMPP Installationspfad enthält Leerzeichen. Dies könnte die Funktionalität von Programmen/Scripten beeinflussen Voraussetzungen werden geprüft Alle Voraussetzungen sind erfüllt Initialisiere Module Das FileZilla Modul ist deaktiviert Das Mercury Modul ist deaktiviert Starte Check-Timer Control Panel bereit Versuche Apache zu starten... Statusänderung erkannt: gestartet Versuche MySQL zu starten... Versuche MySQL zu starten... Statusänderung erkannt: gestartet Statusänderung erkannt: gestoppt Fehler: MySQL wurde unerwartet beendet Ursache könnte ein geblockter Port, fehlende Abhängigkeiten, fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein. Drücke den Logs Button um error logs zu sehen und prüfe im Windows Event Viewer für weitere Hinweise Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.

Als ich heute wieder einmal auf Xamp zurückgreifen wollte merkte ich, dass es nicht klappt. Was muss ich tun damit Xamp wieder richtig funktioniert?

Danke im Voraus

...zur Frage

Apache startet nicht auf El Capitan?

Hey Leute. Ich habe El Capitan Version 10.11.5 (15F34) und will über XAMPP ein MagentoShop Simulieren. Letzteres will ich über ein Bitnami Package machen.

Problem ist das ich über XAMPP weder Apache noch MySQL starten kann. Ich habe versucht Apache über das Terminal zu starten. Alles ausser " sudo /Applications/XAMPP/xamppfiles/bin/apachectl start" hat nicht funktioniert. Direktes ansprechen mit "sudo apachectl start" etc. ist nicht möglich gewesen.

Nun da Apache On war, habe ich versucht das Magento Packet drauf zu hauen. Während der Installation hatte ich dann auf einmal nicht die erforderlichen Rechte ( bin Admin ) um das Packet in den XAMPP Ordner zu hauen der in Applications liegt. Vor dem Start von Apache ging das, die Installation ist natürlich daran gescheitert das Apache nicht erreichbar war ( dachte bis dahin das beim h hochfahren des Systems Apache automatisch startet....). Nach Neustart des Systems, habe ich nun das Problem das Apache wieder nicht startet und -der Terminal spuckt mir aus das ich nicht die nötigen Rechte besitze. Über die XAMPP Applikation geht auch nix mehr (??). Ich kann nicht einmal den Port ändern . . . :-/

Hatt jemand deinen konstruktiven Vorschlag/Tipp für mich?

Danke euch...!

...zur Frage

Apache und MysQL mit c# starten?

Hallo,

Wie kann man Apache und MySql in c# mit Buttons starten. Sprich wie bei XAMPP das man auf Buttons drückt und MySql und Apache sich starten.

Danke im vorraus

...zur Frage

Xampp MySQL Datenbank "Zugriff verweigert"?

Hallo! Ich habe bei Apache und MySQL in allen Config Dateien (my.ini + config.inc.php den selben User, das selbe Passwort und den selben Port eingestellt. Wenn ich nun zu meiner Seite verbinde und PHPMyAdmin aufrufen will kommt immer nur dieser Screen: http://puu.sh/jmkGp/591d67c2c1.png Alle Namen sind gleich und auch passwörter, trotzdem will er nicht :/ Braucht ihr hier noch den Inhalt der Configs? Ich sollte anmerken, dass Ich wenig Erfahrung im Gebiet MySQL/Php habe, trotzdem brauche ich eine Datenbank :/ Danke!

...zur Frage

Was möchtest Du wissen?