OpenOffice: Zeilen multiplizieren über mehrere Spalten

5 Antworten

{=SUMME(B3:B35*C3:C35)}

geschweifte Klammern wie immer nicht mit eingeben sondern durch abschliessen der Formel mit der  Tastenkombination Strg+Shift+Enter erzeugen.

Ich versuche es etwas zu verdeutlichen.

 

Spalte A enthält ausschließlich Mengenangaben, hingegen hat Spalte B den Stückpreis integriert.

Am Ende sollen also pro Zeile A*B gerechnet. Dies geschiet jede Zeile dadrunter genauso. Natürlich könnte ich nun hinter jeder Zeile eine Formel setzen, die eine Summe Bildet und die einzelnen Summen wiederrum zusammenzählen.. Jedoch ist das nicht der Sinn des ganzen. Ich möchte diese Aufgabe mit nur einer einzigen Formel lösen, die oben angegebene Formel löst diese Aufgabe bis zu einem gewissen Grad hin, jedoch ist sie weder schön noch funktioniert sie auf Dauer.

 

Also nochmal kurz gefasst:

(A1*B1)+(A2*B2) nur ohne Begrenzung.

So:

=SUMMENPRODUKT(B3:B35;C3:C35)

Oder nicht?

nein, ich kenne nur die Formel z.b. =SUMME (B3:B35) und =(C3:C35) halt einzeln.DANN die erste ausgerechnete multiplukation nach unten ziehen. Kannst auch die ersten 2 markieren und dann nach unten ziehen.  Mit der Aussage SUMME, addiert das programm. DU wolltest doch aber vorher Multiplizieren. Also ERST! =(B3*C3) und =(B4*C5),....(waagerech multiplizieren) und senkrecht mit dem =Summe (D3:D35) . das Zeichen":" (doppelpunkt steht für BIS zur zelle....Du kannst auch einzelne zellen summieren. Indem du =Summe( und dann die einzelnen zellen anklickst, mit der gedrückten STRG taste kannst du dann auch ziehen. Entweder senkrecht oder waagerecht)

0
@WhiteAngel1986

Sorry, aber WAS passt Dir an meiner Formel nicht?

(Probiere es mal aus)

Sie macht IMHO genau DAS, was der Fragesteller nachgefragt hat.

Zumindest bring sie dasselbe Ergebnis wie seine lange Formel.

Kann es sein, dass Du mein "Oder nicht?" falsch verstanden hast? Ich wollte den Fragestellen damit nur auffordern, eine Rückmeldung zu geben.

Schau Dir den Assi zu SUMMENPRODUKT mal an. Damit kann man sehr viel machen.

0
@Oubyi

sy, habe nicht gesehen das jemand anderes die antwort gab. Dachte er selbst hat es so probiert. Nach deiner anwort habe ich es in meinem excel auch so versucht und es kam eine fehlermeldung. Hatte warscheinlich vorhin was falsches eingegeben. (auch wenig zeit gehabt). Als ich es eben nochmal probierte, (direkt kopiert) ging es. Wie gesagt,...sy!

LG

0
@WhiteAngel1986

Kein Problem.

Hatte ich mir fast so gedacht.

Mal abwarten ob Ocian noch eine Rückmeldung gibt.

LG (;o)

0

Meine Arrayformel ist kürzer :-P

Hinweis an den Fragesteller: Nimm bitte die Summenproduktformel von Oubyi, da Array-Formeln gerade bei der Bearbeitung oftmal Probleme haben wenn man z.B. gerne mal vergisst sie nach dem Bearbeiten mit Strg+Shift+Enter abzuschließen. Oubyis Formel ist deutlich unanfälliger.

0
@augsburgchris

Ich arbeite auch lieber mit Arrays, aber da selbst mir (;o)) der Lapsus mit dem Enter in der fertigen Formel schon passiert ist, versuche ich hier möglichst darauf zu verzichten

0

Was möchtest Du wissen?