Hallo zusammen, ich brauche dringend eine Formel in Excel. siehe Beschreibung?

5 Antworten

Angenommen Deine Liste fängt in A1:B1 an.
Dann in C1 diese Formel:
=B1
In C2 diese Formel:
=WENN(A1=A2;C1&"/"&B2;B2)
und runterkopieren.
In D1 diese Formel
=WENN(A1=A2;"";"x")
und runterkopieren.
Jetzt Spalte D nach x filtern, A:C kopieren und an anderer Stelle mit Inhalte einfügen: Werte,  wieder einfügen. Mittlere Spalte löschen,.

Klappt es?

Hi,

richtig gut! aber Fast haben wir es geschafft.

In Spalte C ist jetzt anstatt  zum Beispiel YC/ZT , steht da 2/YC , Excel hat erkannt das diese ID 2 mal vorkommt.

Der letzte Feinschliff fehlt :(

0
@fiti40

Ich denke, das hast Du etwas falsch umgesetzt.
Ich gebe Dir mal hier eine neue Antwort, damit ich einen Screenshot anhängen kann.

0

Zunächst würde ich mit Gruppenwechsel in einer neuen Spalte kumulieren

C1: =B1
C2: =WENN(A1=A2;C1&B2;B2)

(ungetestet)

Jetzt kannst du dir in Spalte C die Zeilen markieren, in denen die letzte ID einer Gruppe steht und anschließend danach filtern.

Vielen dank für die rasche Antwort. Aber ich habe das nicht so richtig verstanden :(

0
@fiti40

Ich meine das so wie Oubyi. Vielleicht verstehst du seine Erklärung besser.

1

@Oubyi

vielleicht war das Beispiel von mir einfach nur schlecht : /  (sorry mein Fehler)

oder ich hab irgendwo ein tippfehler :(

für weitere Tipps wäre ich sehr dankbar

 - (Computer, Informatik, Microsoft)

Ließ nochmal meine Antwort richtig:

Dann in C1 diese Formel:
=B1
In C2 diese Formel:
=WENN(A1=A2;C1&"/"&B2;B2)

1

Wie doppelte Werte in Excel extrahieren und erkennen mit Index, Sverweis mehrere Bedingungen?

Wie doppelte Werte in Excel extrahieren und erkennen mit Index, Sverweis mehrere Bedingungen?

Hallo liebe Community,

ich stehe momentan vor einem schwierigen "Doppelt-Werte-Suchen" Puzzle und hoffe sehr, dass ihr Lösungsideen habt.

Die beigelegte Bilddatei zeigt ganz genau mein Problem , es sind Zwei Fragen:

1) Wie kann ich die Doppelten Werte von Spalte A in Spalte E anhand einer Formel extrahieren (nur einmalige Werte, nicht alle doppelten)?

2) Ich möchte in E4 eine Formel eintragen, die z.B. "Delete" herausgibt, WENN: a) eine ID in Spalte A mehr als 1mal vorkommt WEITERHIN soll: b) in Spalte E (wenn ich die Formel runterziehe) nur 1mal "Delete" stehen pro Doppeleintrag (bzw. immer 1mal weniger "Delete" als es in Spalte A insgesamt Doppelwerte gibt) c)... d)... e)...

Es gibt einige Bedingungen/Szenarien an die ich die Formel knüpfen möchte, bin nicht sicher ob da Zwischenschritte/-Spalten notwendig sind eventuell... Ich hoffe ihr kennt eine mögliche Lösung, denn meine Tabellen haben hundertausende Zeilen und wirklich viele derartiger Fälle...

Danke sehr für Eure Unterstützung:-)

...zur Frage

Excel 2003: Mehrere Wenn Formel hintereinander geht das? Wenn ja wie?

Moin Leute,

ich habe folgendes Problem:

Spalte A(ID): a1, b1, g3, x2, z6, h1, t2, z4, m5

Spalte B(Zeiten): 30, 55, 30, 77, 23,...

Jetzt möchte ich mit einer Formel den Lohn berechnen.

Wenn der eine 1 in seiner ID stehen hat bekommt er 50 € die Stunde, wenn eine 2 in der ID dann 40€ und alles andere 30€ die Stunde.

 

Jetzt habe ich geschrieben

=WENN(A1="1"; B1*50; B1*30)

Ich frage mich wie ich jetzt das mit der 2 einbaue. Kann mir vllt jemand helfen?

 

Danke im Voraus

...zur Frage

Excel Makro VBA Zellen vergleichen und bei Übereinstimmung Zeile löschen

Hallo miteinander, kenne mich leider gar nicht in VBA aus und brauche dringend Hilfe für ein Projekt. Ich beschreibe mal kurz mein Problem: Im Worksheet "Objekt löschen" in zeile C6 soll eine Objekt ID eingegeben werden. Diese muss dann mit den Objekt IDs im Worksheet "Objektdaten" in der Spalte B verglichen werden. Wenn sie dort existiert, dann soll die gesamte Zeile, in der sich die eingegebene ID befindet, gelöscht werden. Das ganze soll funktionieren, indem man auf eine Schaltfläche auf dem 1. Tabellenblatt klickt. Ich hoffe, das war jetzt einigermaßen verständlich erklärt. Freue mich sehr über eure Hilfe Danke :) Rosi

...zur Frage

Access Abfrage jede ID nur einmal

Hi,

ich sitze derzeit an Access 2013. Ich habe hier Datensätze, die per Mail reinkommen und dann telefonisch oder schriftlich bearbeitet werden. Bis die Frage abgeschlossen ist, ist der Status in Bearbeitung. Hierbei habe ich ein Formular mit den Kundendaten und ein Unterformular in dem ich die Telefonate etc. festhalten kann. Siehe Datei im Anhang.

Ich möchte nun eine Abfrage machen, welche IDs noch offen sind. Leider zeigt Access da jede ID mehrfach an, bei der mehr als 1 Kommunikation im Unterformular liegt. Siehe weitere Datei im Anhang. Rein logisch ist mir klar, dass das daher kommt, das es eben 4 Unterformulare mit dieser Referenz-ID 14 gibt als Beispiel. Access macht in dem Sinne ja also nichts falsch da der einzige Filter derzeit beim Status "in Bearbeitung" liegt.

Wie kann ich nun jedoch meine Abfrage anpassen, dass ich die offenen IDs nur noch jeweils 1x angezeigt bekomme? Ich würde die Abfrage mit der Entwurfsansicht öffnen und vermutlich irgendwas in der ID Spalte eingrenzen....aber was/wie?

...zur Frage

Mehrere INT Werte in eine Spalte MYSQL-PHP

Ich habe folgendes Problem, ich will mit einem int Wert einem Auftrag Mitarbeiter IDs zuteilen, kann aber nur pro spalte eine ID eintragen und ich möchte halt das irgendwie ID, ID, ID, ID aber wenn das so geht bräuchte ich auch noch Hilfe wie dann diese IDs verwalte halt löschen mit PHP etc. .Ich währ auch für andere Ideen offen. Danke im voraus!

...zur Frage

Wie 2 Exceltabellen vergleichen und eine mit Inhalten der anderen ergänzen?

Hallo zusammen,

ich habe zwei Tabellen mit Produkten

Tabelle A beinhaltet in Spalte A eine ID und in Spalte B eine Bezeichnung. Die Tabelle ist gemessen an dem zu erreichenden Endzustand nicht vollständig, das heißt nicht alle tatsächlich vorhandenen Produkte sind vorhanden. In weiteren Spalten gibt es zusätzliche Attribute, die hier aber nicht benötigt werden.

Tabelle B ist die Referenz, beinhaltet also alle Produkte (ohne Zusatzattribute) und beinhaltet ebenfalls in Spalte A die ID und in Spalte B die Bezeichnung.

Nun möchte ich feststellen welche Produkte (IDs) mir in Tabelle A fehlen und diese dort einfügen. Das Einfügen der Inhalte könnte am Ende der Tabelle stattfinden, über eine neue Sortierung bringe ich dann alles in die richtige Reihenfolge (nach IDs sortiert).

Wie bekomme ich das hin?

Vielen Dank!

...zur Frage

Was möchtest Du wissen?