Excel doppelte, text formatierte Einträge zählen (ZÄHLENWENN)?

...komplette Frage anzeigen Screenshot - (Computer, Mathe, Software)

2 Antworten

willst Du wirklich nur die Summe aller Doppel wissen? Ich denke doch,dass Du wissen willst, welche doppelt sind und ob evtl nicht sogar mehrfache dabei sind, oder?

In diesem Fall ist eine Hilfsspalte sinnvoll:

= Zählenwenn(A$1:A$20000;A1)-1

Diese Formel neben die auszuwertende Spalte A setzen (zB B1), und aufs Ausfüllkästchen doppelklicken: die Formel wird bis zur letzten gefüllten Zelle in A1 kopiert (sofern in A1 keine Lücken(?) und in B1 keine schon vorhandenen Einträge(?), ausprobieren, da verhalten sich xl und Libre Office etwas unterschiedlich und das kann ich mir nicht merken).

Die FormelZelle Bendef (Strg+1) so formatieren:

#.##0;[Rot]-#.##0;[Farbe7] "٠"

Das ist ein vielfältig verwendbares Format und macht die Zahl 0 (nur exakt 0, nicht gerundete 0 !) (=Einfach-Einträge) fast unsichtbar (die sog indische Null ist sehr klein und Magentafarben, jede Mehrfachnennung wird mit 1 zur Null dazugezählt (Fett und Arial Rounded MT bold macht das noch auffälliger), allerdings an jedem Ort des Auftretens (eine Dreifachnennung liefert 3*2=6, eine Spaltensumme ergibt so keinen Sinn).

Willst Du wissen, wie viele unterschiedliche Einträge (also EAN-Artikel) Du hast, hilft folgender Trick:

=1/Zählenwenn(A$1:A$20000;A1)

Mehrfachnennungen addieren sich in der Spaltensumme zu 1

Ich denke, von diesen Aussagen hast Du mehr als nur von der Zahl der Mehrfachnennungen! Und 2*20000 so kurze Formeln sind für xl bzw heutige Rechner kein Problem.

Das nur als Alternative zur sehr schön einfachen Formel von Ninombre.

 Hab eben erst Deinen Screenshot angeschaut: dasas Zählenwenn da probleme macht, war mit nicht bewusst.

Ersetze in der Spalte alle 0 durch zB ⵙ (das kommt sonst nie vor und aschaut ähnlich aus, Du kannst eas auch wieder zurück-ersetzen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
22.01.2016, 23:39

Halt, die Formel 1/Zählenwenn stimmt so nicht, da muss ich nochmal ran! spätestens bis morgen!

0
Kommentar von Tim204
25.01.2016, 11:00

Vielen Dank für deine ausführliche Hilfestellung. Der Sinn dahinter war es einfach alle EANs die doppelt vorkommen zu addieren und dann Formatierung entfernen und doppelte Einträge löschen. So, dass ich am Ende jede EAN einmal in der Liste habe mit entsprechender Menge wie oft diese vorkam. Es geht hierbei um eine Inventur wo die EANs einfach hintereinander pro Stück abgescannt werden. Wahrscheinlich ist das in der Tat nicht die beste Lösung dafür, aber als Excel Einsteiger ist es erstmal für den Zweck ausreichend. 

0

Alternativ: =SUMMENPRODUKT((A:A=A1)*1), mit Zählenwenn komme ich auch auf keine Lösung

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Tim204
22.01.2016, 19:13

Ohh, ja super dann nehme ich die Methode.. Musste nicht unbedingt ZÄHLENWENN sein, Danke! Ich hoffe nur das er bei ca. 20.000 EAN Einträgen am ende nicht Excel überforder beim ermitteln :D

0

Was möchtest Du wissen?