Wenn bei Excel in Spalte A1 bis A300 Mittwoch steht, soll in Spalte B, von B1 bis B300, neben der Zelle Mittwoch, das Wort, z.B. xy stehen. Geht das?

4 Antworten

Ja, das geht. Wenn Spalte A als Text formatiert ist, dann lautet die Formel für B1:

=WENN(A1="Mittwoch";"xy";"")

Falls Spalte A als Datum formatiert ist:

=WENN(REST(A1;7)=4;"xy";"")

Die Formel in Spalte B runterkopieren.

Dann schreibst du in der Spalte B1:

=WENN(A1="Mittwoch";"xy";"etwasanderes")

Das kannst du dann bis Zelle B300 runterziehen. Dann wird in der Spalte B immer xy geschrieben, wenn in der entsprechenden Zelle A Mittwoch steht und sonst wird etwasanderes geschrieben.

DH!
Wenn im Sonst-Fall die Zelle leer bleiben soll, dann:

=WENN(A1="Mittwoch";"xy";"")

Voraussetzung ist aber jeweils, dass in A der Wochentag als Text steht und nicht als Datum, dass so formatiert ist, dass der Wochentag angezeigt wird (TTTT). Falls DAS der Fall ist, dann:

=WENN(WOCHENTAG(A1)=4;"xy";"")

oder:

=WENN(REST(A1;7)=4;"xy";"")

3

Wenn es nur den Mittwoch betrifft ist die bereits bechriebene WENN-Funktion die richtige. Wenn es verschiedene Begriffe sind, denen jeweils ein anderer Begriff oder Wert zugeordnet werden soll, eignet sich der SVERWEIS heverragend. Allerdings benötigst du dafür eine Verweistabelle.


Was möchtest Du wissen?