Summe in Excel über jeweils mehrere Zellen kontinuierlich fortsetzen?

... komplette Frage anzeigen

6 Antworten

Da bietet sich ein Pivottabelle zu der bestehenden Tabelle an.

Füg vorab in deiner Tabelle eine neue Spalte ein, in der immer jeweils DIE 15 Zeilen, die zusammengefasst werden sollen, die selbe Kennzeichnnung erhalten. Also z.B. in Zeile 1-15 eine 1 in der neuen Spalte, Zeile 16-30 eine 2 in der neuen Spalte und so weiter, kannst du ja runterkopieren bis ans Ende der Tabelle.

Dann legst du eine Pivottablle an und summierst darin pro Wert aus der neuen Spalte.
Weißt du, wie das geht mit Pivottabellen?
Pivottabellen sind ein geniales Tool, um bestehende Tabellen auszuwerten, zu komprimieren, umzustrukturieren, einzelne Merkmale auszuwerten, ...

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von kaubakka
18.11.2015, 11:40

Das würde klappen, danke. Allerdings habe ich mich jetzt dafür entschieden es mit der Summe als Array Formel zu versuchen {=SUMME(J2:J16)}. Das klappt auch soweit. Allerdings lässt sich diese mit den üblichen Tastenkombinationen (STRG+U) nicht nach unten kopieren, was mich gerade noch vor die Frage stellt wie ich ohne den Fokus zu verlieren ans Ende der Tabelle komme. bei 500 000 Zeilen ist scrollen unmöglich.

0

Vielleicht ist ein erster, guter Schritt, die Zeiten auf ein Vielfaches von 15 Minuten zu bringen, um danach besser gruppieren und mit der Teilergebnisfunktionalität arbeiten zu können:

=REST(OBERGRENZE(MINUTE(A1);15);60)

oder direkt

=ZEIT(STUNDE(A1)+WENN(MINUTE(A1)>45;1;0);REST(OBERGRENZE(MINUTE(A1);15);60);0)

(du musst wahrscheinlich noch das komplette Datum mit Tag, Monat und Jahr bilden)

Antwort bewerten Vielen Dank für Deine Bewertung

Du fängt die gekürzte Tabelle einfach so an:

=SUMME(BEREICH.VERSCHIEBEN(Tabelle1!$A$1:$A$15;15*(ZEILE(A1)-1);0))

wobei sich Tabelle1!$A$1:$A$15 der erste 15 Zeilen Bereich ist. Formel nach unten ausfüllen für weitere 35k zeilen und fertig


Antwort bewerten Vielen Dank für Deine Bewertung

ich würde eine extra Spalte anlegen, die dir das Ganze über eine Formel automatisch gruppiert. Darauf kannst du dann eine Pivottabelle legen. 

Ich weiß nicht, ob eine Pivot nicht vielleicht auch schon von haus aus irgendwie clustern kann. vielleicht funktioniert das auch ohne Hilfsspalte. 

hier mal ein Beispiel
https://drive.google.com/file/d/0B7RClrQFWfzhNWlfaUo2Z0hDMzg/view?usp=sharing

Antwort bewerten Vielen Dank für Deine Bewertung

Das sollte so klappen:

="A"&(ZEILE(A1)*15-14&":A"&ZEILE(A1)*15)

und nach unten kopieren soweit wie nötig.
Klappt es?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von kaubakka
18.11.2015, 12:04

Gewitzt! Ja das  funktioniert mit der Anpassung auf Zeile 2 und unter hinzunahme der Summenformel. Der Vorteil hierbei ist, dass ich keine überflüssigen Zeilen habe wie bei der Array Lösung, danke!

0

Nur mal zu Verständnis:

minütliche Werte über einJahr ??
also für eine Stunde 60 Werte
ein Tag (60*24) 1.440 Werte
ein Jahr (60*24*365) 525.600 Werte

Daraus alle 15 Minuten ein Wert = 35.040 Werte.

Ist die Frage so gemeint ?

Gruß aus Berlin

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von kaubakka
18.11.2015, 10:33

genau!

0

Was möchtest Du wissen?