In excel Geburtstag automatisch heraussuchen. Wie geht das?

2 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

=WENN(UND(MONAT(C2)=MONAT(HEUTE());TAG(C2)=TAG(HEUTE()));"Geburtstag!";"")
und runterkopieren.So siehst Du auch noch der wievielte Geb. es ist:
=WENN(UND(MONAT(C12)=MONAT(HEUTE());TAG(C12)=TAG(HEUTE()));"Geburtstag!("&DATEDIF(C12;HEUTE();"Y")&")";"")

Klappt es?
Oder willst Du wirklich nur das aktuelle Datum angezeigt bekommen, wenn irgendjemand Geburtstag hat? So könnte man Deine Frage auch verstehen.

Ich hatte nur vor eben in einer Zelle das aktuelle Datum anzeigen zu lassen wenn eine/r von der C spalte Geburtstag hat. Simpel gemacht.

0
@Ghanasoccer

=WENN(UND(MONAT(WERT(C:C))=MONAT(HEUTE());TAG(WERT(C:C))=TAG(HEUTE()));HEUTE();"")

WERT wird gebraucht weil es sonst nicht richtig erkannt wird, und dann noch dieses Zelle formatieren als Datum.

0
@Ghanasoccer

Also bei mir funktioniert Deine Formel nicht.
Auch nicht als Matrix-Formel.
Wenn Du wirklich nur das aktuelle Datum haben willst, falls irgendjemand Geburtstag hat (wo ist da der Sinn?) dann würde ich das so machen:

=WENN(SUMMENPRODUKT((MONAT(C1:C1000)=MONAT(HEUTE()))*(TAG(C1:C1000)=TAG(HEUTE())))>0;HEUTE();"")

Aber wenn Deine Formel bei dir klappt und Du einen Sinn darin siehst, ist ja alles gut.

0
@Oubyi

Ja, ich hab gerade nachgeschaut und es hat nur funktioniert bei mir weil in der gleichen Zeile auch eine mit dem Geburtstag war...

fail naja. Danke deine Formel geht sicher!

Ich fänds toll wenn du dir mal meine Formel anschauen würdest.

0
@Ghanasoccer

Mit
WERT(C:C))=MONAT(HEUTE())
fragst Du eine Matrix ab, dazu müsste das Ganze auch als Matrixformel eingegeben werden, also Mit
STRG&SHIFT&ENTER,
sodass es in { }- Klammern steht.Allerdings kann die Funktion UND - aus welchen Gründen auch immer - nicht mit Matrizen umgehen und daher wird immer FALSCH zurückgegeben.
SO könnte man Deine Formel umbauen, damit sie klappt:

{=WENN(SUMME((MONAT(C1:C10)=MONAT(HEUTE()))*(TAG(C1:C10)=TAG(HEUTE())));HEUTE();"")}

Um das richtig zu verstehen sollte man sich aber etwas mit Matrix-Formeln und Wahrheits-Werten auskennen.

0

Excel Alter berechnen?

Hallo. Ich habe eine Excel-Tabelle erstellt. In dieser befinden sich in Spalte F (ab F2 bis F102) Geburtstage. Manche Zellen in F sind allerdings leer (also ohne Geburtsdatum.

In Spalte I soll nun das Alter erscheinen. Das habe ich wie folgt gelöst:

=DATEDIF(F2;HEUTE();"Y")

Leider zeigt mir Excel bei allen Zeilen ohne Datum nun beim Alter 118 an.

Ich finde keine Lösung. Wie lautet eine Formel, die das Alter ausgibt und wenn kein Geburtsdatum eingetragen ist, dann die entsprechende Zelle in I leer lässt?

Vielen Dank für die Hilfe.

...zur Frage

Wie lasse ich das Datum bei Excel fortlaufend?

Hallo, ich möchte bei Excel das Datum so haben, das wenn ich sage an einem Mittwoch beginnt der 1. das er mir den Rest automatisch weiter eintippt und wenn es geht auch noch die restlichen Tage vom Vormonat darüber. Habe aber keinen Sonntag drin und 2 Zeilen platz zwischen Samstag und Montag. Gibt es dafür eine Formel?

...zur Frage

Datum in Excel falsch: Wie kann man Monat und Tag vertauschen

Hi zusammen,

ich habe eine Excelliste mit Datensätzen bei der eine Spalte das Datum ist. Leider ist das heutige Datum (9. Dezember 2009) als "12.09.2009" eingetragen.

Wie bekomme ich es nun hin, dass ich z.B. in einer Hilfsspalte aus "12.09.2009" das Datum "09.12.2009" mache? Über eine reine Datumsformatierung geht das nicht.

Vielen Dank euch!

...zur Frage

Excel Datum einfügen?

Hallo,

ich bin gerade am erstellen einer Checkliste. Diese besitzt auch Kontrollkästchen.
Wenn etwas erledigt ist und ich somit das Kontrollkästchen anklicke, soll das Datum automatisch in die Zelle rechts davon eingetragen wird.

Das Datum soll dann aber statisch gespeichert werden, also sich nicht aktualisieren, wenn ich das worksheet schließe und wieder öffne.

Kann mir dabei wer helfen?

...zur Frage

Excel Hilfe Bitte?

Heyyy,

Ich habe 2 spalten in einer Excel-Datei, sobald ich in Spalte 1 ein datum einfüge kommt in Spalte 2 ein grüner Pfeil. Sollte noch kein datum in spalte 1 sein ist in spalte 2 ein roter Pfeil.

Wie geht das ?

MFG Julian

...zur Frage

Was möchtest Du wissen?