Excel Formel für Berechnung ob Wert zwischen 2 Zahlen liegt oder nicht

...komplette Frage anzeigen

4 Antworten

Dazu braucht man aber keine WENN-Funktion und kein UND (obwohl es damit natürlich auch geht).
Es reicht ein "einfaches":

=(C1>=A1)*(C1<=B1)

(z1 in A1, z2 in B1, z3 in C1)

Antwort bewerten Vielen Dank für Deine Bewertung
Oubyi 05.04.2013, 23:30

Danke fürs ☆

0

Habe nun das selbst herausgefunden. mein Problem war die ganze Zeit das und, wie das richtig in die Formel eingesetzt wird.

=WENN(UND(I2>=$D2;I2<=$C2;1);1;0)

C2 ist Zahl 1 D2 Zahl 2 I2 ist die Zahl 3

Mein Problem war, dass ich das ganze in 2 Klammer Bereiche unterteilt habe und nicht wusste, dass man ganz pauschal hinten eine Ersatzantwort angeben kann, wenn die Bedingung nicht zutrifft. Hatte hinten das Gegenteil von dem vorne drin, um die Antwort 0 zu erhalten. Hatte dann aber immer Fehler statt 0 ausgegeben bekommen

Antwort bewerten Vielen Dank für Deine Bewertung
oberschwabe1980 30.03.2013, 00:51

Ok, die $ müssen nicht drin sein. Die Zeichen habe ich nur drin, weil ich das ganze mehrmals nebeneinander habe und so die Formel ohne zu ändern kopieren kann.

0
Antwort bewerten Vielen Dank für Deine Bewertung

Schon mal was von der WENN-Funktion gehört? SOwas steht doch in der Excelhilfe...

Antwort bewerten Vielen Dank für Deine Bewertung
oberschwabe1980 30.03.2013, 00:36

Hatten leider zu meiner Schulzeit Mitte der 90er noch nicht die Möglichkeiten wie heute. Da waren wir froh, dass wir in der 9 Klasse den PC Raum für 6 Monate je 1 Schulstunde nutzen konnten. In der 10 Klasse immerhin 1 mal die Woche.

So konnte man nicht in Detail gehen

0
clubschalker 30.03.2013, 00:41
@oberschwabe1980

Ich gehöre auch zu jenen, die in den 90er Jahren auf der Schule waren... habe es dann trotzdem geschafft, die Excelhilfe zu finden ;) Also wie gesagt, du benötigst die WENN-Funktion. Oben rechts findest du die Hilfe. Da einfach mal eingeben, dann wird das ganz gut erklärt.

0

Was möchtest Du wissen?