Excel Formel für Berechnung ob Wert zwischen 2 Zahlen liegt oder nicht

4 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Dazu braucht man aber keine WENN-Funktion und kein UND (obwohl es damit natürlich auch geht).
Es reicht ein "einfaches":

=(C1>=A1)*(C1<=B1)

(z1 in A1, z2 in B1, z3 in C1)

Danke fürs ☆

0

Habe nun das selbst herausgefunden. mein Problem war die ganze Zeit das und, wie das richtig in die Formel eingesetzt wird.

=WENN(UND(I2>=$D2;I2<=$C2;1);1;0)

C2 ist Zahl 1 D2 Zahl 2 I2 ist die Zahl 3

Mein Problem war, dass ich das ganze in 2 Klammer Bereiche unterteilt habe und nicht wusste, dass man ganz pauschal hinten eine Ersatzantwort angeben kann, wenn die Bedingung nicht zutrifft. Hatte hinten das Gegenteil von dem vorne drin, um die Antwort 0 zu erhalten. Hatte dann aber immer Fehler statt 0 ausgegeben bekommen

Ok, die $ müssen nicht drin sein. Die Zeichen habe ich nur drin, weil ich das ganze mehrmals nebeneinander habe und so die Formel ohne zu ändern kopieren kann.

0

Excel Formel Berechnung Anzahl2?

Ich habe folgendes Problem:

In einer Liste mit diversen Einträgen soll die Summe in einer Spalte errechnet werden.

In dieser Spalte gibt es Bereiche mit Zahlen und Datum und Bereiche mit Text und Datum.

Gezählt werden sollen aber nur die Bereiche mit Zahlen und Datum. Bisher habe ich im Interent dazu nichts gefunden, wie ich die Bereiche mit Text und Datum ausschließen kann.

Ich bedanke mich jetzt schon für die sicherlich zahlreichen Lösungsvorschläge.

(Ein Beispiel wollte ich anfügen, das klappte aber leider nicht)

Meine benutze Formel lautet:

=ANZAHL2(G4:G251)

anzumerken wäre noch, dass es auch leere Zellen gibt, die ich natürlich nicht zählen möchte

...zur Frage

Excel Frage: Wenn Datum X in einem Zeiträume A, B, C, oder D liegt, dann gibt mir den (zu diesem Datum) dazugehörigen Wert?

Folgendes Problem:

Spalte A: Anfangsdatum Spalte B: End-datum Spalte C: Benötigte Formel um den richtigen Wert aus Spalte F anzugeben

Spalte E: Datumsangaben Spalte F: Werte

Ich möchte, dass die Zellen in Spalte C schauen welcher dazugehörige Wert (Spalte F) gemäß Datum (Spalte E) soll für den Zeitraum ausgegeben werden.

Beispiel ist in der anhängenden Grafik dargestellt. C2 soll z.B. den Wert 10,3 ausspucken. C3 den Wert 15,5 usw..

Ich hoffe Ihr könnt die Fragestellung einigermaßen nachvollziehen. Mein Problem ist, dass teilweise wie in diesem Beispiel das Startdatum in Spalte E kein typischer Quartalsbeginn ist und somit meine bisherige Formel dahin ist ...

Besten Dank schon mal im Voraus für eure Hilfe.

...zur Frage

Wie referenziere ich in Excel?

Im Bild habe ich eine kleine Tabelle mit Naturkonstanten, mit denen ich rechnen will. Ich würde gerne in meine Formeln einfach nur die Begriffe in der linken Spalte benutzen, nicht die Zahlen selbst. Excell soll sich dann die Zahlen dazu selbst aus der Tabelle rauspicken. Ich weiss, man kann jeder Zelle einen individuellen Namen geben, aber so will ich das nicht lösen. Ich weiss, dass das auch eleganter geht, weiss aber nicht mehr, wie. Könnt ihr mir helfen?

...zur Frage

Excel Zeichen aus Zelle entfernen, Zahl behalten

Wieder mal ne Frage zu Excel:

Ich habe eine Tabelle bei der in der Spalte H eine Auflistung von Zahlen ist, die ein "H" hinten dranhaben. Also ['irgendeine zahl' H]. Gibt es jetzt iwo eine Möglichkeit, das H aus allen Zahlen zu entfernen? Ich möchte die Summe aller dieser Zahlen berechnen und diese Formel erkennt nur reine Zahlen. Die Art ist eig egal, ob Formel, Makro (VBS).

Vielen Dank schon im Voraus für die Antworten

Panther12889

...zur Frage

Wenn dann formel in Excel mit zahlenbereich prüfung?

Ich brauche Funktion in der ich prüfen kann wenn die Zahl in einem Kästen in einem bestimmten Zahlenbereich liegt das dann ein gewisser Wert erzeugt wird z.B. wenn der wert zwichen 0-10 liegt dann ein 5 und wenn er zwischen 10,01 - 50 liegt dann eine 1. wie schriebe ich das dann meine idee war es mal so zu probieren das will aber nicht ganz so. =WENN(SUMME(D31)<=10;5;=WENN(SUMME(D31)<=50;1;0))

...zur Frage

Wenn in Zelle Zahl enthalten, dann Zelle ausblenden (Excel)?

Hi,

ich habe in Excel eine Spalte mit 5.000 Urls. In einigen Zellen sind achtstellige Zahlen enthalten. Ich möchte das nun so automatisch filtern, wenn in Spalte A eine Zahl von 0 bis 1 enthalten ist, dann blende diese Zeile komplett aus.

Wie mache ich das mit der WENN-Formel ?

Vielen Dank

...zur Frage

Was möchtest Du wissen?