Excel - Ist es möglich, dass der Wert einer Zelle bei Eingabe an Ort und Stelle multipliziert wird?

2 Antworten

Wenn es wie vorgeschlagen nicht geht, dann

eine Spalte daneben mit der Formel versehen.

Entweder auf z.B. 2. Blatt den Wert aus dem 1. Blatt holen oder danach die 1. Spalte ausblenden.

Doch, das ist schon möglich, und zwar so:
Mache einen Rechtsklick auf den Tabellenreiter (ganz unten, wo z.B. Tabelle1 steht).
Wähle: Code anzeigen...
Dann öffnet sich der VBA-Editor für dieses Tabellenblatt. Kopiere diesen Code in das große Fenster:

Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Column = 1 Then '(anpassen: 1 für Spalte A, 2 für B usw.)
On Error GoTo ErrorHandler
Application.EnableEvents = False
Target.Value = Target.Value * 2
ErrorHandler:
Application.EnableEvents = True
End If
End Sub

Spalte anpassen!
VBA-Editor schließen.
Datei speichern(ab Excel 2007) als

.xlsm

Teste mal genau. ob es so klappt, wie Du es Dir vorgestellt hast.

Deine Antwort funktioniert bestimmt super, aber bei mir irgendwie nicht.

Ich hab ein MacBook Pro und Microsoft Office installiert.

Wenn ich einen Rechtsklick auf den Tabellenreiter mache, dann steht da nichts weiter als: "Hilfe", "Einfügen", "Löschen", "Umbenennen", "Verschieben/Kopieren" und "Alle Blätter markieren".

Weißt du noch einen anderen Rat? :)

0
@Guertelrose

Mit Mac kenne ich mich leider gar nicht aus.
Bein Windows wäre eine Alternative ALT & F11 zu drücken.
SO kommst Du in den VBA-Editor.
DA musst Du dann aber zuerst unbedingt im Projekt-Explorer das Tabellenblatt auswählen (doppelklicken) in dem der Code laufen soll.
Ich denke F11 gibt es beim Mac nicht, aber Du müsstest doch in der Hilfe sehen können, wie Du den VBA Editor öffnest.
Oder Du suchst den Makro-Rekorder und nimmst irgendetwas auf.
Dann kommst, Du mit Makro/ Bearbeiten auch in den VBA-Editor.
Hilft Dir das weiter?

0
@Guertelrose

Das ist schade.
Ohne VBA ist Excel aber, für den fortgeschrittenen Gebrauch, höchstens noch "die Hälfte wert".
Selbst so simple Sachen, wie Deine Aufgabenstellung hier, lassen sich ohne VBA NICHT lösen.
Und ich habe mit VBA in Excel schon komplexe Tools zur Datenanalyse und Prozessoptimierung geschrieben.
Das kannst Du mit dem Mac dann "vergessen", es sei denn es gibt für den Mac ein alternatives Tabellenkalkulationsprogramm, dass eine Programmiersprache unterstützt.

0

Excel Formel: Zelle kopieren, wenn Bedingung erfüllt?

Ich möchte in Excel die Zelle B1 so formatieren, dass der Text aus Zelle A1 dort erscheint, WENN in Zelle C1 der Wert "Ja" oder "Yes" steht. Kann mir jemand mit der Formel helfen? Danke schonmal.

...zur Frage

Excel - MINDESTENS Formel?

Hallo
weiß jemand welche Formel man bei Excel eingeben muss wenn man z.b. eine Zelle haben will bei der mindestens 500 rauskommt:
also ist die zahl z.b. 44 soll anstatt 44, 500 dort stehen und ist die zahl 784 soll da 784 stehen...???

...zur Frage

Excel - Summe / Formel?

Beispiel:

Ich habe Spalte A bis C

In Zelle A1 steht ein Wert: 12

In Zelle B1 steht ein Wert: 15

In Zelle C1 steht ein Wert:  0

Spalte C hat immer den aktuellsten Wert.

In unserem Fall 0

Da in Spalte C1 0 steht, möchte ich den Wert aus Zelle B1 in die Zelle D1 schreiben.

Ich möchte also immer einen Wert, der größer ist als 0 als aktuellen Wert haben.

Wie kann ich das per  Formel ausdrücken?

...zur Frage

Wenn A1=A2="X" Dann "Ja" sonst "nein" Excel Wenn dann formel?

Hallo ich möchte ein bisschen mit Excel rumprobieren und komme grad nicht weiter. Ich möchte ein Tikatoospiel erstellen die Frage ist nur wie sage ich das wen A1 und A2 und A3 X ist gewonnen wenn nicht leer machen kann. =WENN((A1=B2=C3)="X";"Gewonnen";"…") =WENN((A1&B2&C3)="X";"Gewonnen";"…") =WENN(A1=B2=C3="X";"Gewonnen";"…") =WENN(A1&B2&C3="X";"Gewonnen";"…") gehen alle nicht

...zur Frage

Excelfrage -- Werte in Excel eingeben die automatisch multipliziert werden, und wie?

Hallo liebe Excel-Brains :)

Ich brauche dringend eure Hilfe für eine Arbeit bei mir auf der Arbeit. Folgendes Problem in der Tabelle:

          Paket 1       Paket 2       Paket 3
           1,50 €        2,30 €         4,80 € 
01. Jan         
02. Jan         
03. Jan         
Gesamt:    - €               - €           - €

Ich möchte gerne eine Formel oder eine Funktion verwenden, die es mir ermöglicht dann im jeweiligen Feld einfach die Zahl einzugeben und mit Excel automatisch den Wert mit den vorgegebenen Wert multipliziert ohne das ich einen großen Aufwand mit Formeln oder so beim Eingeben habe.

Also als Bsp.: Ich habe am 01. Januar 10 Pakete 1 verkauft und will dann nur im Feld eingeben "10" und dann errechnet mit Excel sofort das Ergebnis und liefert mir dann in der Zelle wo ich die "10" eingegeben habe den Wert 15 €. Welche Formel oder welche Funktion muss ich hier verwenden?

Vielen lieben Dank für eure Hilfe!! :)

...zur Frage

Was möchtest Du wissen?