Wie kann ich in Excel anhand vom heutigen Datum die Werte vom Vorjahr (selber Wochentag) anzeigen lassen?

... komplette Frage anzeigen

3 Antworten

Puh, ich hab rumprobiert und mal rum versucht =D

Irgendwie ist was gute bei raus gekommen..... Mal schauen was DU davon hältst :P


Also, folgender Tabellen Aufbau:

Ich habe in A1 ein normales Feld in welches du dein Datum einträgst, welches du vergleichen möchtest.

Im Feld darunter also in A2, trägst du eine Zahl ein, die angibt wie viel Jahre rückwirkend du etwas vergleichen möchtest!

In der Zelle A3:A5 findet eine kleine Berechnung statt:

Zelle A3 Formel:

=WOCHENTAG(DATUM(JAHR(A1)-A2;MONAT(A1);TAG(A1)))

Zelle A4 Formel:

=WOCHENTAG(A1)

Zelle A5 Formel:

=A4-A3

In die Zelle B1 trägst du diese Formel ein:

=WENN(ISTSCHALTJAHR(DATUM(JAHR(A1)-A2;MONAT(A1);TAG(A1)));DATUM(JAHR(A1)-A2;MONAT(A1);TAG(A1)+A5);DATUM(JAHR(A1)-A2;MONAT(A1);TAG(A1)+A5))

und das richtige Datum + die Anzahl Jahre die du eingetragen hast weniger + der richtige Wochentag aus diesem Monat erscheinen.


Versuchs doch mal und melde dich dann nochmal =)


Grüße,


iMPerFekTioN


Edit: Du kannst dann halt mit der Zahleneingabe in A2 bestimmten wie viele Jahre du zurück willst!

Dann wird das richtige Datum mit dem richtigen Wochentag angezeigt wie du es ja wolltest.

Die Auslesung des Umsatzes hab ich aber noch nicht gemacht! :)

Kommentar von Iamiam
02.09.2016, 11:21

auch ein schöner Vorschlag, DH!

kannte Istschaltjahr(A1) noch nicht, dürfte aber Probleme bei Datümern bis zum 28. Feb. machen?

1
Kommentar von 100Excelfragen
02.09.2016, 15:36

Vielen Dank zunächst für die schnelle Hilfe... es hat bis zur letzten "großen Formel" geklappt... hier kam leider ein Fehler und ich krieg es natürlich nicht hin, den zu lösen -.-

Ich habe die Formeln in anderen Zellen erstellt:

O 35 --> 02. Sep 2016

O36 --> 1 (denn ich möchte ja letztes Jahr vergleichen

O37 --> =WOCHENTAG(DATUM(JAHR(O35)-O36;MONAT(O35);TAG(O35)))

O38 --> =WOCHENTAG(O35)

O39 --> =O38-O37

=WENN(ISTSCHALTJAHR(DATUM(JAHR(O35)-O36;MONAT(O35);TAG(O35)));DATUM(JAHR(O35)-O36;MONAT(O35);TAG(O35)+O39);DATUM(JAHR(O35)-O36;MONAT(O35);TAG(O35)+O39))

Habt ihr Rat? Tausend Dank!!!

1

mit Pivot habe ich keine Erfahrung, aber

den gleichen Wochentag des Vorjahres erhältst Du mit

=HEUTE()-364  oder-schon vorbereitet fürs Folgende: =heute()-(363+1)

Das stimmt, sofern es kein Schaltjahr ist Dafür brauchen wir eine Korrektur:

=HEUTE()-(363+WENN(TAG(HEUTE()<>TAG(HEUTE()-364));1;0))

oder - auch nur ein Klammernpaar weniger-:

=HEUTE()-363-WENN(TAG(HEUTE()<>TAG(HEUTE()-364));1;0)

auch, wenns Dir logischer oder übersichtlicher erscheint:

=HEUTE()-364-WENN(TAG(HEUTE()=TAG(HEUTE()-363));1;0)

Anstatt heute() kannst Du natürlich auch jeden anderen Datumsbezug setzen.(3x)

Gegenüber dem -ebenfalls bedenkenswerten Vorschlag mit KW und Wochentag hat das hier den Vorteil, dass Du vom Gebietsschema unabhängig bist. (KW hat vier oder 5 genormte Möglichkeiten der Definition=>Hilfe)

Feiertage musst Du manuell korrigieren, da kenne ich keinerle Automatismus, der halbwegs zu bewältigen wäre. Fixe Feiertage, zB 1.Mai wandern ja in der Woche, Wochentagsfeste Feiertage (Ostermontag zB) finden an ganz anderen Zeitpunkten statt.. Sehr komplizierte Korrekturen und nur übers ganze Jahr möglich, aber da drücke ich mich jetzt...

Kommentar von Iamiam
02.09.2016, 11:15

vllt solltest Du die Tage vor und nach Weihnachten besser ohne Bezug auf den Wochentag auswerten? (aber das ist ein inhaltliches und kein xl-Problem)

1
Kommentar von Iamiam
02.09.2016, 11:36

Auslesen des Tages-Umsatzes:

=index(Datumsspalte;Vergleich(Datum;Umsatzspalte;0)

Die Zwischensumme September stört nur dann nicht, wenn September ein String ist und kein Datum

Formelbeispiel:Datum in Sp.B, Umsatz in Sp. C, für 26.8.2015:

=index(Tabelle1!C:C;Vergleich("26.8.16"*1;Tabelle1!B:B;0))

*1 macht aus einem Datumsstring in Anfz  eine xl-verwertbare Datumszahl, die in B:B gefunden wird und dann wird daneben aus C:C ausgelesen

1
Kommentar von Iamiam
02.09.2016, 13:02

Bin nochmal auf ein Problem am 29.2.16 gestoßen, muss ich mir heute abend nochmal zu Gemüte führen!

1

Arbeite hier nicht mit dem Datum sonder mit der Kalenderwoche und dem Wochentag, das ist eindeutig.

Kommentar von Iamiam
02.09.2016, 11:10

DH! möglicherweise der eher nachvollziehbare Vorschlag im Vergleich zur langen Formel in meiner AW hat allerdings auch Tücken (Def. Kalenderwoche ist vom Gebietsschema abhängig, ausserdem springt die um, was v.a. die Zeit nach Neujahr bzw Weihnachten schwierig auswertbar macht)

2

Was möchtest Du wissen?