Excel zählenwenn-Funktion mit Datum?

3 Antworten

Bevor man sich mit Zählenwenn und der Syntax bei Datümern rumschlägt, sollte man =Summenprodukt((Zellbereich>="Grenzdatum"*1)*1) testen.

In Deinem Fall: =Summenprodukt((Datumszählbereich>=A2)*1)

oder $A$2, wenns kopiert werden soll

z.B. =Summenprodukt((A5:A500>="1.1.2017"*1)*1)

zumindest früher musste man bei < und > das Datum in Gänsefüßchen schreiben und das *1 nehmen. ist das inzwischen überflüssig?

Aber die Lösung von A-Chris ist ok.

Schreib ">="&A2

Unsinn.

0
@augsburgchris

Muss ich nicht testen. Zeichen in "" werden in Excel als Text und nicht als Formelbestandteil berechnet. Was genau soll das bringen?

0
@augsburgchris



=ZÄHLENWENN(B2:B5;">55")

Ermittelt die Anzahl der Zellen mit einem Wert größer als 55 in den Zellen B2 bis B5. Das Ergebnis lautet "2".





=ZÄHLENWENN(B2:B5;"<>"&B4)

Ermittelt die Anzahl der Zellen mit einem Wert ungleich 75 in den Zellen B2 bis B5. Das kaufmännische Und-Zeichen (&) verknüpft den Vergleichsoperator für ungleich (<>) und den Wert in B4 zu: =ZÄHLENWENN(B2:B5;"<>75"). Das Ergebnis lautet "3".



Aus der soeben gelinkten Seite.

0

Was möchtest Du wissen?