Wie bekomme ich dynamische Verweise in excel?

1 Antwort

Angenommen Deine "Zelle1" ist die Zelle A1 und vorausgesetzt, der hier angezeigte, durch das Dropdown aus Tabelle2!C:C ausgewählte Wert (aus C5) kommt dort nur einmal vor, erhältst Du mit:

=INDEX(Tabelle2!D:D;VERGLEICH(A1;Tabelle2!C:C;0))

den Wert der Nachbarzelle (D5) angezeigt.
Falls Du das für die Schule machst, wird der Lehrer allerdings eher einen SVERWEIS erwarten (der von mir und anderen Experten nicht angewendet wird, da er recht unflexibel ist). Dann müsstest Du diese Formel vorweisen, die das gleiche Ergebnis zeigt:

=SVERWEIS(A1;Tabelle2!C:D;2;0)

Klappt es?

P.S.: In beiden Fällen würde ich aber dazu raten, die Spalten zu begrenzen, also C1:C1000 statt C:C usw.

Danke! Hat super funktioniert und nein ist nicht für die Schule :)

0

Excel Spalte nach unten automatisch weiterzählen?

Hallo zusammen.

ich habe in meiner Zelle:

=ZÄHLENWENN(C$23:C$29;"TD")

stehen. Das funkltioniert.

Nun möchte ich die Zelle nach unten ziehen und die spalte WEITERZÄHLEN.

=ZÄHLENWENN(D$23:D$29;"TD")

=ZÄHLENWENN(E$23:E$29;"TD")

=ZÄHLENWENN(F$23:F$29;"TD")

...zur Frage

Auswahlliste in Excel für eine Spalte einer Tabelle automatisch erweitern, wenn Tabelle nach unten gezogen wird?

In der Menüleiste unter Daten -> Datenüberprüfung gibt es ja die Möglichkeit bei Einstellungen -> Liste einen Bereich als Auswahlmöglichkeiten für die einzelne Zelle vorzugeben.

Ich habe das Problem dass das nicht automatisch fortgeführt wird wenn ich meine Tabelle erweitere. (Im gegensatz zu Formeln, welche das automatisch machen).

Wie kann ich es so einstellen dass es klappt. Ich frage eigentlich nur weil ich auch Tabellen habe bei denen es fuktioniert, ich aber hier keinen Einstellungsunterschied feststellen kann.

Danke!

...zur Frage

Wie kann ich bei Word 2016 erzwingen, dass die Spalten meiner zu breiten Tabelle umgebrochen werden?

Hallo,

Ich benutze Word 2016 und habe eine Tabelle erstellt, die zu breit ist, um auf ein DIN-A4-Querformat-Blatt zu passen. Ich möchte daher die überlappenden Spalten umbrechen und unter dem ersten Teil der Tabelle darstellen lassen, quasi so, als hätte ich zwei Tabellen untereinander mit den verschiedenen Spalten.

Das Problem ist aber, dass die Tabelle gemeinsame Zeilentitel besitzt. Wie kann ich Word als Äquivalenz zum Seitenumbruch der verschiedenen Tabellenzeilen den Zeilenumbruch der verschiedenen Tabellenspalten automatisieren lassen?

Ich habe schon gegoogelt, aber zu dieser Problematik fand ich da gar nichts. Bitte helft mir! :(

Mit freundlichen Grüßen,

KnorxThieus (m)

...zur Frage

Excel - Wenn Wert in Spalte = x, dann Nachbarzelle kopieren

Hallo,

lässt sich folgende Aufgabe über eine Formel lösen?

Wenn ja, wie lautet die Formel?

Ich habe in Spalte A Texte und in Spalte B dazugehörige Zahlenwerte.

In Spalte C stehen stehen die gleichen Texte wie in Spalte A, nur in einer anderen Reihenfolge.

Wenn nun z.B. in Spalte A der Text in der Zelle A3 = "xy" steht, soll der dazugehörige Zahlenwert in Zelle B3 = "365" zu dem passenden Tex in Spalte C gezählt werden.

Also wenn "xy" in Zelle C10 steht, muss der Wert aus B3 = "365" in D10 eingetragen werden.

Ich hoffe es ist verständlich ausgedrückt.

Danke & Gruß Peter

...zur Frage

Werte untereinander in Excel erfassen - VBA

Frage an die Excel Profis und VBA Experten. Die Aufgabenstellung baut aufeinander auf.

  1. Aufgabenstellung: Zelle A1 soll als Eingabefeld in Excel dienen. Alle Werte, die in A1 eingegeben werden, sollen einfach untereinander ausgegeben werden, also in a2, a3, a4 usw. Die Cursormarkierung (damit meine ich die schwarze Umrahmung der aktiven Zelle) bleibt aber in A1.

  2. Aufgabenstellung: Aufbauend auf Aufgabenstellung 1 soll nun nachdem in A1 ein Wert eingegeben wurde, der Wert wie gehabt in A2 erscheinen. Die schwarze Umrahmung soll aber jedoch zunächst in B2 erscheinen um einen weiteren Wert einzugeben. Erst nach Eingabe eines Wertes in B2 soll die Umrahmung wieder in A1 springen, damit ein nächster Wert eingegeben werden kann, der dann in Zelle A3 erscheint. Dann springt die Cursormarkierung in B3, um einen Wert einzugeben. Danach wieder in A1 usw.

  3. Aufgabenstellung: Aubauend auf Aufgabenstellung 2 sollen die Werte, die in den Zellen der Spalte B eingegeben werden, mit den Werten der Spalte A im Reiter "Tabelle2" verglichen werden. Sofern der eingegebene Wert in der Spalte B mit denen der Spalte A (Reiter Tabelle2) übereinstimmt, soll Excel ein Fenster öffnen, in dem "Wert gefunden" steht.

Ist das in Excel 2003 per VBA für alle 3 Aufgabenstellungen möglich?

...zur Frage

Hallo Zusammen, brauche hilfe bei Excel bedingte Formatierung Ferien TEIL 2?

Hallo Zusammen, brauche hilfe bei Excel bedingte Formatierung Ferien?

habe die Frage bereits gestern gestellt und von Chris auch eine Antwort erhalten. Habe nun diese Datei hochgeladen und bitte um weitere Unterstützung.

ich habe 2 Bilder eingefügt das eine soll jetzt den Monat Dezember darstellen und in der anderen Registerkarte sind die Ferien hinterlegt. Jetzt sollen im Dezember alle Spalten markiert (bedingte Formatierung) werden die zum Beispiel den Ferienzeitraum 02.12.2017 bis 05.12.2017 und 10.12. - 15.12.2017.

!!! Es soll nicht nur die Zelle mit dem Datum markiert werden, sondern auch die Felder darunter!!!

Ich habe keine VBA-Kenntnisse

Für die Feiertage habe ich das hinbekommen.

...zur Frage

Was möchtest Du wissen?