Sony Vegas erkennt bei Video keinen Ton

 - (Video, Sony, Videobearbeitung)  - (Video, Sony, Videobearbeitung)

2 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Das ist sicher ne Avi DivX datei richtig? Das passiert wenn Sony Vegas mit dem ''processing mode'' der Audiodatei nicht klar kommt. Das Problem hat Vegas schon seit Sony Vegas 8.

Hier nen 30 sec Video wie du das wieder hinbekommst.

http://www.youtube.com/watch?v=h-w3dRjwmlE

Processing Mode heißt nix anderes als Bearbeitungsmodus und steht bei VirtualDub nur für ne Codecänderung. Das Gegenteil wäre Directstream Copy, gar keine Bearbeitung vom Codec, der wird einfach übernommen. Also ne Audiodatei kann soweit ich weiß nicht sowas wie nen 'processing mode' haben. Wenn doch klär mich auf, bei Audio kenn ich mich nicht so sonderlich aus.

Wenn in der AVI ne MPEG-4 ASP ist (was DivX früher erstellt hat) drin ist, dann ist da höchstwahrscheinlich ne MP3 Audiodatei drin. Im Video wird daraus ne PCM gemacht (Full Processing Mode ohne Codeceinstellung = unkomprimiert) - was man üblicherweise als WAV kennt.

Warum ist Vegas Pro seit Versionen hindurch so verbuggt bei AVI Dateien?

@TE - für Codecinformationen solltest dir nen besseres Informationstool herunterladen. Zum Beispiel MediaInfo (http://mediainfo.sourceforge.net/de). Dann kannst konkrete Informationen über die Codecs auslesen und mitteilen.

0
@Yetanotherpage

Da hab ich mich etwas unglücklich ausgedrückt. x)

Ich meine einfach das Vegas mit der Art der Audiodatei nicht klarkommt. Die Audiodatei wird sich sicherlich um eine MP3 handeln. Ich hatte das gleiche Problem, wenn die MP3 in der AVI Datei eine variable Bitrate aufwies. Die Convertierung in CBR hat das Problem behoben.

Warum Vegas damit immernoch nicht klarkommt weiß ich nicht. Avi DivX hat in der Videobearbeitung eigentlich auch nichts zu suchen.

0

Ich hab leider keine Ahnung, welches Format die Audiospur genau hat.

Jedenfalls hab ich das Video mit Fraps inklusive Windows-Output und External-Input mittels Mikro aufgenommen (falls das weiterhelfen sollte).

Das Video bzw. Virtual Dub hat mir leider auch nicht weitergeholfen, Vegas erkennt nach wie vor keine Audiospur.

0
@Dom27

Achso, dann war ich etwas zu voreilig mit meiner DivX vermutung.

Fraps hat seinen eigenen Codec den er mitinstalliert.

0
@CaseCrank

Weißt du zufällig auch, wie bzw. mit welchem Programm man diesen Audio-Codec auslesen kann?

Dann kann ich mir doch die entsprechenden Codecs downloaden, oder?

0
@Dom27

Nur für Video benutzt Fraps n eigenen Codec. Für Audio benutzt Fraps was allgemeines wie PCM (also WAV)... was Standard ist und jedes vernünftige Programm sollte sowas rudimentäres wie PCM öffnen können (kann es auch). Reinstalliere mal Vegas Pro.

Wenn das nicht hilft könntest Audio in VirtualDub konvertieren (in MP3 z.B.) oder du demuxt (=entpackst) Audio aus der AVI und hättest die WAV Datei denn separat und musst hoffen das Vegas Pro wenigstens mit der nackten Datei zurecht kommt. Aber da viele Leute Vegas Pro für ihre Frapsaufnahmen nutzen und ich noch nie gehört habe das sie Probleme mit dem PCM Stream haben ist dein Vegas wohl nicht ganz sauber... oder dein PC.

Weißt du zufällig auch, wie bzw. mit welchem Programm man diesen Audio-Codec auslesen kann?

Ähm...

@TE - für Codecinformationen solltest dir nen besseres Informationstool herunterladen. Zum Beispiel MediaInfo (http://mediainfo.sourceforge.net/de). Dann kannst konkrete Informationen über die Codecs auslesen und mitteilen.

0
@Yetanotherpage

Danke für die Hilfe bis jetzt!

Zu deinem Kommentar:

Reinstalliere mal Vegas Pro.

Werde ich sofort versuchen.

...könntest Audio in VirtualDub konvertieren (in MP3 z.B.) oder du demuxt (=entpackst) Audio aus der AVI und hättest die WAV Datei denn separat und musst hoffen das Vegas Pro wenigstens mit der nackten Datei zurecht kommt.

Was ich noch nicht erwähnt habe, ist, dass die Videos, die ich bearbeiten und rendern möchte, Let's Play Folgen sind, falls dir/euch das was sagt. Das heißt ich rendere ca. 1-2 Folgen à 15min pro Tag und wenn ich dann bei jeder Folge vorher noch mit VirtualDub die Tonspur extrahieren muss, wird das ziemlich zeitaufwendig :/

Aber da viele Leute Vegas Pro für ihre Frapsaufnahmen nutzen und ich noch nie gehört habe das sie Probleme mit dem PCM Stream haben ist dein Vegas wohl nicht ganz sauber... oder dein PC.

Ich habe vor einigen Monaten schonmal Videos mit Fraps auf die gleiche Weise aufgenommen und damals hat auch alles ohne Probleme funktioniert. Kann es vielleicht an einem der letzten Updates liegen?

Btw hier ist ein Screenshot von der Datei in MediaInfo: http://img190.imageshack.us/img190/6324/mediainfoe.png

0
@Dom27

Sieht alles normal aus mit der Frapsdatei. BTW is schon Fraps 3.5 draußen, das splittet nicht mehr in 4 GB Häppchen. ^^

Wenn sich dein Audioproblem nicht mit ner Reinstallation vom Programm lösen lässt bleibt dir nicht so viel übrig.

  • Kannst ne ältere Version nutzen mit der es noch funktionierte.
  • Kannst deine Videos vor dem einfügen konvertieren (bzw. nur Audio, Video auf Kopie/Stream lassen). Bei mehreren Videos bietet sich n Konverter eher an als VirtualDub.
  • Kannst dein Aufnahmeprogramm wechseln zu einem wo du den Audiocodec zu einem ändern kannst den dein Vegas (un)Pro noch akzeptiert.
0
@Yetanotherpage

BTW is schon Fraps 3.5 draußen, das splittet nicht mehr in 4 GB Häppchen. ^^

Hab schon gesehen und geupdatet, ist eine super Funktion ;)

Bin jetzt vorerst mal auf den ... ich wills gar nicht aussprechen ... Windows Movie Maker (puh) umgestiegen und render meine Folgen jetzt mal notfalls damit.

Ich hoffe, ich finde bald eine weniger zeitaufwendigere Lösung für mein Problem und kann dann endlich wieder auf Vegas Pro umsteigen.

Vielen Dank für deine großartige Hilfe, umsonst war sie ja doch nicht, denn ich weiß jetzt, welchen Codec der Sound bei den Videos hat und welche Möglichkeiten ich hab, das Problem zu beheben, wenn auch etwas eitaufwendig ;)

0

Weil Vegas vermutlich den Audio-Codec nicht unterstützt oder keinen Zugriff hat.

Was möchtest Du wissen?