Weiß jemand wie man den Median von 330 Werten in Excel berechnet?

... komplette Frage anzeigen

2 Antworten

Wenn die Werte nicht total versteut in der Tabelle sind, kannst du Wertebereiche angeben. Diese dürfen dann auch mehr als 255 Werte enthalten, alle Werte werden berücksichtigt.

=MEDIAN(A:B) funktioniert wunderbar (habe es mit 900 Zahlen in den beiden Spalten getestet.

Du kannst auch unzusammenhängende Bereiche angeben
=MEDIAN(A:A;C5:C100;F:H)

Antwort bewerten Vielen Dank für Deine Bewertung

zur Definition des Medianwerts gibts einen Wikipedia-Eintrag. Demnach ist der Medianwert Deiner 330 Werte (Hälfte = 165):

=Kgrösste(Bereich330Werte;165)  oder noch genauer

=(Kgrösste(Bereich330Werte;165)+Kgrösste(Bereich330Werte;166))/2

Bin zwar kein Statistiker, aber die Sache scheint mir eindeutig!

Quantilsgrenzen müssten sich m.E. ähnlich berechnen lassen, für die Summierung könnte Summewenn infrage kommen..

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
04.03.2016, 19:11

Kleine Erweiterung: Wenn die Anzahl der Werte ungerade ist, genügt die erste Formel, ansonsten die zweite. in Eine Formel lässt sich das so fassen (n=Anzahl(BereichWerte):

=WENN(REST(n;2)=0;(KGRÖSSTE(Bereich;n/2)+KGRÖSSTE(Bereich;n/2+1))/2;KGRÖSSTE(Bereich;(n+1)/2))

umgesetzt auf einen Beispielsbereich von nur $A$10:$A$17:

=WENN(REST(ANZAHL($A$10:$A$17);2)=0;(KGRÖSSTE($A$10:$A$17;ANZAHL($A$10:$A$17)/2)+KGRÖSSTE($A$10:$A$17;ANZAHL($A$10:$A$17)/2+1))/2;KGRÖSSTE($A$10:$A$17;(ANZAHL($A$10:$A$17)+1)/2))

sieht zwar monströs aus, ist aber nur konsequent in Adressen ausgedrückt, bei Dir natürlich eine Spanne von 330 Werten. Kannst ja die Adresse(n) gesamelt gegen die Deine auswechseln (Fo-Zelle plus eine weitere markieren, suchen $A$10:$A$17, ersetzen durch DEINELISTE) (Strg+h)

Anstatt Rest(n;2) kann auch =istgerade(n) verwendet werden.

1

Was möchtest Du wissen?