Median mit mehreren Bedingungen statt Mittelwert?

... komplette Frage anzeigen

2 Antworten

SO ist die Formel für den Mittelwert schon mal falsch. Du meinst sicherlich:

=MITTELWERTWENNS(D2:D185; A2:A185; "<14"; B2:B185; "weiblich")

Für den entsprechenden Median finde ich jetzt leider nur eine Lösung mit Hilfsspalte.
Also in eine Hilfsspalte (z.B. Spalte F, ab F2) die Formel:

=WENN(UND(A2<14;B2="weiblich");D2)

und runterkopieren.
Dann für den Median:

=MEDIAN(F2:F185)

Ich grübel nochmal über eine Lösung ohne Hilfsspalte, kann aber nichts versprechen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von schmiddi1967
20.11.2016, 18:12

Diese Matrixformel sollte das gewünschte Ergebnis bringen.

=MEDIAN(WENN((A2:A185<14)*(B2:B185="weiblich");D2:D185;""))

Achtung Matrixfrormel mit STRG+SHIFT+ENTER (gleichzeitig) abshliessen.

5
Kommentar von 2009Jasmin
20.11.2016, 18:45

Vielen Dank für die Antwort! Es hat super geklappt!

0
Kommentar von schmiddi1967
20.11.2016, 18:50

Bitte gerne, Hauptsache wir konnten dir helfen 😂

0
Kommentar von schmiddi1967
20.11.2016, 20:04

Danke, ich bin auch eher durch Zufall drauf gekommen 😂

2

ich hab auch was ausgebrütet, aber ich bin wohl auf einem Straussenei gesessen, jedenfalls ist meine Formel viiieel größer geworden ; - (

ebenfalls Matrixformel:

  • {=(INDEX(A:A;KGRÖSSTE(((B$5:B$33&D$5:D$33)="14"&"W")*ZEILE(B$5:B$33);AUFRUNDEN((SUMMENPRODUKT(((B$5:B$33&D$5:D$33)="14"&"w")*1)-1)/2+1;0)))
  • +INDEX(A:A;KGRÖSSTE(((B$5:B$33&D$5:D$33)="14"&"W")*ZEILE(B$5:B$33);ABRUNDEN((SUMMENPRODUKT(((B$5:B$33&D$5:D$33)="14"&"w")*1)-1)/2+1;0))))/2}

Ich schreib sie trotzdem als AW hier, damit es eine Hilfreichste geben kann (leider kann die hier nicht Schmiddi bekommen, weil Kommentar, obwohl er sie verdient hätte! DH!)

Auf die Idee, Median() die Matrixarbeit übernehmen zu lassen, bin ich nicht gekommen, ich hab die Formel grundlegend funktional neu aufgebaut (leicht abweichend mit ="14" und "w" statt weiblich, beides noch als Direkteingabe, sowie nur Bereich Zeile5..33, aber das ließe sich ja alles anpassen, auch wenn man es ohnehin jetzt nicht mehr braucht...

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von schmiddi1967
20.11.2016, 20:31

Danke Iamiam,

mir geht es eher darum das dem FS geholfen wird als um die HA.

Den Expertenstatus verliere ich sowieso, war leider zu lange nicht aktiv :((

0

Was möchtest Du wissen?