Excel: Text in Zelle mit "Wenn" Funktion durchsuchen

...komplette Frage anzeigen

2 Antworten

Du kannst dafür die FINDEN Funktion verwenden. Wenn das gesuchte Worte nicht gefunden wird, gibt Excel eine Fehlermeldung zurück. Deine Gesamtformel könnte dann so aussehen:

=WENN(ISTFEHLER(FINDEN("ist";A1));"Schade";"Freut mich")

Danke für die Hilfe :)

0
@DeeDee07

Finden unterscheidet GROSS/klein. Suchen nimmt eins fürs andere, findet also auch Ist am Satzanfang oder Istrien.

1

mit sog. Wildcards kann man sogar noch näher eingrenzen:

=VERGLEICH("*ist*";A1;0) liefert 1, (nämlich die erste gleich einzige Zelle von A1), wenn ..ist.. im Wort vorhanden (* steht für beliebig viele -auch gar kein- Zeichen).
Also bei Mist, Histidin(eine Aminosäure), überlisten, Christi Geburt, Istrien, ist.

=VERGLEICH("*ist";A1;0) liefert nur dann 1, wenn ...ist am Wort/Satzende(Dentist, ..bist, ist)
und

=VERGLEICH("*ist??";A1;0) liefert 1, wenn nach dem ist noch genau 2 Zeichen folgen, zB bei Listen, Mister, Distel, oder auch ..ist 1 (Leerzeichen & 1 nach ist)

Wird das nicht gefunden, wird #NV zurückgegeben.

Gibt man als Bereich nicht A1, sondern A9:A99 an, wird die Nummer der ersten Zelle, in der "ist" gefunden wird, zurückgegeben: wäre das zB A15, erscheint 7 (7.Zelle in A9:A99)

Finden bezieht sich dagegen immer nur auf EINE Zelle (Ausnahme: Matrixformeln, da ist es zwar auch so, wird aber durch die Zahl der Matrixzellen erweitert)

Was möchtest Du wissen?