Excel: Summewenns mit mehreren Kriterien pro Kriterienbereich?

...komplette Frage anzeigen Fleisch und Gemüse - (Microsoft, Excel, SUMMEWENNS)

4 Antworten

Addiere die Gemüsesumme zur Fleischsumme:

=SUMMEWENNS(C2:C11;A2:A11;"Norden";B2:B11;"Gemüse")+SUMMEWENNS(C2:C11;A2:A11;"Norden";B2:B11;"Fleisch")

Alternative:

=SUMMENPRODUKT((A2:A11="Norden")*((B2:B11="Gemüse")+(B2:B11="Fleisch"))*C2:C11)
Suboptimierer 05.05.2016, 10:00

Hast du noch mehr Oder-Kriterien, kannst du eine Vergleichsfunktion nutzen und die Oder-Begriffe in einem Vektor staffeln: 

=SUMMENPRODUKT((A2:A11="Norden")*(NICHT(ISTNV(VERGLEICH(B2:B11;{"Fleisch";"Gemüse";"…"};0))))*C2:C11)
2

wieso nicht einfach die Zellen zusammen rechnen anstatt mit if klauseln? Wird das von dir so verlangt oder willst du die Sache vereinfachen?

Carbon69 05.05.2016, 09:06

Das Problem ist ich hab normalerweise eine Tabelle mit 400 Zeilen. Die kann ich aus Datenschutzgründen natürlich nicht hochladen.

0

Für SUMMENPRODUKT kann man auch

{=SUMME((B2:B11="Norden")*((C2:C11="Gemüse")+(C2:C11="Fleisch"))*D2:D11)}

schreiben.

Achtung:

Dies ist eine Matrixformel und muss daher mit Strg+Umschalttaste+Enter abgeschlossen werden!!!

Also { und } nicht normal eingeben!

Was möchtest Du wissen?