Excel: rechnen mit Zellen, die Zahlen und Text enthalten?

5 Antworten

Hallo,

hier die Formel für B1, die auch andere Vorzeichen berücksichtigen würde (z. B. eventuell das ">"-Zeichen).

=WENN(ISTZAHL(A1);A1*0,001;LINKS(A1;1)&WENN(ISTTEXT(A1);ERSETZEN(A1;1;1;"")*0,001;""))

Die Formel aus B1 nach unten kopieren.

Die "*0,001" könntest Du auf eine Zelle beziehen, z. B. $C$1 (Vorteil hierdrin ist, falls wenn sich der Multiplikator ändern sollte, die Formel nicht abgeändert werden muß.

Die Werte aus den Formeln können aber leider nicht summiert werden, da im Anschluss der Berechnung der Textwert wieder greift. Dies gilt auch bei bereits sehr guten unterbreiteten Vorschlägen.

Dies ginge nur mit einer benutzerdefinierten Formatierung, die Du aber auschließt, oder Du verwendest für die Vorzeichen eine Zusatzspalte.Für beide Fälle wäre die Formel nicht mehr erforderlich (außer die Berechnung *0,001).

Gruß Tron

Die Information in der Zelle ist nicht atomar. Ich würde Das Vergleichssymbol in eine Spalte links neben die Zahl extrahieren.

Und wie geht das?

0
@ma428967123uh

Du fügst links davon zwei Hilfsspalten ein. In die linke schreibst du 

=WENN(NICHT(ISTZAHL(LINKS(...;1));LINKS(...;1);"")

Daneben

=WENN([Spalte mit "<"]<>"";RECHTS(...;LÄNGE(...)-1);...)

Die Mischmaschspalte, in der Formel durch ... dargestellt, kannst du dann ausblenden.

Oder probier mal die Spalte mit "Daten → Text in Spalten" zu splitten.

2

Meinst Du das ungefähr so wie in meinem Screenshot?
Die Formel in Spalte C würde dann so lauten:
=WENN(LINKS(A1;1)="<";"< " &RECHTS(A1;LÄNGE(A1)-1)*B1;A1*B1)

 - (Computer, Excel, Microsoft Office)

Excel Zellen aus verschiedenen Tabellen addieren

Hi ich hab keine Ahnung von excel drum bitte ich um möglichst 'einfache' Antworten :-) ich möchte verschiedene Zellen aus zwei verschiedenen tabellenblättern addieren und sie in Blatt 3 dann 'zusammen rechnen' also dort in einer Zelle das Ergebnis darstellen. Habe in Google leider nur etwas zu 'gleichen Zellen aus verschiedenen Tabellen' gefunden. Bei mir sind die Zellen aber an unterschiedlichen Stellen.. Bitte um Hilfe !!

...zur Frage

Anzahl der gefärbten Zellen anzeigen lassen?

Hey. Habe bei excel eine Tabelle angefertigt. Habe nun einen Teil der zellen rot und den anderen blau gefärbt. Gibt es irgendwie eine Formel, mit der sich die Anzahl der Rot gefärbten Zellen anzeigen lässt? :) Danke im Voraus und LG

...zur Frage

Excel Summe mit Buchstaben und Zahlen in einer Zelle

Hallo,

ich habe eine Excel Tabelle in deren Zellen sich Zahlen und Buchstaben befinden. z.B A1=2x B1=3y C1=4x D1=1y

Nun will ich in einer Zelle alle x-Werte zusammenrechnen und in einer anderen Zelle alle y-Werte es soll also rauskommen z.B E1=6x und F1=4y

Ich hoffe ihr könnt mir helfen, vielen Dank schonmal!

...zur Frage

Frage zu Diagrammen in Excel 365?

Ich hätte drei Fragen zu Excel (Microsoft Office 365):

  1. Die Markierungen an der y-Achse stehen in meinem Fall für z.B. Sehr gut, gut, befriedigend, usw.. Ich würde es gerne so haben, das man diese auch an der y-Achse lesen kann, also anstatt der 1, ein "Sehr gut". Und da wäre die Frage was der leichteste Weg wäre, sodass sich dies auch richtig skaliert, falls man das Diagramm größer bzw. kleiner macht.
  2. Ist es möglich den Graphen/die Linie, je nach y-Wert unterschiedlich farbig zu machen, wenn er zum Beispiel zwischen 1 und 2 ist, dass er dann grün ist, und zwischen 2 und 3, dass er gelb ist. Gibt es dafür eine Möglichkeit?
  3. Ist es möglich, einen senkrechten Strich zu haben, wenn ein Tag vorbei ist? Sodass man leichter erkennen kann, welche Werte zu welchem Tag gehören?

Vielen Dank für eure Hilfe

...zur Frage

Hallo, wenn ich in Zelle A1, A2 usw. irgendein Zeichen eingebe, soll in der Zelle daneben (B1, B2 usw.) das Datum und wieder eine daneben die Uhrzeit einfügen?

...zur Frage

EXCEL Werte in Zellen hintereinander setzen, Formel?

Hallo,

ich habe in excel Zahlen berechnen lassen, diese stehen aber in zwei Zellen.

Also angenommen Zelle A1 steht "33" und Zelle B1 steht "44".

Welcge Formel muss ich anwenden, damit ich automatischin Zelle C1 "3344" angezeigt bekomme, also einfach die zahlen hintereinander gesetzt?

Danke für eure Hilfe!

...zur Frage

Was möchtest Du wissen?