Excel: rechnen mit Zellen, die Zahlen und Text enthalten?

...komplette Frage anzeigen

5 Antworten

Die Information in der Zelle ist nicht atomar. Ich würde Das Vergleichssymbol in eine Spalte links neben die Zahl extrahieren.

ma428967123uh 17.07.2017, 14:31

Und wie geht das?

0
Suboptimierer 17.07.2017, 14:34
@ma428967123uh

Du fügst links davon zwei Hilfsspalten ein. In die linke schreibst du 

=WENN(NICHT(ISTZAHL(LINKS(...;1));LINKS(...;1);"")

Daneben

=WENN([Spalte mit "<"]<>"";RECHTS(...;LÄNGE(...)-1);...)

Die Mischmaschspalte, in der Formel durch ... dargestellt, kannst du dann ausblenden.

Oder probier mal die Spalte mit "Daten → Text in Spalten" zu splitten.

2

Hallo,

hier die Formel für B1, die auch andere Vorzeichen berücksichtigen würde (z. B. eventuell das ">"-Zeichen).

=WENN(ISTZAHL(A1);A1*0,001;LINKS(A1;1)&WENN(ISTTEXT(A1);ERSETZEN(A1;1;1;"")*0,001;""))

Die Formel aus B1 nach unten kopieren.

Die "*0,001" könntest Du auf eine Zelle beziehen, z. B. $C$1 (Vorteil hierdrin ist, falls wenn sich der Multiplikator ändern sollte, die Formel nicht abgeändert werden muß.

Die Werte aus den Formeln können aber leider nicht summiert werden, da im Anschluss der Berechnung der Textwert wieder greift. Dies gilt auch bei bereits sehr guten unterbreiteten Vorschlägen.

Dies ginge nur mit einer benutzerdefinierten Formatierung, die Du aber auschließt, oder Du verwendest für die Vorzeichen eine Zusatzspalte.Für beide Fälle wäre die Formel nicht mehr erforderlich (außer die Berechnung *0,001).

Gruß Tron

Immer das gleiche Zeichen?

Dann:

="<"&WECHSELN(A1;"<";"")*0,001

Klappt es?

Meinst Du das ungefähr so wie in meinem Screenshot?
Die Formel in Spalte C würde dann so lauten:
=WENN(LINKS(A1;1)="<";"< " &RECHTS(A1;LÄNGE(A1)-1)*B1;A1*B1)

 - (Computer, Excel, Microsoft Office)

Excel ist "dumm" ,wie Suboptimierer schon Kommentiert hat, mach das Zeichen in ein extra feld

ma428967123uh 17.07.2017, 14:34

Dann brauch ich dafür eine Formel. Ich tippe die Tabellen nicht selbst sondern bekomme sie in dem Format. Hunderte Zellen manuell zu trennen kommt nicht in Frage?

0
Salua1993 17.07.2017, 14:38

ist dieses Zeichen denn wichtig? also könntest du es nicht rausnehmen? und später wieder einfügen?

0

Was möchtest Du wissen?