Excel 2010 min und max bei Datum wenn zelle leer Datum 1900

4 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Das ganze funktioniert mit LibreOffice Calc. Sollte mit Excel eigentlich genau gleich sein:

=WENN(A1;A1;"")

Heißt soviel wie: Wenn Zelle A1 einen Wert hat, soll er diesen anzeigen, wenn nicht zeigt er den Inhalt von " " (nichts) an.

Kann ich das irgendwie mit dem summenwert von min und max verbinden? da ich bei eingefügten Zeilen den Bereichsbezug nicht verlieren will.

Falls das nicht geht wie sieht die Formelt dann mit dem Summenbezug von min und max zusammen aus.

0
@skyerjoe
=WENN(MAX(A1:A4);MAX(A1:A4);"")

Der zieht den Maximalwert aus dem Bereich A1 bis A4 und zeigt den höchsten an, wenn es keine Werte gibt, zeigt er nichts.

0
@skyerjoe

Danke für die Rückmeldung. - Freut mich, dass es klappt.

0

ich verstehe zwar nicht, warum die Formel von Oubyi nicht klappt (auch bei mir nicht!), aber so bekommst Du das kleinste Datum auch ohne Matrixformel:
=KGRÖSSTE(A:A;ANZAHL(A:A))

Texte und Leerzellen werden dabei ignoriert, allerdings darf in A:A kein #Bezug! oder sonstiger Fehler auftauchen.
Sind in A:A weitere kleine Zahlen. muss Anzahl mit -deren Anzahl korrigiert werden.(besser sowas vermeiden).
Selbstverständlich kannst Du auch zB A15:A77 als Adresse verwenden. Gehts damit?

übrigens gehen (nach einem ersten Misserfolg) auch

=KKLEINSTE(A:A;ZÄHLENWENN(A:A;"=0")+1)
=KKLEINSTE(A:A;ZÄHLENWENN(A:A;"""")+1)
=KKLEINSTE(A:A;ZÄHLENWENN(A:A;"=""")+1)
=KKLEINSTE(A:A;ZÄHLENWENN(A:A;"<1")+1) (< was ich empfehle, da so auch Texte ausgeschlossen werden!)

nicht dagegen:
=KKLEINSTE(A:A;ZÄHLENWENN(A:A;"=")+1)
und
=KKLEINSTE(A:A;ZÄHLENWENN(A:A;"")+1)
Letztere liefern falsche Zahlen. obwohl die Syntax in anderen Zusammenhängen schon funktioniert hat. Aber die Syntax vin Zählenwenn ist in ihren Feinheiten ohnehin etwas kryptisch, ich probiere da immer alles erst aus!

0

Was steht in der Spalte? Sind das Datumsangaben? Ich kann es nicht nachvollziehen.

Was möchtest Du wissen?