Wie kann ich, wenn bestimmter Wert überschritten dann x in in nächste Spalte eintragen?

...komplette Frage anzeigen

6 Antworten

Das kannst du hiermit sehr leicht erreicht

=WIEDERHOLEN("x";A1/20)

wenn die Zahl in A1 steht

Jackie251 30.11.2016, 11:57

oh sehe grad an deinen Kommentaren das du etwas ganze anderes meintest als das wie ich deine Frage verstanden hatte.
Sorry

0
Jackie251 30.11.2016, 12:02
@Jackie251

update

versuche es damit wenn A1 und A2 die ersten beiden Zahlen der Liste sind

=WENN(GANZZAHL(A2/20)>GANZZAHL(A1/20);"x";"")
2
augsburgchris 30.11.2016, 12:05
@Jackie251

50 Daumen hoch. Danke. Passt perfekt. Wusste doch es geht einfach. Heute ist nicht mein Tag.

0
augsburgchris 30.11.2016, 11:58

Noch nicht ganz. Ok, so bekomme ich ein x in alle Zellen grösser 20 und 2x in in alle grösser 40 usw. 

Aber ich will hier jeweils nur das erste vorkommen angezeigt haben. 

Ansatz aber soweit schon mal super. 


1

Ich habe mich jetzt mal - auf die Schnelle - nur an Deinem Screenshot orientiert und mich nicht durch die Antworten gearbeitet:

Wie wäre es mit dieser Formel in B2! und runterkopieren:

=WENN(A2>((ZÄHLENWENN($B$1:B1;"x")+1)*20);"x";"")

Sieht zumindest in meinem Test so aus wie Dein Beispiel.

Noch ein Vorschlag:

=WENN(REST(A1;20)=0;"X";"")

Gruß aus Berlin

augsburgchris 30.11.2016, 12:48

Funktioniert aber leider nur wenn die 20 enthalten ist. Wenn der erste Wert über 20 die 23 ist klappt es leider nicht mehr. Aber trotzdem Danke. Gute Verkürzung für diesen Fall.

0
Britzcontrol 30.11.2016, 13:34
@augsburgchris

Das war aber in der Frage nicht zu erkennen:
"... eine Liste von 1 bis 100..."

Gruß aus Berlin

1

erster Wert über 20, erstere Wert über 40, erster Wert über 60 und erster Wert über 80.

So sollte das ganze aussehen - (Excel, Office)
Jackie251 30.11.2016, 12:04

hier nochmal damit es nicht untergeht

=WENN(GANZZAHL(A2/20)>GANZZAHL(A1/20);"x";"")

sollte das Problem lösen

1
Jackie251 30.11.2016, 12:06
@Jackie251

Oh die 100 soll kein x erhalten?
Dann muss noch eine Undbedingung dazu
also

=WENN(Und(A2<100;GANZZAHL(A2/20)>GANZZAHL(A1/20));"x";"")
1
Oubyi 30.11.2016, 15:14

20 ist aber nicht "erster Wert über 20,"
Ansonsten siehe meine Antwort.

0

in die Zelle, in der das X stehen soll =WENN(<vorherige Zelle> > 20; "X"; "")

Das kannst du dann auf alle anderen Zellen weiterziehn.

augsburgchris 30.11.2016, 11:36

nein kann ich nicht, weil dann jeder Wert über 20 markiert wird. ich will aber nur die erste Zeile die über 20 ist markiert haben. respektive das selbe mit 40, 60, 80

0
augsburgchris 30.11.2016, 11:41
@valvaris

Wie meinst du das? Deine Formel ist lediglich eine Wennformel die jeden Wert über 20 markiert. Ich benötige aber die Markierung nur in der ersten Zeile über 20 und dann wieder wenn die 40 erreicht ist.

0
augsburgchris 30.11.2016, 11:47
@augsburgchris

Für einen Wert ist es unkompliziert: 

=WENN(SUMME($B$2:B2)=20;"";WENN(A2>20;20;""))

Bekomm ich die 40, 60 und 80 eventuell über eine  Arrayformel rein?

0
valvaris 30.11.2016, 11:51
@augsburgchris

=WENN(SUMME($B$2:B2)=20;"";WENN(A2>40;40;""))
Musst natürlich A2 durch die anderen Zelen ersetzen, was Excel automatisch macht, wenn du die Formel von einer Zelle in die nächste ziehst.

0
augsburgchris 30.11.2016, 11:56
@valvaris

Dann ist die Summe 20 im benutzten Bereich von B doch schon lange erreicht. Dann steht ja wieder in jeder Zelle gösser als 40 eine 40 drin. 

0
valvaris 30.11.2016, 11:58
@augsburgchris

Ach du willst bei 40 2x X drin haben und bei 60 3x  etc ?

Dann ist die Antwort von Jackie die passende für dich.

0
valvaris 30.11.2016, 12:02
@augsburgchris

Ne Arrayformel gibts leider nicht, du kannst nur diese ganzen WENN-Formeln hintereinander setzen.

0
augsburgchris 30.11.2016, 12:03
@valvaris

Dann schreib ich mir glaub ich schnell ein Makro. Das ist hier praktikabler.

0
valvaris 30.11.2016, 12:08
@augsburgchris

Alles klar, wenn du die Möglichkeit hast, ist das die schönere Variante

0
augsburgchris 30.11.2016, 12:15
@valvaris

Naja, ich versuche VBA soweit es geht zu vermeiden, wenn es mit Formeln geht. Aber die Lösung von Jackie ist perfekt.

0

Was möchtest Du wissen?