Wie erstelle ich Hyperlinks auf Tabellenblätter automatisch? (Formel in Hyperlinkadresse?)

 - (Excel, Formel, Hyperlink)

2 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Du sagst, es klappt nicht, zeigst aber in Deinem Screenshot, dass es sehr wohl klappt (so wie auch in MEINEM).
Was ist da nicht richtig?
Bei einem Makro könnte ich Dir vielleicht auch helfen, aber WARUM?
Und: 400 Tabellenblätter sind nicht wirklich "toll".
Das müsste sich anders lösen lassen. Aber das musst Du wissen, manchmal geht es vielleicht wirklich nicht anders.

 - (Excel, Formel, Hyperlink)

das problem war es, dass die Hyperlinks sich automatisch erstellen. dieser tip ist übrigens aus herpers.de

0
@flashlights90

Welcher Tip?
Und die Formel erstellt doch automatisch die Hyperlinks.
Oder möchtest Du, dass in Spalte D alle Tabellen der Datei automatisch angezeigt werden?
Dazu fügst Du diesen Code in ein allgemeines Modul ein:
Sub Blätter()
Dim Zelle As Range
Dim I As Integer
Set Zelle = Range("D1")
For I = 1 To Worksheets.Count
Zelle.Offset(I - 1, 0).Value = Sheets(I).Name
Next I
End Sub
Hilft Dir das?

0
@Oubyi

Da habe ich mir die Arbeit wohl mal wieder umsonst gemacht.
Schade!

0

Kann ich mit Makros arbeiten? Ich bin in diesem Feld allerdings totaler Anfänger! Es sollen etwa 400 Links auf gleichviele Tabellenblätter verbinden.

Wie kann ich Daten einer Ecxeldatei in der Ordnung A1, B1......Z1 (also erste Zeile) zu in eine SPalte ziehen B1 wird A2, C1 wird A3?

...zur Frage

Kann Excel verschiede "Werte" angeben?

Hallo, ich habe ein Problem mit Excel: Ich will bei einem Schulprojekt etwas mit Stunden angeben, wobei Excel bei einer Stunde automatisch mit "1 Stunde" und bei zwei oder mehr Stunden automatisch mit "[Zahl] Stunden" antwortet. Ich bin auf Folgende Formel gekommen: =WENN(A1=1; A1 Stunde; A1 Stunden) bzw. =WENN(A1>1; A1 Stunden; A1 Stunde). Excel sagt dann aber #NAME, obwohl ich eigentlich keinen Fehler sehe. Meine einzige Erklärung wäre, dass Excel mit dem "A1 Stunde; A1 Stunden" nicht klar kommt, obwohl diese Werte aber theoretisch Sinn machen würden.

Weiß irgendjemand, wie man dieses Problem lösen/umgehen kann?

...zur Frage

WENN- Funktion für ganze Spalte

Hallo,

ich möchte, dass eine WENN Funktion automatisch auf eine ganze Spalte angewendet wird und die Summe gebildet wird.

Bsp: C1=WENN(UND(ODER(Tabelle1!A1=56;Tabelle1!A1=89;Tabelle1!A1=78);Tabelle1!B1=375735);Tabelle1!J1;0)

Ich möchte nun, dass, das nun auf die ganze Spalte angwand wird (also aus A1 wird A2 aus B1 B2 und aus J1 J2) ohne die Formel ewig runterziehen zu müssen (es geht ungefähr bis A1500) und in C1(in der anderen Tabelle die Summe erscheint (also von allen J werten wo DANN eintrit)

Vielen Dank schon jetzt für die Hilfe

...zur Frage

Wie kann ich Excel Formel Ergebnisse sortieren?

Beispiel: wir haben folgende Zellen:

A1 --> 2

B2 --> 4

A2 --> =A1+B1 (=6)

A3 --> =A1-B1 (=-2)

A4 --> =B1-A1 (=2)

A5 --> =A1*B1 (=8)

nun möchte ich in der Spalte B die Inhalte der Formelen sortieren:

d.h. in B2=8, B3=6, B4=2, B=-2.

Mit harten Werten weiß ich wie es funktioniert, aber wie funktioniert dies mit Formelergebnisse???

...zur Frage

Was möchtest Du wissen?