Wie bei Excel Zellen zusammenfassen mit gleicher Nummer davor?

... komplette Frage anzeigen

2 Antworten

Was meinst du mit zusammenfassen? Soll alles in eine Zelle? 

Als erstes solltest du die Liste sortieren. Das kannst du über Filter oder über die Sortierfunktion von Excel lösen.

In der sortierten Liste kannst du die Texte in Spalte C kumulieren.

C3: =WENN(A3<>A2;B3;C2&ZEICHEN(10)&B3)

(ungetestet)
Das ziehst du herunter. Willst du jetzt nur die zusammengefassten Texte haben, dann kannst du in Spalte D einfach auf =A4<>A3 abfragen und die Liste nach Spalte D=WAHR filtern.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von TenseikenSlash
09.11.2016, 11:58

Also ich meine: In der Zelle D3 soll der Text aus den Zellen B3, B4, B6, B8 zu einer alleine zusammengeführt werden.

So ganz verstehe ich die Formel gerade nicht, oder wie man nach D=WAHR filtert. Bin bei Formeln etwas unbeholfen.

0

Hallo,

ein bisschen kompliziert, sollte aber funktionieren:

{=WENN(ISTFEHLER(INDEX($B$2:$B$14;KGRÖSSTE(($A$2:$A$14=1)*(ZEILE($A$2:$A$14)-1);ZÄHLENWENN($A$2:$A$14;1)+1-ZEILE(A1))));"";INDEX($B$2:$B$14;KGRÖSSTE(($A$2:$A$14=1)*(ZEILE($A$2:$A$14)-1);ZÄHLENWENN($A$2:$A$14;1)+1-ZEILE(A1))))&" "&WENN(ISTFEHLER(INDEX($B$2:$B$14;KGRÖSSTE(($A$2:$A$14=1)*(ZEILE($A$2:$A$14)-1);ZÄHLENWENN($A$2:$A$14;1)+1-ZEILE(A2))));"";INDEX($B$2:$B$14;KGRÖSSTE(($A$2:$A$14=1)*(ZEILE($A$2:$A$14)-1);ZÄHLENWENN($A$2:$A$14;1)+1-ZEILE(A2))))&" "&WENN(ISTFEHLER(INDEX($B$2:$B$14;KGRÖSSTE(($A$2:$A$14=1)*(ZEILE($A$2:$A$14)-1);ZÄHLENWENN($A$2:$A$14;1)+1-ZEILE(A3))));"";INDEX($B$2:$B$14;KGRÖSSTE(($A$2:$A$14=1)*(ZEILE($A$2:$A$14)-1);ZÄHLENWENN($A$2:$A$14;1)+1-ZEILE(A3))))&" "&WENN(ISTFEHLER(INDEX($B$2:$B$14;KGRÖSSTE(($A$2:$A$14=1)*(ZEILE($A$2:$A$14)-1);ZÄHLENWENN($A$2:$A$14;1)+1-ZEILE(A4))));"";INDEX($B$2:$B$14;KGRÖSSTE(($A$2:$A$14=1)*(ZEILE($A$2:$A$14)-1);ZÄHLENWENN($A$2:$A$14;1)+1-ZEILE(A4))))}

LG, Chris

Edit: Eingabe ohne {} und mit STRG + Shift + Enter bestätigen

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?