Excel - nur Zellen mit Inhalt markieren?

4 Antworten

Es gibt die Funktion ISTLEER, mit der kannst Du das machen (mit einem entsprechenden NICHT davor). du kannst aber auch beim Addieren statt SUMME SUMMEWENN benutzen und das dabei abfragen.

ICh weiss nicht, ob ich dich richtig verstehe, aber du kannst die Felder mit Hilfe der Funktion "Bearbeiten -> Gehe zu -> Inhalte" auswählen. Dort dann z.B. Konstanten wählen. Zuvor die Spalte komplett markieren.

Markiere den ganzen Bereich.
Gehe dann auf:
Start/ Bearbeiten/ Suchen und Auswählen/ Gehe zu.../ Inhalte.../ Leerzellen (anklicken) --OK!
Dann ein Klick auf das Summenzeichen unter Bearbeiten und anschließend am besten noch Fett oder Farbig Fromatieren, damit Du die Summenzeilen erkennen kannst.

Excel VBA Frage nach Zählenwenn Abfrage -- andere Zelle automatisch farbig markieren

eigentlich ist es ein einfache Aufgabenstellung. Aber ich bekomme es mir normalen "Boardmitteln" in Excel nicht hin. Daher eine Frage an die Excel VBA Profis.

In einer Spalte B werden Zahlen untereinander (bis zu 100 Zeilen) eingegeben. In der Spalte A wird eine Zählenwenn Abfrage gestartet, die für die 100 Zeilen in der Spalte B anzeigt, wieviel mal eine Zahl in Spalte B vorkommt. Für jedes Ergebnis der Zählenwenn Abfrage in Spalte A soll die entsprechende Zelle mit einer Farbe gefärbt werden. Gleichzeitig sollen die Zellen in der Spalte C mit derselben Farbe wie in Spalte A eingefärbt werden.

Ich habe zunächst an die bedingte Formatierung gedacht, jedoch lässt diese nur 3 Varianten zu. Daher meine Frage: Ist es möglich, dieses Problemstellung mit EXCEL Vba zu realisieren?

Ich nutze excel 2003.

Ich habe noch ein Bild angehängt, wie das Ergebnis aussehen sollte.

Hoffe ihr könnt mir helfen.

...zur Frage

Formel für lückenloses Auflisten einer Spalte in Excel 2007

Hallo,

ich habe folgende Situation Excel 2007

In der Spalte FE stehen Zahlen von der Zelle FE 1062 - FE 1562 in diesem Bereich stehen etwa 30 verschiedene Zahlen. D.h es gibt viele leere Zellen dazwischen.

Um das zu verhindern, hätte ich gerne eine Formel die die Zahlen lückenlos auflistet in die Spalte IB von Zelle IB 1062 - IB 1562.

Hier ist meine Formel wie ich sie mir überlegt habe:

{=WENN(ZEILE(A1)>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE(A1))))}

Diese Formel funktioniert auch eigentlich. Aber nur wenn die Zahlen, welche sortiert werden sollen z.B in der Zelle A1 oder B1, C1.... stehen. Ich habe auch schon versucht einfach diese Formel auf die Spalte FE anzupassen, aber Excel zeigt dann nur in der Spalte IB leere Zellen an, also keine aufgelisteten Zahlen.

Kann mir jemand von euch helfen, damit die Formel richtig arbeitet ?

am besten gleich eine korrekte Formel hier reinstellen.

Gruß Danii358

...zur Frage

Was möchtest Du wissen?