Tabellen Auswertung Excel über mehrere Spalten

3 Antworten

Probier mal:

=WENNFEHLER(WENN(VERGLEICH(A2;Tabelle2!C:C;0)=VERGLEICH(B2;Tabelle2!D:D;0);INDEX(Tabelle2!E:E;VERGLEICH(A2;Tabelle2!C:C;0));"Keine Übereinstimmung");"Keine Übereinstimmung")

Diese Formel in Tabelle1 E1 eintragen und runterkopieren. Sie funktioniert, wenn in den jeweiligen Spalten keine doppelten Werte vorkommen.

Schau mal, ob ich Dich mit dieser Formel in Tabelle1!E1 (und runterkopieren) richtig verstanden habe:

{=WENNFEHLER(INDEX(Tabelle2!$F$1:$F$1000;VERGLEICH(A1&B1;Tabelle2!$C$1:$C$1000&Tabelle2!$D$1:$D$1000;0));"")}

ACHTUNG!
Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

@ Oubyi:
Geniale Idee, aber ich krieg das nicht zum laufen, auch nicht mit
{=WENNFEHLER(INDEX(Tabelle2!$F$1:$F$1000;VERGLEICH(A1&B1;Tabelle2!$C1&Tabelle2!$D1;0));"")}
in Tab1!e1 und runterkopieren. Ich schätze, dass der Operator & mit {Fo} unverträglich ist?
(oder stelle ich mich mal wieder nur zu blöd an?)

0
@Iamiam

Ich hatte meine Formel vorher getestet und habe es gerade nochmal gemacht und es funktioniertt!?
Beispiel wie in der Frage:

Tabelle 1 A5=1,2
Tabelle1 B5=AA
Tabelle 2 C9=1,2
Tabelle2 D9=AA
Tabelle2 F9=85

Formel in Tabelle E1:
={=WENNFEHLER(INDEX(Tabelle2!$F$1:$F$1000;VERGLEICH(A1&B1;Tabelle2!$C$1:$C$1000&Tabelle2!$D$1:$D$1000;0));"")
Anzeige in Tabelle1 E1:
85

Bist Du vielleicht mit den Tabellen/ Spalten durcheinander gekommen?
Das ist MIR nämlich am Anfang passiert.

0
@Oubyi

Du hast recht, ist mir ja auch in meiner Antwort passiert. (ich verwende nämlich standardmäßig nicht Tabelle, sondern das kürzere Blatt als Blattnamen bzw gemischt und bin offensichtlich darüber gestolpert.
Neu ist mir, dass jetzt die Textfunktion & mit Matrixformeln kompatibel ist, ich hätte das früher schon öfters verwenden wollen und da gings (noch?) nicht.
Also, es bleibt dabei: geniale Idee!
Meine Formel mit Hilfsspalte in Tabelle2 (ebenfalls die &Verknüpfung von C&D) brauche ich deshalb erst gar nicht mehr zu posten.

1

Formel in Tabelle1!E9:

=WENN(UND(INDEX(A$1:A$9999;VERGLEICH(Blatt1!C9;A$1:A$9999;0))=Blatt1!C9;INDEX(B$1:B$9999;VERGLEICH(Blatt1!C9;A$1:A$9999;0))=Blatt1!D9);F9;"in Tab2 nicht vorhanden")

Die Formel dann rauf- und runterkopieren.

Halt, da muss ich nochmal ran!
Die Formel meldet "...nicht vorhanden", wenn der Wert in A darüber schon mal auftaucht ohne Kombination mit Wert B!
Vllt doch Hilfsspalte notwendig?

0
@Iamiam

die Verwendung einer Hilfsspalte (mit Tabelle2!C&D) hat sich mit dem Nachvollzug von Oubyis Formel erledigt.

0

Kann excel muster in zahlen oder wörtern erkennen?

Gibt es eine möglichkeit das excel muster wie "HALLO" oder "12338" erkennt und sie so aus einer reihe zahlen denen zuordnet die auch aus 4 verschiedenen ziffern bestehen und die 3. und die 4. gleich sind?

...zur Frage

Tabellen in C# darstellen?

Hi! Ich muss für die Schule ein Programm mit zwei "for- Schleifen" schreiben, welches die ASCII Tabelle ausgibt.

Die Bedingung: Es muss eben eine Tabelle sein. Unser Lehrer gab uns den Tipp, mit 'Zeile' und 'Spalte'.

Wie würde so eine Tabellen- Darstellung in C# aussehen?(Bitte wirklich nur eine Tabelle mit zwei for- Schleifen, den Rest möchte ich selbst machen).

Als Beispiel wie meins bis jetzt aussieht:

for (int Zeile = 0; Zeile < 8; Zeile++)

 { Console.Write("\n"); for (int Spalte = 0; Spalte < 64; Spalte++)

  {

 Console.Write(" " + Convert.ToChar(Zeile + 64)); Zeile++; 

 } }

...zur Frage

Wert aus Tabelle 1 mehreren Zeilen in Tabelle 2 zuordnen

Ich habe 2 Tabellen. In der ersten Tabelle ist pro Zeile ein Hauptartikel mit einer eindeutigen Artikelnummer aufgeführt. In einer weiteren Spalte der jeweiligen Zeile steht die Katalogseite, in der der Hauptartikel abgebildet ist. Die zweite Tabelle hat alle Varianten eines Hauptartikels. Das sind bis zu 50 Zeilen pro Hauptartikel. Jede Variante hat auch in einer Spalte die Hauptartikelnummer, somit besteht ein eindeutiger Idex zwischen den beiden Tabellen. Jedoch fehlt in der Variantentabelle die Spalte Katalogseite. Wie kann ich die Variantentabelle mit der Katalogseiten des jeweiligen Hauptartikels füllen? Nur zur Verdeutlichung: Tabelle 1, mit einem Hauptartikel pro Zeile hat 650 Zeilen. Tabelle 2 Variantenartikeln, hat 22.000 Zeilen aber auch nur 650 Hauptartikel!

...zur Frage

Excel / Google Tabellen Datum der letzten Änderung in Zeile und Spalte?

Hallo,

ich habe eine Tabelle erstellt (siehe Bild), in der Spieler ihre Werte ein tragen müssen. Dies geschieht in den Spalten B bis U, in Spalte V soll Excel dann automatisch das Datum der Änderung eintragen. Wie kann ich das umsetzten, ich such mir schon den halben Tag die Finger und Augen wund aber gefunden habe ich leider noch nix.

Beispiel: Spieler aus Zeile 34 ändert heute seine Werte aus den Spalten B bis U dann soll in Spalte V Zeile 34 > 18.10.16 )stehen. Spieler aus Zeile 24 hat gestern seine Werte geändert (Spalten B bis U) dann soll in Spalte V Zeile 24 > 17.10.16 )stehen.

Zusätzlich wäre nett, wenn das Datum rot eingefärbt würde, wenn die letzte Änderung länger als 2 Tage her ist.

Habt ihr Ideen?

Ich sag schonmal Danke

...zur Frage

MySQL auf unterschiedliche Tabellen verweisen?

Hi :)

Ich stehe vor einem Problem: ich muss eine MySQL-Tabelle erstellen, welche eine Spalte besitzt, die Verweise auf andere Tabellen enthält. Nun kenne ich bereits im Groben die Funktionsweise von Fremdschlüsseln: ein Wert in einer bestimmten Spalte einer Haupttabelle verweist auf eine Zeile einer anderen Tabelle. Nun brauche ich allerdings eine Lösung, bei der sich die Fremdschlüssel (in einer Spalte) nicht nur auf EINE andere Tabelle beziehen, sondern auf verschiedene. Beispiel: die Tabelle "Main" enthält eine Spalte "Erweiterung" ... und dies enthält Verweise auf unterschiedliche andere Tabellen mit welchern anschließend gearbeitet werden soll. So enthält die erste Zeile beispielsweise ein "A", was sich auf die Tabelle "A" bezieht. Die zweite Zeile enthält ein "B", welches sich auf die Tabelle "B" bezieht ... allerdings haben A und B unterschiedliche Spalten.

Gibt es eine Möglichkeit mit der ich die Inhalte der Haupttabelle mit der "Erweiterung" A und den Inhalten von A/der Erweiterung B und den Inhalten von B kombinieren kann? Also im Prinzip: eine dynamische ERweiterung von Spalten, je nach Wert von "Erweiterung". Ich hatte schon den Ansatz für jede "Erweiterung" eine neu Tabelle anzulegen und diese dann auszulesen, aber wie ich das anstelle weiß ich auch nicht.

Ich hoffe ihr könnt damit was anfangen xD ... Danke im Voraus :)

...zur Frage

Microsoft Office Paket günstig oder kostenlos ?

Hallo Leute kann mir jemand sagen wo ich möglichst günstig oder kostenlos eine Office Paket bekomme brauche das für die schule Würde mich über SINNVOLLE antworten freuen

...zur Frage

Was möchtest Du wissen?